]> git.pld-linux.org Git - packages/rtl8812au.git/commitdiff
- updated to 4.3.2_11100.20140411 auto/th/rtl8812au-4.3.2_11100.20140411-0.20140901.1
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Sep 2014 22:02:09 +0000 (00:02 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 1 Sep 2014 22:02:09 +0000 (00:02 +0200)
Yes, github is a better place to find a working, up to date
driver than vendors. Or even Realtek. Go figure.

BTW this driver gives me ~25MB/s on 802.11ac

disable-CONFIG_IOCTL_CFG80211.patch [deleted file]
linux-3.11.patch [new file with mode: 0644]
rtl8812au.spec
usb-ids.patch [deleted file]

diff --git a/disable-CONFIG_IOCTL_CFG80211.patch b/disable-CONFIG_IOCTL_CFG80211.patch
deleted file mode 100644 (file)
index 39b4cfb..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- rtl8812AU_8821AU_linux/include/autoconf.h  2014-08-27 23:33:57.409940321 +0200
-+++ rtl8812au/include/autoconf.h       2014-08-27 21:42:42.000000000 +0200
-@@ -40,7 +40,7 @@
- #define PLATFORM_LINUX        1
--#define CONFIG_IOCTL_CFG80211 1
-+//#define CONFIG_IOCTL_CFG80211 1
- #ifdef CONFIG_PLATFORM_ARM_SUNxI
-       #ifndef CONFIG_IOCTL_CFG80211 
diff --git a/linux-3.11.patch b/linux-3.11.patch
new file mode 100644 (file)
index 0000000..9fe8378
--- /dev/null
@@ -0,0 +1,16 @@
+diff --git a/os_dep/linux/os_intfs.c b/os_dep/linux/os_intfs.c
+index ca56b4c..659305f 100644
+--- a/os_dep/linux/os_intfs.c
++++ b/os_dep/linux/os_intfs.c
+@@ -660,7 +660,11 @@ u16 rtw_recv_select_queue(struct sk_buff *skb)
+ static int rtw_ndev_notifier_call(struct notifier_block * nb, unsigned long state, void *ndev)
+ {
++#if (LINUX_VERSION_CODE>=KERNEL_VERSION(3,11,0))
++      struct net_device *dev = netdev_notifier_info_to_dev(ndev);
++#else
+       struct net_device *dev = ndev;
++#endif
+ #if (LINUX_VERSION_CODE>=KERNEL_VERSION(2,6,29))
+       if (!dev->netdev_ops || dev->netdev_ops->ndo_do_ioctl != rtw_ioctl)
index b748255ff1aad36fb60b4763f87804140cc48707..6ce79a876d8cd0c1d7d454baae653503efbb37b8 100644 (file)
@@ -20,20 +20,21 @@ exit 1
 %define                bkpkg   %(echo %{_build_kernels} | tr , '\\n' | while read n ; do echo %%undefine alt_kernel ; [ -z "$n" ] || echo %%define alt_kernel $n ; echo %%build_kernel_pkg ; done)
 
 %define                rel     1
-%define                snap    20140817
+%define                snap    20140901
 %define                pname   rtl8812au
 Summary:       Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter
 Name:          %{pname}%{_alt_kernel}
-Version:       4.2.2_7502.20130517
+Version:       4.3.2_11100.20140411
 Release:       0.%{snap}.%{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL
 Group:         Base/Kernel
-URL:           http://www.realtek.com.tw/
-#Source0:      https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/v%{version}/%{name}-%{version}.tar.gz
-Source0:       https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
-# Source0-md5: 988810755bc6e687d358475861a2a6ca
-Patch0:                disable-CONFIG_IOCTL_CFG80211.patch
-Patch1:                usb-ids.patch
+#Source0:      https://github.com/abperiasamy/rtl8812AU_8821AU_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
+Source0:       https://github.com/austinmarton/rtl8812au_linux/archive/master/%{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: 693825ab344b68a1217f20ab8dd98b82
+# good luck finding this chip on Realtek website :/
+#URL:          http://www.realtek.com.tw/
+URL:           https://github.com/austinmarton/rtl8812au_linux
+Patch0:                linux-3.11.patch
 BuildRequires: rpmbuild(macros) >= 1.678
 %{?with_dist_kernel:%{expand:%kbrs}}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
@@ -76,9 +77,8 @@ Driver for AC1200 (802.11ac) Wireless Dual-Band USB Adapter\
 
 %prep
 #%setup -q -n %{pname}-%{version}
-%setup -q -n rtl8812AU_8821AU_linux-master
+%setup -q -n rtl8812au_linux-master
 %patch0 -p1
-%patch1 -p1
 
 %build
 %{expand:%bkpkg}
diff --git a/usb-ids.patch b/usb-ids.patch
deleted file mode 100644 (file)
index 3c85156..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- rtl8812AU_8821AU_linux/os_dep/linux/usb_intf.c     2014-08-27 22:10:59.813481830 +0200
-+++ rtl8812au/os_dep/linux/usb_intf.c  2014-08-27 21:42:42.410208374 +0200
-@@ -256,6 +256,7 @@
-       {USB_DEVICE(USB_VENDER_ID_REALTEK, 0x881B),.driver_info = RTL8812},/* Default ID */
-       {USB_DEVICE(USB_VENDER_ID_REALTEK, 0x881C),.driver_info = RTL8812},/* Default ID */
-       /*=== Customer ID ===*/
-+      {USB_DEVICE(0x050D, 0x1106),.driver_info = RTL8812}, /* Belkin - sercomm */
-       {USB_DEVICE(0x050D, 0x1109),.driver_info = RTL8812}, /* Belkin F9L1109 - SerComm */
-       {USB_DEVICE(0x2001, 0x330E),.driver_info = RTL8812}, /* D-Link - ALPHA */
-       {USB_DEVICE(0x7392, 0xA822),.driver_info = RTL8812}, /* Edimax - Edimax */
-@@ -268,14 +268,15 @@
-       {USB_DEVICE(0x0586, 0x3426),.driver_info = RTL8812}, /* ZyXEL - */
-       {USB_DEVICE(0x2001, 0x3313),.driver_info = RTL8812}, /* D-Link - ALPHA */
-       {USB_DEVICE(0x1058, 0x0632),.driver_info = RTL8812}, /* WD - Cybertan*/
-+      {USB_DEVICE(0x13b1, 0x003f),.driver_info = RTL8812}, /* Linksys WUSB6300 */
-       {USB_DEVICE(0x1740, 0x0100),.driver_info = RTL8812}, /* EnGenius - EnGenius */
-       {USB_DEVICE(0x2019, 0xAB30),.driver_info = RTL8812}, /* Planex - Abocom */
-       {USB_DEVICE(0x07B8, 0x8812),.driver_info = RTL8812}, /* Abocom - Abocom */
-       {USB_DEVICE(0x2001, 0x3315),.driver_info = RTL8812}, /* D-Link - Cameo */
-       {USB_DEVICE(0x2001, 0x3316),.driver_info = RTL8812}, /* D-Link - Cameo */
-       {USB_DEVICE(0x20F4, 0x805B),.driver_info = RTL8812}, /* TRENDnet - Cameo */
-       {USB_DEVICE(0x13B1, 0x003F),.driver_info = RTL8812}, /* Linksys - SerComm */
--      {USB_DEVICE(0x2357, 0x0101),.driver_info = RTL8812}, /* TP-Link - T4U */
-+      {USB_DEVICE(0x20f4, 0x805b),.driver_info = RTL8812}, /* TRENDnet - */
- #endif
- #ifdef CONFIG_RTL8821A
-@@ -285,7 +284,8 @@
-       {USB_DEVICE(USB_VENDER_ID_REALTEK, 0x8822),.driver_info = RTL8821},/* Default ID */
-       /*=== Customer ID ===*/
-       {USB_DEVICE(0x7392, 0xA811),.driver_info = RTL8821}, /* Edimax - Edimax */
--      {USB_DEVICE(0x7392, 0xA812),.driver_info = RTL8821}, /* Edimax - Edimax */
-+      {USB_DEVICE(0x7392, 0xA812),.driver_info = RTL8821}, /* Edimax - EW-7811UTC */
-+      {USB_DEVICE(0x2357, 0x0101),.driver_info = RTL8821}, /* TP-Link - Archer T4U */
-       {USB_DEVICE(0x2001, 0x3314),.driver_info = RTL8821}, /* D-Link - Cameo */
-       {USB_DEVICE(0x0846, 0x9052),.driver_info = RTL8821}, /* Netgear - A6100 */
-       {USB_DEVICE(0x0411, 0x0242),.driver_info = RTL8821}, /* BUFFALO - Edimax */
This page took 0.125966 seconds and 4 git commands to generate.