]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- updated
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Oct 2007 13:12:40 +0000 (13:12 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm-old-fileconflicts-behaviour.patch -> 1.3
    rpm-pld-autodep.patch -> 1.22

rpm-old-fileconflicts-behaviour.patch
rpm-pld-autodep.patch

index 9869de2093478dcc708af3114e965cff94c046fc..ad163a69db7f76edab0535aa838893b0b55230f8 100644 (file)
@@ -1,6 +1,6 @@
---- rpm-4.4.4/lib/poptI.c.orig 2005-11-27 13:50:16.000000000 +0000
-+++ rpm-4.4.4/lib/poptI.c      2005-12-28 02:43:01.029574304 +0000
-@@ -16,7 +16,7 @@
+--- rpm/lib/poptI.c.orig       2007-07-24 16:36:47.000000000 +0200
++++ rpm/lib/poptI.c    2007-10-02 15:11:29.213848100 +0200
+@@ -17,7 +17,7 @@
  /*@-fullinitblock@*/
  /*@unchecked@*/
  struct rpmQVKArguments_s rpmIArgs = {
@@ -9,13 +9,15 @@
  };
  /*@=fullinitblock@*/
  
-@@ -274,9 +273,6 @@
+@@ -275,10 +275,6 @@
        N_("skip files with leading component <path> "),
        N_("<path>") },
  
 - { "fileconflicts", '\0', POPT_BIT_CLR, &rpmIArgs.probFilter,
 -      (RPMPROB_FILTER_REPLACEOLDFILES | RPMPROB_FILTER_REPLACENEWFILES),
 -      N_("detect file conflicts between packages"), NULL},
-  { "force", '\0', 0, NULL, RPMCLI_POPT_FORCE,
-       N_("short hand for --replacepkgs --replacefiles"), NULL},
+-
+  { "freshen", 'F', POPT_BIT_SET, &rpmIArgs.installInterfaceFlags,
+       (INSTALL_UPGRADE|INSTALL_FRESHEN|INSTALL_INSTALL),
+       N_("upgrade package(s) if already installed"),
+
index 3723aae6cec56819313347074a18dab9a6f883e6..fc2b87a63ba6cd12a09601281abf4ea54763be44 100644 (file)
@@ -1,28 +1,25 @@
---- rpm-4.4.8/lib/rpmfc.h.orig 2005-11-18 23:08:14.231293000 +0100
-+++ rpm-4.4.8/lib/rpmfc.h      2005-11-18 23:55:16.694214392 +0100
-@@ -1,6 +1,7 @@
- #ifndef _H_RPMFC_
- #define _H_RPMFC_
+diff -ur rpm.org/configure.ac rpm/configure.ac
+--- rpm.org/configure.ac       2007-10-02 14:48:58.200734000 +0200
++++ rpm/configure.ac   2007-10-02 14:49:18.697896240 +0200
+@@ -979,6 +979,14 @@
  
-+#include <regex.h>
- #undef        FILE_RCSID
- #include "magic.h"
-@@ -44,6 +45,11 @@
-     StringBuf sb_python;/*!< concatenated list of python colored files. */
-     StringBuf sb_php;   /*!< concatenated list of php colored files. */
-+    int findprov, findreq;
-+    regex_t *noautoprov;
-+    int noautoprov_c;
-+    regex_t *noautoreq;
-+    int noautoreq_c;
- };
+ AC_MSG_HEADER([INSTALLATION PARAMETERS])
  
- /**
---- rpm-4.4.9/lib/rpmfc.c.orig 2007-05-22 08:11:41.155736775 +0200
-+++ rpm-4.4.9/lib/rpmfc.c      2007-05-22 08:23:39.964699364 +0200
-@@ -15,6 +15,8 @@
++dnl enable generating autorequires containing packages names
++dnl
++AC_ARG_ENABLE([adding-packages-names-in-autogenerated-dependancies],
++              [  --enable-adding-packages-names-in-autogenerated-dependancies   Add packages names for autogenerated dependancies to requires],
++              AC_MSG_RESULT([Using packages names in autogerated requires is enabled])
++              AC_DEFINE_UNQUOTED([AUTODEP_PKGNAMES], [1], ["Generating autorequires containing packages names."]))
++dnl
++
+ dnl # figure out what root's primary group is
+ AC_MSG_CHECKING([root's primary group])
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <stdio.h>
+diff -ur rpm.org/lib/rpmfc.c rpm/lib/rpmfc.c
+--- rpm.org/lib/rpmfc.c        2007-10-02 14:48:58.244068000 +0200
++++ rpm/lib/rpmfc.c    2007-10-02 14:52:24.222380740 +0200
+@@ -17,6 +17,8 @@
  #define       _RPMDS_INTERNAL
  #include <rpmds.h>
  #include <rpmfi.h>
@@ -31,7 +28,7 @@
  
  #include "debug.h"
  
-@@ -309,14 +311,83 @@
+@@ -311,14 +313,83 @@
      return buf;
  };
  
        /*@globals rpmGlobalMacroContext, h_errno, fileSystem, internalState @*/
        /*@modifies fc, rpmGlobalMacroContext, fileSystem, internalState @*/
  {
-@@ -402,6 +473,8 @@
+@@ -404,6 +475,8 @@
            }
  /*@=branchstate@*/
  
  
            /* Add tracking dependency for versioned Provides: */
            if (!fc->tracked && deptype == 'P' && *EVR != '\0') {
-@@ -714,7 +787,7 @@
+@@ -718,7 +791,7 @@
        *se = '\0';
        se++;
  
            /* Add to package requires. */
            ds = rpmdsSingle(RPMTAG_REQUIRENAME, s, "", RPMSENSE_FIND_REQUIRES);
            xx = rpmdsMerge(&fc->requires, ds);
-@@ -743,44 +816,52 @@
+@@ -747,49 +820,61 @@
  
      if (fc->fcolor->vals[fc->ix] & RPMFC_PERL) {
        if (strncmp(fn, "/usr/share/doc/", sizeof("/usr/share/doc/")-1)) {
 -              xx = rpmfcHelper(fc, 'P', "perl");
 -          if (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
 -              xx = rpmfcHelper(fc, 'R', "perl");
-+          if (fc->findprov && (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
++          if (fc->findprov && fc->fcolor->vals[fc->ix] & RPMFC_MODULE)
 +              xx = rpmfcHelper(fc, 'P', "perl", fc->noautoprov, fc->noautoprov_c);
-+          if (fc->findreq && (is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE)))
++          if (fc->findreq && is_executable || (fc->fcolor->vals[fc->ix] & RPMFC_MODULE))
 +              xx = rpmfcHelper(fc, 'R', "perl", fc->noautoreq, fc->noautoreq_c);
        }
      } else
        if (is_executable)
  #endif
 -          xx = rpmfcHelper(fc, 'R', "python");
-+      if (fc->findreq)
++          if (fc->findreq)
 +          xx = rpmfcHelper(fc, 'R', "python", fc->noautoreq, fc->noautoreq_c);
      } else
      if (fc->fcolor->vals[fc->ix] & RPMFC_LIBTOOL) {
        if (is_executable)
  #endif
 -          xx = rpmfcHelper(fc, 'R', "libtool");
-+      if (fc->findreq)
++          if (fc->findreq)
 +          xx = rpmfcHelper(fc, 'R', "libtool", fc->noautoreq, fc->noautoreq_c);
      } else
      if (fc->fcolor->vals[fc->ix] & RPMFC_PKGCONFIG) {
        if (is_executable)
  #endif
 -          xx = rpmfcHelper(fc, 'R', "pkgconfig");
-+      if (fc->findreq)
++          if (fc->findreq)
 +          xx = rpmfcHelper(fc, 'R', "pkgconfig", fc->noautoreq, fc->noautoreq_c);
      } else
      if (fc->fcolor->vals[fc->ix] & RPMFC_BOURNE) {
  #ifdef        NOTYET
-       xx = rpmfcHelper(fc, 'P', "executable");
+-      xx = rpmfcHelper(fc, 'P', "executable");
++      if (fc->findprov)
++      xx = rpmfcHelper(fc, 'P', "executable", fc->noautoprov, fc->noautoprov_c);
  #endif
--      if (is_executable)
+       if (is_executable)
 -          xx = rpmfcHelper(fc, 'R', "executable");
-+      if (fc->findreq && is_executable)
++          if (fc->findreq)
 +          xx = rpmfcHelper(fc, 'R', "executable", fc->noautoreq, fc->noautoreq_c);
      } else
      if (fc->fcolor->vals[fc->ix] & RPMFC_PHP) {
 +      xx = rpmfcHelper(fc, 'P', "php", fc->noautoprov, fc->noautoprov_c);
        /* not only executable, files run by httpd usually are not */
 -          xx = rpmfcHelper(fc, 'R', "php");
-+      if (fc->findreq)
++          if (fc->findreq)
 +          xx = rpmfcHelper(fc, 'R', "php", fc->noautoreq, fc->noautoreq_c);
+     } else
+     if (fc->fcolor->vals[fc->ix] & RPMFC_MONO) {
+-      xx = rpmfcHelper(fc, 'P', "mono");
++      if (fc->findprov)
++      xx = rpmfcHelper(fc, 'P', "mono", fc->noautoprov, fc->noautoprov_c);
+       if (is_executable)
+-          xx = rpmfcHelper(fc, 'R', "mono");
++          if (fc->findreq)
++          xx = rpmfcHelper(fc, 'R', "mono", fc->noautoreq, fc->noautoreq_c);
      }
      return 0;
-@@ -808,20 +889,26 @@
+ }
+@@ -816,20 +901,26 @@
      default:
        break;
      case RPMTAG_PROVIDENAME:
        break;
      }
      return rc;
-@@ -862,6 +949,109 @@
+@@ -870,6 +961,109 @@
      { NULL, 0 }
  };
  
  int rpmfcApply(rpmfc fc)
  {
      rpmfcApplyTbl fcat;
-@@ -880,6 +1070,26 @@
+@@ -888,6 +1082,26 @@
      int i;
      int xx;
      int skipping;
 +    rpmMessage(RPMMESS_DEBUG, _("%i _noautoprov patterns.\n"), fc->noautoprov_c);
 +    rpmMessage(RPMMESS_DEBUG, _("%i _noautoreq patterns.\n"), fc->noautoreq_c);
  
    /* Generate package and per-file dependencies. */
-     for (fc->ix = 0; fc->fn[fc->ix] != NULL; fc->ix++) {
-@@ -900,9 +1110,43 @@
/* Make sure something didn't go wrong previously! */
+ assert(fc->fn != NULL);
+@@ -911,9 +1125,43 @@
        for (fcat = rpmfcApplyTable; fcat->func != NULL; fcat++) {
            if (!(fc->fcolor->vals[fc->ix] & fcat->colormask))
                /*@innercontinue@*/ continue;
  
  /*@-boundswrite@*/
      /* Generate per-file indices into package dependencies. */
---- rpm-4.4.9/po/pl.po.orig    2007-05-22 08:11:40.947724921 +0200
-+++ rpm-4.4.9/po/pl.po 2007-05-22 08:24:24.091213990 +0200
-@@ -2937,6 +2937,86 @@
- msgid "Failed to find %s:\n"
- msgstr "Nie uda³o siê odnale¼æ %s:\n"
+diff -ur rpm.org/lib/rpmfc.c.orig rpm/lib/rpmfc.c.orig
+--- rpm.org/lib/rpmfc.c.orig   2007-09-22 22:37:16.000000000 +0200
++++ rpm/lib/rpmfc.c.orig       2007-10-02 14:48:58.244068387 +0200
+@@ -783,7 +783,7 @@
+     } else
+     if (fc->fcolor->vals[fc->ix] & RPMFC_PHP) {
+       xx = rpmfcHelper(fc, 'P', "php");
+-      if (is_executable)
++      /* not only executable, files run by httpd usually are not */
+           xx = rpmfcHelper(fc, 'R', "php");
+     } else
+     if (fc->fcolor->vals[fc->ix] & RPMFC_MONO) {
+diff -ur rpm.org/lib/rpmfc.h rpm/lib/rpmfc.h
+--- rpm.org/lib/rpmfc.h        2007-07-14 05:22:44.000000000 +0200
++++ rpm/lib/rpmfc.h    2007-10-02 14:49:18.731230377 +0200
+@@ -98,6 +98,11 @@
+     StringBuf sb_python;/*!< concatenated list of python colored files. */
+     StringBuf sb_php; /*!< concatenated list of php colored files. */
  
-+#: lib/rpmfc.c:334
-+#, c-format
-+msgid "Compilation of regular expresion '%s' (expanded from '%s') failed. Skipping it.\n"
-+msgstr "Kompilacja wyra¿enia regularnego '%s' (powsta³ego z '%s') nie powiod³a siê; pominiêto.\n"
-+
-+#: lib/rpmfc.c:395
-+#, c-format
-+msgid "%i _noautoprov patterns.\n"
-+msgstr "%i wzorców _noautoprov.\n"
-+
-+#: lib/rpmfc.c:405
-+#, c-format
-+msgid "%i _noautoreq patterns.\n"
-+msgstr "%i wzorców _noautoreq.\n"
-+
-+#: lib/rpmfc.c:459
-+#, c-format
-+msgid "Checking %c: '%s' against _noauto expr. #%i\n"
-+msgstr "Sprawdzanie %c: '%s' z wyra¿eniem _noauto #%i\n"
-+
-+#: lib/rpmfc.c:462
-+#, c-format
-+msgid "Skipping %c: '%s' as it matches _noauto expr. #%i\n"
-+msgstr "Pominiêto %c: '%s' pasuj±ce do wyra¿enia _noauto #%i\n"
-+
-+#. XXX ts created in main() should be used
-+#: lib/rpmfc.c:1173
-+msgid "Searching for required packages....\n"
-+msgstr "Poszukiwanie wymaganych pakietów...\n"
-+
-+#: lib/rpmfc.c:1197
-+#, c-format
-+msgid "#%i requires: %s,%s,%i\n"
-+msgstr "#%i wymaga: %s,%s,%i\n"
-+
-+#: lib/rpmfc.c:1199
-+#, c-format
-+msgid "skipping #%i require\n"
-+msgstr "pominiêto zale¿no¶æ #%i\n"
-+
-+#: lib/rpmfc.c:1205
-+#, c-format
-+msgid "skipping %s requirement processing (matches noautoreqdep pattern #%i)\n"
-+msgstr "pominiêto przetwarzanie zale¿no¶ci %s (pasuje do wzorca noautoreqdep #%i)\n"
-+
-+#: lib/rpmfc.c:1211
-+#, c-format
-+msgid "skipping #%i require (is file requirement)\n"
-+msgstr "pominiêto zale¿no¶æ #%i (zale¿no¶æ od pliku)\n"
-+
-+#: lib/rpmfc.c:1216
-+#, c-format
-+msgid "%s -> not found\n"
-+msgstr "%s -> nie znaleziono\n"
-+
-+#: lib/rpmfc.c:1219
-+#, c-format
-+msgid "Iterator: %p\n"
-+msgstr "Iterator: %p\n"
-+
-+#: lib/rpmfc.c:1221
-+#, c-format
-+msgid "%s -> multiple (skipping)\n"
-+msgstr "%s -> wiele (pominiêto)\n"
-+
-+#: lib/rpmfc.c:1230
-+#, c-format
-+msgid "%s -> %s (skipping)\n"
-+msgstr "%s -> %s (pominiêto)\n"
-+
-+#: lib/rpmfc.c:1295
-+#, c-format
-+msgid "skipping %s provides detection (matches noautoprovfiles pattern #%i)\n"
-+msgstr "pominiêto wykrywanie w³asno¶ci %s (pasuje do wzorca noautoprovfiles #%i)\n"
-+
-+#: lib/rpmfc.c:1306
-+#, c-format
-+msgid "skipping %s requires detection (matches noautoreqfiles pattern #%i)\n"
-+msgstr "pominiêto wykrywanie w³asno¶ci %s (pasuje do wzorca noautoreqfiles #%i)\n"
-+
- #: lib/rpmfi.c:622
- #, c-format
- msgid "%s skipped due to missingok flag\n"
---- rpm/configure.ac.orig      2004-08-22 13:02:30.000000000 +0200
-+++ rpm/configure.ac   2004-08-22 13:25:37.000000000 +0200
-@@ -971,6 +971,18 @@
- AC_SUBST(__CHGRP_RHF)
++    int findprov, findreq;
++    regex_t *noautoprov;
++    int noautoprov_c;
++    regex_t *noautoreq;
++    int noautoreq_c;
+ };
  
- dnl
-+dnl enable generating autorequires containing packages names 
-+dnl
-+AC_ARG_ENABLE([adding-packages-names-in-autogenerated-dependancies],
-+            [  --enable-adding-packages-names-in-autogenerated-dependancies   Add packages names for autogenerated dependancies to requires],
-+       
-+              AC_MSG_RESULT([Using packages names in autogerated requires is enabled])
-+              AC_DEFINE(AUTODEP_PKGNAMES, 1, "Generating autorequires containing packages names.") 
-+      
-+            )
+ /**
+--- rpm/lib/rpmfc.h.org        2007-10-02 15:05:48.028299804 +0200
++++ rpm/lib/rpmfc.h    2007-10-02 15:06:03.052024633 +0200
+@@ -67,6 +67,13 @@
+ };
+ #if defined(_RPMFC_INTERNAL)
 +
++#if defined(WITH_PCRE) && defined(HAVE_PCREPOSIX_H)
++#include <pcreposix.h>
++#else
++#include <regex.h>
++#endif
 +
-+dnl
- dnl figure out what root's primary group is
- dnl
- AC_MSG_CHECKING(root's primary group)
+ /**
+  */
+ struct rpmfc_s {
This page took 0.078048 seconds and 4 git commands to generate.