]> git.pld-linux.org Git - packages/rpm.git/commitdiff
- drop obsolete apache_config_* and nsplugin_* macros auto/ac/rpm-build-macros-1_398-1 auto/ac/rpm-build-macros-1_398-2
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 18 Oct 2007 20:54:33 +0000 (20:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    rpm.macros -> 1.398

rpm.macros

index 5ba4822a217b6fb4f2ad57a9e8945822d030350b..6611ac9ed2aa8b46852ecb97b518d328110c3004 100644 (file)
@@ -846,75 +846,6 @@ else \
        [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i group || : \
 fi;
 
-# apache_config_{install/uninstall} macros *DEPRECATED*
-# Author: Elan Ruusamäe <glen@pld-linux.org>
-#
-# You should use webapp macros instead. these are here until single piece of
-# them is gone from specs ;)
-#
-# The config is installed/removed inside trigger, this means that you can any
-# time install apache1 or apache package and the configuration file is updated.
-# if you don't need the config for various reason for specific apache, just
-# remove the symlink from apache config directory. the trigger will not put the
-# config again to that version of apache. In other words the config is linked
-# to apache config directory on first install of PACKAGE or apache.
-#
-# should be called in trigger body:
-#  %triggerin -- apache1 >= 1.3.33-2
-#  %apache_config_install -v 1
-#
-# Add package's apache config to apache config.
-#
-# Usage:
-#   %apache_config_install -v {1|2} -c %{_sysconfdir}/apache-%{name}.conf -n 99
-#
-#  -v REQUIRED: specify apache version. can be 1 or 2.
-#  -c OPTIONAL: specify full path to PACKAGE's config. Defaults to %{_sysconfdir}/apache-%{name}.conf.
-#  -n OPTIONAL: specify config "slot". defaults to 99
-#  -f OPTIONAL: force symlink creation regardless if package was upraded. useful in triggers
-#
-# Internal macros. don't use ;).
-# expands apache config dir by apache version at build time.
-%__apache_confdir() %(if [ %{1} = 1 ]; then echo /etc/apache/conf.d; elif [ %{1} = 2 ]; then echo /etc/httpd/httpd.conf; else echo >&2 Unknown apache version specified; fi)
-# expands apache service name by apache version at build time.
-%__apache_svcname() %(if [ %{1} = 1 ]; then echo apache; elif [ %{1} = 2 ]; then echo httpd; else echo >&2 Unknown apache version specified; fi)
-
-%apache_config_install(fv:c:n:) \
-%{!-v:%{error:apache_config_install: Required argument -v missing}} \
-%{?debug:set -x; echo "apache_config_install:%{-v*} %{name}-%{version}-%{release} 1:[$1]; 2:[$2]"} \
-if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ]) && [ -d %{__apache_confdir %{-v*}} ]; then\
-       ln -sf %{-c*}%{!-c:%{_sysconfdir}/apache-%{name}.conf} %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf\
-fi\
-# reload apache if the config symlink is there\
-if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then\
-       # additionally don't reload if target package (the webserver) is upgraded, as webserver is restarted anyway in %post \
-       if [ "$2" != "2" ] && [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then\
-               /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2\
-       fi\
-fi\
-%{nil}
-
-# Remove package's apache config from apache config.
-#
-# Usage:
-#   %apache_config_uninstall -v {1|2} -n 99
-#
-#  -v REQUIRED: specify apache version. can be 1 or 2.
-#  -n OPTIONAL: specify config "slot". defaults to 99
-%apache_config_uninstall(v:n:) \
-%{!-v:%{error:apache_config_uninstall: Required argument -v missing}} \
-%{?debug:set -x; echo "apache_config_uninstall:%{-v*} %{name}-%{version}-%{release}: 1:[$1]; 2:[$2]"} \
-# remove link if either of the packages are gone \
-if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
-       if [ -L %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf ]; then \
-               rm -f %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf \
-               if [ -f /var/lock/subsys/%{__apache_svcname %{-v*}} ]; then \
-                       /etc/rc.d/init.d/%{__apache_svcname %{-v*}} reload 1>&2 \
-               fi \
-       fi \
-fi \
-%{nil}
-
 # webapp macros
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
@@ -953,32 +884,6 @@ if [ -n "%{-f:1}" ] || [ "$1" = "0" ] || [ "$2" = "0" ] && [ -L /etc/%1/webapps.
 fi \
 %{nil}
 
-# see browser-plugins.spec / template-browser-plugin.spec
-# Author: Elan Ruusamäe <glen@pld-linux.org>
-%nsplugin_install(d:f) { \
-# create link if it's first install of either of the packages \
-if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{-d*} ]); then \
-( \
-%( \
-       for file in %{*}; do \
-               echo echo Installing $file to %{-d*}; \
-               echo "ln -sf %{_libdir}/browser-plugins/$file %{-d*};"; \
-       done ) \
-) | ( %banner -t 5 -e %{name}-in ); fi; \
-}
-
-%nsplugin_uninstall(d:) { \
-# remove link if either of the packages are gone \
-if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
-( \
-%( \
-       for file in %{*}; do \
-               echo echo Removing $file from %{-d*}; \
-               echo "rm -f %{-d*}/$file;"; \
-       done ) \
-) | ( %banner -t 5 -e %{name}-un ); fi; \
-}
-
 # service macro.
 # Author: Elan Ruusamäe <glen@pld-linux.org>
 #
This page took 0.051607 seconds and 4 git commands to generate.