- don't treat symlinks as executables when classyfying files for dependency extraction
[packages/rpm.git] / rpm.spec
1 #
2 # TODO:
3 # - when adopting, use 4.5 ticket for checklist: https://bugs.launchpad.net/pld-linux/+bug/262985
4 #
5 # Conditional build:
6 %bcond_without  apidocs         # don't generate documentation with doxygen
7 %bcond_without  python3         # don't build python bindings
8 %bcond_without  plugins         # build plugins
9 %bcond_without  recommends_tags # build without Recommends tag (bootstrapping)
10 %bcond_with     imaevm          # build with IMA/EVM support (requires libimaevm from ima-evm-utils)
11
12 %define         db_ver          5.3.28.0
13 %define         popt_ver        1.15
14 %define         sover           9.1.2
15
16 %if "%{_rpmversion}" >= "4.12" && "%{_rpmversion}" < "5"
17 %define with_recommends_tags    1
18 %endif
19
20 Summary:        RPM Package Manager
21 Summary(de.UTF-8):      RPM Packet-Manager
22 Summary(es.UTF-8):      Gestor de paquetes RPM
23 Summary(pl.UTF-8):      Aplikacja do zarządzania pakietami RPM
24 Summary(pt_BR.UTF-8):   Gerenciador de pacotes RPM
25 Summary(ru.UTF-8):      Менеджер пакетов от RPM
26 Summary(uk.UTF-8):      Менеджер пакетів від RPM
27 Name:           rpm
28 Version:        4.16.1.2
29 Release:        0.4
30 Epoch:          1
31 License:        GPL v2 / LGPL v2.1
32 Group:          Base
33 Source0:        http://ftp.rpm.org/releases/rpm-4.16.x/%{name}-%{version}.tar.bz2
34 # Source0-md5:  0d10f63a0a4c9517cf3808a601378399
35 Source1:        ftp://ftp.pld-linux.org/dists/th/PLD-3.0-Th-GPG-key.asc
36 # Source1-md5:  23914bb49fafe7153cee87126d966461
37 Source2:        macros.local
38 Source3:        macros.lang
39 Source4:        %{name}.sysconfig
40 Source5:        %{name}.groups
41 Source6:        %{name}-groups-po.awk
42 Source7:        %{name}-install-tree
43 Source9:        %{name}-user_group.sh
44 # http://svn.pld-linux.org/banner.sh/
45 Source10:       banner.sh
46 Source11:       %{name}.noautoprov
47 Source12:       %{name}.noautoprovfiles
48 Source13:       %{name}.noautoreq
49 Source14:       %{name}.noautoreqfiles
50 Source15:       perl.prov
51 Patch0:         %{name}-man_pl.patch
52 Patch1:         %{name}-popt-aliases.patch
53 Patch2:         %{name}-perl-macros.patch
54 Patch3:         %{name}-perl-req-perlfile.patch
55 Patch4:         %{name}-scripts-closefds.patch
56 Patch6:         %{name}-perl_req-INC_dirs.patch
57 Patch7:         %{name}-debuginfo.patch
58 Patch8:         %{name}-libtool-deps.patch
59 Patch9:         %{name}-builddir-readlink.patch
60 Patch10:        %{name}-changelog_order_check_nonfatal.patch
61 Patch11:        %{name}-postun-nofail.patch
62 Patch12:        %{name}-clean-docdir.patch
63 Patch13:        %{name}-perl-magic.patch
64 Patch14:        %{name}-ignore-missing-macro-files.patch
65 Patch15:        x32.patch
66 Patch16:        rpm5-db-compat.patch
67 Patch17:        python-internal-build.patch
68 Patch18:        missing-macros.patch
69 Patch19:        pkgconfig.patch
70 Patch20:        uname-deps.patch
71 Patch21:        aarch64.patch
72 Patch22:        ix86-platforms.patch
73 Patch23:        shortcircuited-deps.patch
74 Patch24:        cpuinfo-deps.patch
75 Patch25:        rpmio-read-proc-files.patch
76 Patch26:        allow-at-in-ver-rel.patch
77 Patch27:        no-exeonly-for-elf-reqprov.patch
78 Patch28:        default-patch-flags.patch
79 Patch29:        %{name}-noarch_py_prov.patch
80 Patch30:        missing-ghost-terminate-build.patch
81 Patch31:        missing-doc-terminate-build.patch
82 Patch32:        noexpand.patch
83 Patch33:        sqlite-db-backend.patch
84 Patch34:        skip-symlinks.patch
85 URL:            https://rpm.org/
86 BuildRequires:  acl-devel
87 BuildRequires:  db-devel >= %{db_ver}
88 BuildRequires:  autoconf >= 2.63
89 BuildRequires:  automake >= 1.4
90 BuildRequires:  bzip2-devel >= 1.0.2-17
91 BuildRequires:  elfutils-devel >= 0.108
92 BuildRequires:  gettext-tools >= 0.19.2
93 BuildRequires:  libarchive-devel
94 BuildRequires:  libcap-devel
95 BuildRequires:  libmagic-devel
96 BuildRequires:  libgcrypt-devel
97 %if %{with plugins}
98 BuildRequires:  audit-libs-devel
99 BuildRequires:  dbus-devel
100 %{?with_imaevm:BuildRequires:   libimaevm-devel >= 1.0}
101 BuildRequires:  libselinux-devel >= 2.1.0
102 %endif
103 # needed only for AM_PROG_CXX used for CXX substitution in rpm.macros
104 BuildRequires:  libstdc++-devel
105 BuildRequires:  libtool >= 1:1.4.2-9
106 BuildRequires:  patch >= 2.2
107 BuildRequires:  pkgconfig(lua) >= 5.1
108 BuildRequires:  popt-devel >= %{popt_ver}
109 BuildRequires:  python3-modules
110 %if %{with python3}
111 BuildRequires:  python3-devel
112 BuildRequires:  rpm-pythonprov
113 BuildRequires:  rpmbuild(macros) >= 1.750
114 %endif
115 BuildRequires:  sqlite3-devel >= 3.22.0
116 BuildRequires:  tcl
117 BuildRequires:  xz-devel
118 BuildRequires:  zlib-devel
119 BuildRequires:  zstd-devel
120 %if %{with apidocs}
121 BuildRequires:  doxygen
122 BuildRequires:  ghostscript
123 BuildRequires:  graphviz
124 BuildRequires:  tetex-pdftex
125 %endif
126 Requires(posttrans):    coreutils
127 Requires:       %{name}-base = %{epoch}:%{version}-%{release}
128 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
129 Requires:       rpm-pld-macros >= 1.744
130 Requires:       FHS >= 3.0-2
131 Requires:       libgcrypt
132 Requires:       popt >= %{popt_ver}
133 %if %{with recommends_tags}
134 Recommends:     rpm-plugin-audit
135 Recommends:     rpm-plugin-prioreset
136 Recommends:     rpm-plugin-syslog
137 Recommends:     rpm-plugin-systemd-inhibit
138 %endif
139 Obsoletes:      rpm-utils-perl
140 Obsoletes:      rpm-utils-static
141 Conflicts:      glibc < 2.2.92
142 # db4.6 poldek needed
143 Conflicts:      poldek < 0.21-0.20070703.00.3
144 # segfaults with lzma 0.42.2
145 Conflicts:      lzma-libs < 4.999.3
146 Conflicts:      util-vserver < 0.30.216-1.pre3034.7
147 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
148
149 %define         _binary_payload         w9.gzdio
150
151 # don't require very fresh rpm.macros to build
152 %define         find_lang sh ./scripts/find-lang.sh $RPM_BUILD_ROOT
153 %define         ix86    i386 i486 i586 i686 athlon geode pentium3 pentium4
154 %define         ppc     ppc ppc7400 ppc7450
155 %define         x8664   amd64 ia32e x86_64
156
157 %define         _rpmlibdir /usr/lib/rpm
158
159 %description
160 RPM is a powerful package manager, which can be used to build,
161 install, query, verify, update, and uninstall individual software
162 packages. A package consists of an archive of files, and package
163 information, including name, version, and description.
164
165 %description -l de.UTF-8
166 RPM ist ein kräftiger Packet-Manager, der verwendet sein kann zur
167 Installation, Anfrage, Verifizierung, Aktualisierung und
168 Uninstallation individueller Softwarepakete. Ein Paket besteht aus
169 einem Archiv Dateien und Paketinformation, inklusive Name, Version und
170 Beschreibung.
171
172 %description -l es.UTF-8
173 RPM es un poderoso administrador de paquetes, que puede ser usado para
174 construir, instalar, pesquisar, verificar, actualizar y desinstalar
175 paquetes individuales de software. Un paquete consiste en un
176 almacenaje de archivos, y información sobre el paquete, incluyendo
177 nombre, versión y descripción.
178
179 %description -l pl.UTF-8
180 RPM jest doskonałym programem zarządzającym pakietami. Umożliwia on
181 przebudowanie, instalację czy weryfikację dowolnego pakietu.
182 Informacje dotyczące każdego pakietu, takie jak jego opis, lista
183 plików wchodzących w skład pakietu, zależności od innych pakietów, są
184 przechowywane w bazie danych i można je uzyskać za pomocą opcji
185 odpytywania programu rpm.
186
187 %description -l pt_BR.UTF-8
188 RPM é um poderoso gerenciador de pacotes, que pode ser usado para
189 construir, instalar, pesquisar, verificar, atualizar e desinstalar
190 pacotes individuais de software. Um pacote consiste de um conjunto de
191 arquivos e informações adicionais, incluindo nome, versão e descrição
192 do pacote, permissões dos arquivos, etc.
193
194 %description -l ru.UTF-8
195 RPM - это мощный менеджер пакетов, который может быть использован для
196 создания, инсталляции, запросов (query), проверки, обновления и
197 удаления программных пакетов. Пакет состоит из файлового архива и
198 служебной информации, включающей название, версию, описание и другие
199 данные о пакете.
200
201 %description -l uk.UTF-8
202 RPM - це потужний менеджер пакетів, що може бути використаний для
203 створення, інсталяції, запитів (query), перевірки, поновлення та
204 видалення програмних пакетів. Пакет складається з файлового архіву та
205 службової інформації, що містить назву, версію, опис та іншу
206 інформацію про пакет.
207
208 %package base
209 Summary:        RPM base package - scripts used by rpm packages themselves
210 Summary(pl.UTF-8):      Podstawowy pakiet RPM - skrypty używane przez same pakiety rpm
211 Group:          Base
212 Requires:       filesystem
213 Obsoletes:      rpm-scripts
214 Obsoletes:      vserver-rpm
215
216 %description base
217 The RPM base package contains scripts used by rpm packages themselves.
218 These include:
219 - scripts for adding/removing groups and users needed for rpm
220   packages,
221 - banner.sh to display %%banner messages from rpm scriptlets.
222
223 %description base -l pl.UTF-8
224 Pakiet podstawowy RPM zwiera skrypty używane przez same pakiety rpm.
225 Zawiera on:
226 - skrypty dodające/usuwające grupy i użytkowników dla pakietów rpm,
227 - banner.sh do pokazywania komunikatów %%banner dla skryptletów rpm.
228
229 %package lib
230 Summary:        RPMs library
231 Summary(pl.UTF-8):      Biblioteki RPM-a
232 Group:          Libraries
233 Requires:       db >= %{db_ver}
234 Requires:       libmagic >= 1.15-2
235 Requires:       popt >= %{popt_ver}
236 Obsoletes:      rpm-libs
237 # avoid SEGV caused by mixed db versions
238 Conflicts:      poldek < 0.18.1-16
239
240 %description lib
241 RPMs library.
242
243 %description lib -l pl.UTF-8
244 Biblioteki RPM-a.
245
246 %package devel
247 Summary:        Header files for rpm libraries
248 Summary(de.UTF-8):      Header-Dateien für rpm Libraries
249 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para programas de manipulación de paquetes rpm
250 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek rpm
251 Summary(pt_BR.UTF-8):   Arquivos de inclusão e bibliotecas para programas de manipulação de pacotes RPM
252 Summary(ru.UTF-8):      Хедеры и библиотеки для программ, работающих с rpm-пакетами
253 Summary(uk.UTF-8):      Хедери та бібліотеки для програм, що працюють з пакетами rpm
254 Group:          Development/Libraries
255 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
256 Requires:       bzip2-devel
257 Requires:       db-devel >= %{db_ver}
258 Requires:       elfutils-devel
259 Requires:       libmagic-devel
260 Requires:       libgcrypt-devel
261 %if %{with selinux}
262 Requires:       libselinux-devel
263 Requires:       libsemanage-devel
264 Requires:       libsepol-devel
265 %endif
266 Requires:       popt-devel >= %{popt_ver}
267 Requires:       zlib-devel
268
269 %description devel
270 The RPM packaging system includes C libraries that make it easy to
271 manipulate RPM packages and databases. They are intended to ease the
272 creation of graphical package managers and other tools that need
273 intimate knowledge of RPM packages. This package contains header files
274 for these libraries.
275
276 %description devel -l de.UTF-8
277 Der RPM-Packensystem enthält eine C-Library, die macht es einfach
278 RPM-Pakete und Dateibanken zu manipulieren. Er eignet sich für
279 Vereinfachung des Schaffens grafischer Paket-Manager und anderer
280 Werkzeuge, die intime Kenntnis von RPM-Paketen brauchen.
281
282 %description devel -l es.UTF-8
283 El sistema de empaquetado RPM incluye una biblioteca C que vuelve
284 fácil la manipulación de paquetes y bases de datos RPM. Su objetivo es
285 facilitar la creación de administradores gráficos de paquetes y otras
286 herramientas que necesiten un conocimiento profundo de paquetes RPM.
287
288 %description devel -l pl.UTF-8
289 System RPM zawiera biblioteki C, które ułatwiają manipulowanie
290 pakietami RPM oraz bazami danych. W zamiarze ma to uprościć tworzenie
291 graficznych programów zarządzających pakietami oraz innych narzędzi,
292 które wymagają szczegółowej wiedzy na temat pakietów RPM. Ten pakiet
293 zawiera pliki nagłówkowe wspomnianych bibliotek.
294
295 %description devel -l pt_BR.UTF-8
296 O sistema de empacotamento RPM inclui uma biblioteca C que torna fácil
297 a manipulação de pacotes e bases de dados RPM. Seu objetivo é
298 facilitar a criação de gerenciadores gráficos de pacotes e outras
299 ferramentas que precisem de conhecimento profundo de pacotes RPM.
300
301 %description devel -l ru.UTF-8
302 Система управления пакетами RPM содержит библиотеку C, которая
303 упрощает манипуляцию пакетами RPM и соответствующими базами данных.
304 Эта библиотека предназначена для облегчения создания графических
305 пакетных менеджеров и других утилит, которым необходимо работать с
306 пакетами RPM.
307
308 %description devel -l uk.UTF-8
309 Система керування пакетами RPM містить бібліотеку C, котра спрощує
310 роботу з пакетами RPM та відповідними базами даних. Ця бібліотека
311 призначена для полегшення створення графічних пакетних менеджерів та
312 інших утиліт, що працюють з пакетами RPM.
313
314 %package utils
315 Summary:        Additional utilities for managing RPM packages and database
316 Summary(de.UTF-8):      Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken
317 Summary(pl.UTF-8):      Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami
318 Group:          Applications/File
319 Requires:       %{name} = %{epoch}:%{version}-%{release}
320 Requires:       popt >= %{popt_ver}
321 %if %{with recommends_tags}
322 Recommends:     bzip2
323 Recommends:     gzip
324 %endif
325 Conflicts:      filesystem-debuginfo < 3.0-16
326
327 %description utils
328 Additional utilities for managing RPM packages and database.
329
330 %description utils -l de.UTF-8
331 Zusatzwerkzeuge für Verwaltung RPM-Pakete und Datenbanken.
332
333 %description utils -l pl.UTF-8
334 Dodatkowe narzędzia do zarządzania bazą RPM-a i pakietami.
335
336 %package build
337 Summary:        Scripts for building binary RPM packages
338 Summary(de.UTF-8):      Scripts fürs Bauen binärer RPM-Pakete
339 Summary(pl.UTF-8):      Skrypty pomocnicze do budowania binarnych RPM-ów
340 Summary(pt_BR.UTF-8):   Scripts e programas executáveis usados para construir pacotes
341 Summary(ru.UTF-8):      Скрипты и утилиты, необходимые для сборки пакетов
342 Summary(uk.UTF-8):      Скрипти та утиліти, необхідні для побудови пакетів
343 Group:          Applications/File
344 Requires(pretrans):     coreutils
345 Requires(pretrans):     findutils
346 Requires:       %{name}-utils = %{epoch}:%{version}-%{release}
347 Requires:       rpm-pld-macros-build >= 1.744
348 Requires:       /bin/id
349 Requires:       awk
350 Requires:       bzip2
351 Requires:       chrpath >= 0.10-4
352 Requires:       cpio
353 Requires:       diffutils
354 Requires:       elfutils
355 Requires:       file >= 4.17
356 Requires:       fileutils
357 Requires:       findutils
358 %ifarch athlon
359 Requires:       gcc >= 3.0.3
360 %else
361 Requires:       gcc
362 %endif
363 Requires:       glibc-devel
364 Requires:       grep
365 Requires:       gzip
366 Requires:       make
367 Requires:       patch
368 Requires:       sed >= 4.0
369 Requires:       sh-utils
370 Requires:       tar >= 1:1.22
371 Requires:       textutils
372 Requires:       which
373 Requires:       xz
374 Provides:       rpmbuild(noauto) = 3
375 %ifarch %{x8664}
376 Conflicts:      automake < 1:1.7.9-2
377 Conflicts:      libtool < 2:1.5-13
378 %endif
379
380 %description build
381 Scripts for building binary RPM packages.
382
383 %description build -l de.UTF-8
384 Scripts fürs Bauen binärer RPM-Pakete.
385
386 %description build -l pl.UTF-8
387 Skrypty pomocnicze do budowania binarnych RPM-ów.
388
389 %description build -l pt_BR.UTF-8
390 Este pacote contém scripts e programas executáveis que são usados para
391 construir pacotes usando o RPM.
392
393 %description build -l ru.UTF-8
394 Различные вспомогательные скрипты и исполняемые программы, которые
395 используются для сборки RPM'ов.
396
397 %description build -l uk.UTF-8
398 Різноманітні допоміжні скрипти та утиліти, які використовуються для
399 побудови RPM'ів.
400
401 %package perlprov
402 Summary:        Additional utilities for checking Perl provides/requires in RPM packages
403 Summary(de.UTF-8):      Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen
404 Summary(pl.UTF-8):      Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w pakietach RPM
405 Group:          Applications/File
406 Requires:       %{name} = %{epoch}:%{version}-%{release}
407 Requires:       perl-Encode
408 Requires:       perl-devel
409 Requires:       perl-modules
410
411 %description perlprov
412 Additional utilities for checking Perl provides/requires in RPM
413 packages.
414
415 %description perlprov -l de.UTF-8
416 Zusatzwerkzeuge fürs Nachsehen Perl-Abhängigkeiten in RPM-Paketen.
417
418 %description perlprov -l pl.UTF-8
419 Dodatkowe narzędzia do sprawdzenia zależności skryptów Perla w
420 pakietach RPM.
421
422 %package pythonprov
423 Summary:        Python macros, which simplifies creation of RPM packages with Python software
424 Summary(pl.UTF-8):      Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w Pythonie
425 Group:          Applications/File
426 Requires:       %{name} = %{epoch}:%{version}-%{release}
427 Requires:       python3
428 Requires:       python3-modules
429 Requires:       python3-setuptools
430
431 %description pythonprov
432 Python macros, which simplifies creation of RPM packages with Python
433 software.
434
435 %description pythonprov -l pl.UTF-8
436 Makra ułatwiające tworzenie pakietów RPM z programami napisanymi w
437 Pythonie.
438
439 %package -n python3-rpm
440 Summary:        Python 3 interface to RPM library
441 Summary(pl.UTF-8):      Interfejs Pythona 3 do biblioteki RPM-a
442 Summary(pt_BR.UTF-8):   Módulo Python 3 para aplicativos que manipulam pacotes RPM
443 Group:          Development/Languages/Python
444 Requires:       %{name} = %{epoch}:%{version}-%{release}
445 Requires:       python3
446 Obsoletes:      python-rpm < 1:4.16.0
447 Obsoletes:      rpm-python
448
449 %description -n python3-rpm
450 The python3-rpm package contains a module which permits applications
451 written in the Python 3 programming language to use the interface
452 supplied by RPM (RPM Package Manager) libraries.
453
454 This package should be installed if you want to develop Python 3
455 programs that will manipulate RPM packages and databases.
456
457 %description -n python3-rpm -l pl.UTF-8
458 Pakiet python3-rpm zawiera moduł, który pozwala aplikacjom napisanym w
459 Pythonie 3 na używanie interfejsu dostarczanego przez biblioteki
460 RPM-a.
461
462 Pakiet ten powinien zostać zainstalowany, jeśli chcesz pisać w
463 Pythonie 3 programy manipulujące pakietami i bazami danych rpm.
464
465 %description -n python3-rpm -l pt_BR.UTF-8
466 O pacote python3-rpm contém um módulo que permite que aplicações
467 escritas em Python 3 utilizem a interface fornecida pelas bibliotecas
468 RPM (RPM Package Manager).
469
470 Esse pacote deve ser instalado se você quiser desenvolver programas em
471 Python 3 para manipular pacotes e bancos de dados RPM.
472
473 %package plugin-audit
474 Summary:        Plugin for logging audit events on package operations
475 Group:          Base
476 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
477
478 %description plugin-audit
479 Plugin for libaudit support
480
481 %package plugin-syslog
482 Summary:        Plugin for syslog functionality
483 Group:          Base
484 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
485
486 %description plugin-syslog
487 This plugin exports RPM actions to the system log.
488
489 %package plugin-systemd-inhibit
490 Summary:        Plugin for systemd inhibit functionality
491 Group:          Base
492 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
493
494 %description plugin-systemd-inhibit
495 This plugin blocks systemd from entering idle, sleep or shutdown while
496 an rpm transaction is running using the systemd-inhibit mechanism.
497
498 %package plugin-ima
499 Summary:        Plugin for IMA file signatures
500 Group:          Base
501 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
502
503 %description plugin-ima
504 This plugin adds support for enforcing and verifying IMA file
505 signatures in an rpm.
506
507 %package plugin-prioreset
508 Summary:        Plugin for resetting scriptlet priorities for SysV init
509 Group:          Base
510 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
511
512 %description plugin-prioreset
513 This plugin is useful on legacy SysV init systems if you run rpm
514 transactions with nice/ionice priorities. Should not be used on
515 systemd systems.
516
517 %package plugin-selinux
518 Summary:        Plugin for SELinux functionality
519 Group:          Base
520 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
521 Requires:       libselinux >= 2.1.0
522
523 %description plugin-selinux
524 Plugin for SELinux functionality.
525
526 %package sign
527 Summary:        Package signing support
528 Group:          Base
529 Requires:       %{name}-lib = %{epoch}:%{version}-%{release}
530
531 %description sign
532 This package contains support for digitally signing RPM packages.
533
534 %package apidocs
535 Summary:        RPM API documentation and guides
536 Summary(pl.UTF-8):      Documentacja API RPM-a i przewodniki
537 Group:          Documentation
538 BuildArch:      noarch
539
540 %description apidocs
541 Documentation for RPM API and guides in HTML format generated from rpm
542 sources by doxygen.
543
544 %description apidocs -l pl.UTF-8
545 Dokumentacja API RPM-a oraz przewodniki w formacie HTML generowane ze
546 źrodeł RPM-a przez doxygen.
547
548 %prep
549 %setup -q -n %{name}-%{version}%{?subver}
550 %patch0 -p1
551 %patch1 -p1
552 %patch2 -p1
553 %patch3 -p1
554 %patch4 -p1
555 %patch6 -p0
556 %patch7 -p1
557 %patch8 -p1
558 %patch9 -p1
559 %patch10 -p1
560 %patch11 -p1
561 %patch12 -p1
562 %patch13 -p1
563 %patch14 -p1
564 %patch15 -p1
565 %patch16 -p1
566 %patch17 -p1
567 %patch18 -p1
568 %patch19 -p1
569 %patch20 -p1
570 %patch21 -p1
571 %patch22 -p1
572 %patch23 -p1
573 %patch24 -p1
574 %patch25 -p1
575 %patch26 -p1
576 %patch27 -p1
577 %patch28 -p1
578 %patch29 -p1
579 %patch30 -p1
580 %patch31 -p1
581 %patch32 -p1
582 %patch33 -p1
583 %patch34 -p1
584
585 install %{SOURCE15} scripts/perl.prov.in
586
587 %{__mv} -f scripts/perl.req{,.in}
588
589 # generate Group translations to *.po
590 awk -f %{SOURCE6} %{SOURCE5}
591
592 %{__sed} -i -e '1s,/usr/bin/python,%{__python3},' scripts/pythondistdeps.py
593
594 %build
595 %{__libtoolize}
596 %{__aclocal}
597 %{__autoheader}
598 %{__autoconf}
599 %{__automake}
600
601 # rpm checks for CPU type at runtime, but it looks better
602 sed -i \
603         -e 's|@host@|%{_target_cpu}-%{_target_vendor}-%{_target_os}|' \
604         -e 's|@host_cpu@|%{_target_cpu}|' \
605         -e 's|@host_os@|%{_target_os}|' \
606         macros.in
607
608 %configure \
609         WITH_PERL_VERSION=no \
610         __GST_INSPECT=%{_bindir}/gst-inspect-1.0 \
611         __GPG=%{_bindir}/gpg \
612 %if %{with python3}
613         PYTHON=python3 \
614         --enable-python \
615 %endif
616         --disable-silent-rules \
617         --enable-shared \
618         --enable-bdb \
619         --enable-bdb-ro \
620         --enable-ndb \
621         --enable-sqlite \
622         --enable-zstd \
623         --with-lua \
624         %{?with_imaevm:--with-imaevm} \
625         --with-cap \
626         --with-acl \
627         --with-audit \
628         --with-archive \
629         --with-selinux=%{!?with_plugins:no}%{?with_plugins:yes} \
630         %{!?with_plugins:--disable-plugins} \
631         --with-vendor=pld
632
633 %{__make}
634
635 %if %{with python3}
636 cd python
637 %py3_build
638 %endif
639
640 %install
641 rm -rf $RPM_BUILD_ROOT
642 install -d $RPM_BUILD_ROOT{/bin,/%{_lib},/etc/sysconfig,%{_sysconfdir}/{rpm,pki/rpm-gpg}} \
643         $RPM_BUILD_ROOT{/var/lib/{banner,rpm},/usr/lib/.build-id}
644
645 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
646
647 %{__make} install \
648         pkgconfigdir=%{_pkgconfigdir} \
649         DESTDIR=$RPM_BUILD_ROOT
650
651 # cleanup
652 %ifnarch %{ix86} %{x8664} x32
653 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/athlon-linux/macros
654 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/geode-linux/macros
655 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i386-linux/macros
656 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i486-linux/macros
657 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i586-linux/macros
658 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/i686-linux/macros
659 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium3-linux/macros
660 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/pentium4-linux/macros
661 %endif
662
663 %ifnarch %{x8664} x32
664 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/amd64-linux/macros
665 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia32e-linux/macros
666 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x32-linux/macros
667 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/x86_64-linux/macros
668 %endif
669
670 %ifnarch %{ppc}
671 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/m68k-linux/macros
672 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc32dy4-linux/macros
673 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc64*-linux/macros
674 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8260-linux/macros
675 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc8560-linux/macros
676 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc-linux/macros
677 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ppc*series-linux/macros
678 %endif
679
680 %ifnarch aarch64
681 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/aarch64-linux/macros
682 %endif
683
684 %ifnarch %{arm}
685 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/arm*-linux/macros
686 %endif
687
688 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/alpha*-linux/macros
689 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/ia64-linux/macros
690 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/mips*-linux/macros
691 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/riscv64-linux/macros
692 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/s390*-linux/macros
693 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sh*-linux/macros
694 rm $RPM_BUILD_ROOT%{_rpmlibdir}/platform/sparc*-linux/macros
695
696 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/rpm/platform
697 %ifarch x32
698 %{_target_cpu}-%{_target_vendor}-linux-gnux32
699 %else
700 %{_target_cpu}-%{_target_vendor}-linux
701 %endif
702 EOF
703
704 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/find-lang.sh
705
706 install -d $RPM_BUILD_ROOT%{_rpmlibdir}/pld
707
708 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_rpmlibdir}/install-build-tree
709 cp -p %{SOURCE9} $RPM_BUILD_ROOT%{_rpmlibdir}/user_group.sh
710 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/rpm
711
712 cp -p %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/banner.sh
713
714 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros
715 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.lang
716 cp -p %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprov
717 cp -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoprovfiles
718 cp -p %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreq
719 cp -p %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/noautoreqfiles
720
721 # move rpm to /bin
722 %{__mv} $RPM_BUILD_ROOT%{_bindir}/rpm $RPM_BUILD_ROOT/bin
723 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmquery
724 ln -sf /bin/rpm $RPM_BUILD_ROOT%{_bindir}/rpmverify
725
726 # move essential libs to /lib (libs that /bin/rpm links to)
727 for a in librpm.so librpmbuild.so librpmio.so librpmsign.so; do
728         mv -f $RPM_BUILD_ROOT%{_libdir}/${a}.* $RPM_BUILD_ROOT/%{_lib}
729         ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/${a}.*.*.*) $RPM_BUILD_ROOT%{_libdir}/${a}
730 done
731
732 # init an empty database for %ghost'ing for all supported backends
733 for be in sqlite bdb ndb; do
734         ./rpmdb \
735                 --macros=$RPM_BUILD_ROOT%{_rpmlibdir}/macros \
736                 --rcfile=$RPM_BUILD_ROOT%{_rpmlibdir}/rpmrc \
737                 --dbpath=${PWD}/${be} \
738                 --define "_db_backend ${be}" \
739                 --initdb
740         cp -va ${be}/. $RPM_BUILD_ROOT/var/lib/rpm/
741 done
742
743 %if %{with python3}
744 # Remove anything that rpm make install might put there
745 %{__rm} -rf $RPM_BUILD_ROOT%{py3_sitedir}
746 cd python
747 %py3_install
748 cd ..
749 %endif
750
751 %{__rm} $RPM_BUILD_ROOT%{_libdir}/rpm-plugins/*.la
752
753 # wrong location, not used anyway
754 %{__rm} $RPM_BUILD_ROOT%{_rpmlibdir}/rpm.{daily,log}
755
756 %find_lang %{name}
757
758 %clean
759 rm -rf $RPM_BUILD_ROOT
760
761 %posttrans
762 if [ -e /var/lib/rpm/Packages ]; then
763         if [ ! -e /var/lib/rpm.rpmbackup-%{version}-%{release} ] && \
764                         /bin/cp -a /var/lib/rpm /var/lib/rpm.rpmbackup-%{version}-%{release}; then
765                 echo
766                 echo "Backup of the rpm database has been created in /var/lib/rpm.rpmbackup-%{version}-%{release}"
767                 echo
768         fi
769         echo
770         echo 'If poldek aborts after migration with rpmdb error, this is expected behaviour,'
771         echo 'you should ignore it and restart poldek'
772         echo
773         %{__rm} -rf /var/lib/rpm/log >/dev/null 2>/dev/null || :
774         %{__rm} -rf /var/lib/rpm/tmp >/dev/null 2>/dev/null || :
775         # Unlock database for rebuild, safe since this is posttrans
776         %{__rm} -f /var/lib/rpm/.rpm.lock >/dev/null 2>/dev/null || :
777         if ! /usr/bin/rpmdb --rebuilddb; then
778                 echo
779                 echo "rpm database conversion failed!"
780                 echo "You have to run '/usr/bin/rpmdb --rebuilddb' manually"
781                 echo
782                 exit 1
783         fi
784 fi
785
786 %post   lib -p /sbin/ldconfig
787 %postun lib -p /sbin/ldconfig
788
789 %pretrans build
790 find %{_rpmlibdir} -name '*-linux' -type l | xargs rm -f
791
792 %files -f %{name}.lang
793 %defattr(644,root,root,755)
794 %doc ChangeLog CREDITS README
795
796 %dir /etc/pki/rpm-gpg
797 /etc/pki/rpm-gpg/PLD-3.0-Th-GPG-key.asc
798
799 %attr(755,root,root) /bin/rpm
800 %attr(755,root,root) %{_bindir}/rpmdb
801 %attr(755,root,root) %{_bindir}/rpmkeys
802 %attr(755,root,root) %{_bindir}/rpmquery
803 %attr(755,root,root) %{_bindir}/rpmverify
804
805 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros
806 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/macros.lang
807 # this is ok to be replaced
808 %config %verify(not md5 mtime size) %{_sysconfdir}/rpm/platform
809
810 %{_mandir}/man8/rpm.8*
811 %{_mandir}/man8/rpmdb.8*
812 %{_mandir}/man8/rpmkeys.8*
813 %{_mandir}/man8/rpm-misc.8*
814 %{?with_plugins:%{_mandir}/man8/rpm-plugins.8*}
815 %lang(fr) %{_mandir}/fr/man8/rpm.8*
816 %lang(ja) %{_mandir}/ja/man8/rpm.8*
817 %lang(ko) %{_mandir}/ko/man8/rpm.8*
818 %lang(pl) %{_mandir}/pl/man8/rpm.8*
819 %lang(ru) %{_mandir}/ru/man8/rpm.8*
820 %lang(sk) %{_mandir}/sk/man8/rpm.8*
821
822 %dir /var/lib/rpm
823 %ghost %config(missingok,noreplace) /var/lib/rpm/*
824 %ghost /var/lib/rpm/.*.lock
825
826 %{_rpmlibdir}/rpmpopt*
827 %{_rpmlibdir}/rpmrc
828 %{_rpmlibdir}/macros
829 %dir %{_rpmlibdir}/macros.d
830 %dir %{_rpmlibdir}/platform
831 %{_rpmlibdir}/platform/noarch-*
832 %ifarch %{ix86} %{x8664} x32
833 %{_rpmlibdir}/platform/athlon*
834 %{_rpmlibdir}/platform/geode*
835 %{_rpmlibdir}/platform/i?86*
836 %{_rpmlibdir}/platform/pentium*
837 %endif
838 %ifarch %{x8664} x32
839 %{_rpmlibdir}/platform/amd64*
840 %{_rpmlibdir}/platform/ia32e*
841 %{_rpmlibdir}/platform/x86_64*
842 %{_rpmlibdir}/platform/x32*
843 %endif
844 %ifarch alpha
845 %{_rpmlibdir}/platform/alpha*
846 %endif
847 %ifarch aarch64
848 %{_rpmlibdir}/platform/aarch64*
849 %endif
850 %ifarch %{arm}
851 %{_rpmlibdir}/platform/arm*
852 %endif
853 %ifarch ia64
854 %{_rpmlibdir}/platform/ia64*
855 %endif
856 %ifarch mips mipsel mips64 mips64el
857 %{_rpmlibdir}/platform/mips*
858 %endif
859 %ifarch %{ppc}
860 %{_rpmlibdir}/platform/ppc*
861 %endif
862 %ifarch sparc sparc64
863 %{_rpmlibdir}/platform/sparc*
864 %endif
865
866 %dir %{_rpmlibdir}/pld
867
868 %attr(755,root,root) %{_rpmlibdir}/rpmdb_dump
869 %attr(755,root,root) %{_rpmlibdir}/rpmdb_load
870
871 # valgrind suppression file for rpm
872 %{_rpmlibdir}/rpm.supp
873
874 %dir /usr/lib/.build-id
875
876 %files base
877 %defattr(644,root,root,755)
878 %dir %{_sysconfdir}/rpm
879 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rpm
880 %dir %{_rpmlibdir}
881 %attr(755,root,root) %{_bindir}/banner.sh
882 %attr(755,root,root) %{_rpmlibdir}/user_group.sh
883 %dir /var/lib/banner
884
885 %files lib
886 %defattr(644,root,root,755)
887 %attr(755,root,root) /%{_lib}/librpm.so.9
888 %attr(755,root,root) /%{_lib}/librpm.so.%{sover}
889 %attr(755,root,root) /%{_lib}/librpmbuild.so.9
890 %attr(755,root,root) /%{_lib}/librpmbuild.so.%{sover}
891 %attr(755,root,root) /%{_lib}/librpmio.so.9
892 %attr(755,root,root) /%{_lib}/librpmio.so.%{sover}
893 %attr(755,root,root) /%{_lib}/librpmsign.so.9
894 %attr(755,root,root) /%{_lib}/librpmsign.so.%{sover}
895 %{?with_plugins:%dir %{_libdir}/rpm-plugins}
896
897 %files devel
898 %defattr(644,root,root,755)
899 %attr(755,root,root) %{_libdir}/librpm.so
900 %attr(755,root,root) %{_libdir}/librpmbuild.so
901 %attr(755,root,root) %{_libdir}/librpmio.so
902 %attr(755,root,root) %{_libdir}/librpmsign.so
903 %{_libdir}/librpm*.la
904 %{_includedir}/rpm
905 %{_pkgconfigdir}/*.pc
906
907 %files utils
908 %defattr(644,root,root,755)
909 %attr(755,root,root) %{_bindir}/rpm2archive
910 %attr(755,root,root) %{_bindir}/rpm2cpio
911 %attr(755,root,root) %{_bindir}/rpmgraph
912 %attr(755,root,root) %{_rpmlibdir}/rpm2cpio.sh
913 %attr(755,root,root) %{_rpmlibdir}/find-debuginfo.sh
914 %attr(755,root,root) %{_rpmlibdir}/tgpg
915 %attr(755,root,root) %{_rpmlibdir}/debugedit
916 %attr(755,root,root) %{_rpmlibdir}/rpmdeps
917 %{_mandir}/man8/rpm2archive.8*
918 %{_mandir}/man8/rpm2cpio.8*
919 %{_mandir}/man8/rpmdeps.8*
920 %{_mandir}/man8/rpmgraph.8*
921 %lang(ja) %{_mandir}/ja/man8/rpm2cpio.8*
922 %lang(ko) %{_mandir}/ko/man8/rpm2cpio.8*
923 %lang(pl) %{_mandir}/pl/man8/rpm2cpio.8*
924 %lang(ru) %{_mandir}/ru/man8/rpm2cpio.8*
925 %lang(pl) %{_mandir}/pl/man8/rpmdeps.8*
926 %lang(ja) %{_mandir}/ja/man8/rpmgraph.8*
927 %lang(pl) %{_mandir}/pl/man8/rpmgraph.8*
928
929 %files build
930 %defattr(644,root,root,755)
931 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/rpm/noauto*
932 %attr(755,root,root) %{_rpmlibdir}/brp-*
933 %attr(755,root,root) %{_rpmlibdir}/check-files
934 %attr(755,root,root) %{_rpmlibdir}/install-build-tree
935 %attr(755,root,root) %{_rpmlibdir}/elfdeps
936 %attr(755,root,root) %{_rpmlibdir}/libtooldeps.sh
937 # needs hacked pkg-config to return anything
938 %attr(755,root,root) %{_rpmlibdir}/pkgconfigdeps.sh
939 %attr(755,root,root) %{_rpmlibdir}/mkinstalldirs
940
941 %attr(755,root,root) %{_rpmlibdir}/fontconfig.prov
942 # must be here for "Requires: rpm-*prov" to work
943 #%{_rpmlibdir}/macros.d/cmake
944 #%{_rpmlibdir}/macros.d/gstreamer
945 #%{_rpmlibdir}/macros.d/libtool
946 #%{_rpmlibdir}/macros.d/perl
947 #%{_rpmlibdir}/macros.d/pkgconfig
948 #%{_rpmlibdir}/macros.d/python
949 #%{_rpmlibdir}/macros.d/selinux
950 #%{_rpmlibdir}/macros.d/tcl
951 #%{_rpmlibdir}/macros.rpmbuild
952
953 %attr(755,root,root) %{_rpmlibdir}/check-buildroot
954 %attr(755,root,root) %{_rpmlibdir}/check-prereqs
955 %attr(755,root,root) %{_rpmlibdir}/check-rpaths
956 %attr(755,root,root) %{_rpmlibdir}/check-rpaths-worker
957 %attr(755,root,root) %{_rpmlibdir}/find-provides
958 %attr(755,root,root) %{_rpmlibdir}/find-requires
959 %attr(755,root,root) %{_rpmlibdir}/ocamldeps.sh
960 %attr(755,root,root) %{_rpmlibdir}/script.req
961 %attr(755,root,root) %{_rpmlibdir}/sepdebugcrcfix
962
963 %dir %{_rpmlibdir}/fileattrs
964 %{_rpmlibdir}/fileattrs/debuginfo.attr
965 %{_rpmlibdir}/fileattrs/desktop.attr
966 %{_rpmlibdir}/fileattrs/elf.attr
967 %{_rpmlibdir}/fileattrs/font.attr
968 %{_rpmlibdir}/fileattrs/libtool.attr
969 %{_rpmlibdir}/fileattrs/metainfo.attr
970 %{_rpmlibdir}/fileattrs/ocaml.attr
971 %{_rpmlibdir}/fileattrs/perl.attr
972 %{_rpmlibdir}/fileattrs/perllib.attr
973 %{_rpmlibdir}/fileattrs/pkgconfig.attr
974 %{_rpmlibdir}/fileattrs/python.attr
975 %{_rpmlibdir}/fileattrs/pythondist.attr
976 %{_rpmlibdir}/fileattrs/script.attr
977
978 %attr(755,root,root) %{_bindir}/gendiff
979 %attr(755,root,root) %{_bindir}/rpmbuild
980 %attr(755,root,root) %{_bindir}/rpmspec
981
982 %{_mandir}/man1/gendiff.1*
983 %lang(pl) %{_mandir}/pl/man1/gendiff.1*
984 %{_mandir}/man8/rpmbuild.8*
985 %lang(ja) %{_mandir}/ja/man8/rpmbuild.8*
986 %lang(pl) %{_mandir}/pl/man8/rpmbuild.8*
987 %{_mandir}/man8/rpmspec.8*
988
989 %files perlprov
990 %defattr(644,root,root,755)
991 %attr(755,root,root) %{_rpmlibdir}/perl.*
992
993 %files pythonprov
994 %defattr(644,root,root,755)
995 %attr(755,root,root) %{_rpmlibdir}/pythondistdeps.py
996
997 %if %{with python3}
998 %files -n python3-rpm
999 %defattr(644,root,root,755)
1000 %dir %{py3_sitedir}/rpm
1001 %attr(755,root,root) %{py3_sitedir}/rpm/*.so
1002 %{py3_sitedir}/rpm/*.py
1003 %{py3_sitedir}/rpm-%{version}-py*.egg-info
1004 %{py3_sitedir}/rpm/__pycache__
1005 %endif
1006
1007 %if %{with plugins}
1008 %files plugin-audit
1009 %defattr(644,root,root,755)
1010 %attr(755,root,root) %{_libdir}/rpm-plugins/audit.so
1011 %{_mandir}/man8/rpm-plugin-audit.8*
1012
1013 %files plugin-syslog
1014 %defattr(644,root,root,755)
1015 %attr(755,root,root) %{_libdir}/rpm-plugins/syslog.so
1016 %{_mandir}/man8/rpm-plugin-syslog.8*
1017
1018 %files plugin-systemd-inhibit
1019 %defattr(644,root,root,755)
1020 %attr(755,root,root) %{_libdir}/rpm-plugins/systemd_inhibit.so
1021 %{_mandir}/man8/rpm-plugin-systemd-inhibit.8*
1022
1023 %files plugin-ima
1024 %defattr(644,root,root,755)
1025 %attr(755,root,root) %{_libdir}/rpm-plugins/ima.so
1026 %{_mandir}/man8/rpm-plugin-ima.8*
1027
1028 %files plugin-prioreset
1029 %defattr(644,root,root,755)
1030 %attr(755,root,root) %{_libdir}/rpm-plugins/prioreset.so
1031 %{_mandir}/man8/rpm-plugin-prioreset.8*
1032
1033 %files plugin-selinux
1034 %defattr(644,root,root,755)
1035 %attr(755,root,root) %{_libdir}/rpm-plugins/selinux.so
1036 %{_mandir}/man8/rpm-plugin-selinux.8*
1037 %endif
1038
1039 %files sign
1040 %defattr(644,root,root,755)
1041 %attr(755,root,root) %{_bindir}/rpmsign
1042 %{_mandir}/man8/rpmsign.8*
1043
1044 %if %{with apidocs}
1045 %files apidocs
1046 %defattr(644,root,root,755)
1047 %doc doc/librpm/html/*
1048 %endif
This page took 0.261948 seconds and 3 git commands to generate.