]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- try to reject UTF8 on AC-branch
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 13 Feb 2007 10:04:55 +0000 (10:04 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    builder.sh -> 1.476

builder.sh

index 1613ecd49e7743329cdb9494a5dcec38d2e09795..eaec3c5e783f14001e40a5b7f9c67030954c6223 100644 (file)
@@ -564,6 +564,10 @@ Exit_error()
                        remove_build_requires
                        echo "Tree branch already exists (${2})."
                        exit 11 ;;
+               "err_acl_deny" )
+                       remove_build_requires
+                       echo "Error: conditions reject building this spec (${2})."
+                       exit 12 ;;
 
        esac
        echo "Unknown error."
@@ -2088,7 +2092,17 @@ case "$COMMAND" in
                                fi
                        fi
 
+                       # ./builder -bs test.spec -r AC-branch -Tp auto-ac- -tt
                        if [ -n "$TEST_TAG" ]; then
+                               # - do not allow utf8 encoded specs on AC-branch
+                               if [ "$CVSTAG" = "AC-branch" ]; then
+                                       local t
+                                       t=$(grep '^Summary(.*\.UTF-8):' $SPECFILE)
+                                       if [ "$t" ]; then
+                                               Exit_error err_acl_deny "UTF-8 not allowed on AC-branch"
+                                       fi
+                               fi
+
                                TAGVER=`make_tagver`
                                echo "Searching for tag $TAGVER..."
                                TAGREL=$(cvs status -v $SPECFILE | grep -E "^[[:space:]]*${TAGVER}[[[:space:]]" | sed -e 's#.*(revision: ##g' -e 's#).*##g')
@@ -2105,6 +2119,7 @@ case "$COMMAND" in
                                                Exit_error err_branch_exists "$TAG_STATUS"
                                        fi
                                fi
+
                        fi
 
                        if [ -n "$NOSOURCE0" ] ; then
This page took 0.05155 seconds and 4 git commands to generate.