]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- --build-prep/-bp option
authorsaq <saq@pld-linux.org>
Fri, 21 Nov 2003 22:08:54 +0000 (22:08 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    builder.sh -> 1.222

builder.sh

index f0ac944394952e8531afc7548b5876dc02bcf91e..f9f3ec1d212bb0f41f13b38ab44858ed5105acd6 100644 (file)
@@ -154,6 +154,8 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
        -bs,
        --build-source  - get all files from CVS repo or HTTP/FTP and only
                          pack them into src.rpm,
+       -bp, --build-prep
+                       - execute the %prep phase of <package>.spec,
        -B, --branch    - add branch
        -c, --clean     - clean all temporarily created files (in BUILD,
                          SOURCES, SPECS and \$RPM_BUILD_ROOT),
@@ -759,6 +761,8 @@ build_package()
            BUILD_SWITCH="-bb" ;;
        build-source )
            BUILD_SWITCH="-bs --nodeps" ;;
+       build-prep )
+           BUILD_SWITCH="-bp --nodeps" ;;
     esac
     if [ -n "$LOGFILE" ]; then
        LOG=`eval echo $LOGFILE`
@@ -1006,6 +1010,8 @@ while test $# -gt 0 ; do
            COMMAND="build-binary"; shift ;;
        -bs | --build-source )
            COMMAND="build-source"; shift ;;
+       -bp | --build-prep )
+           COMMAND="build-prep"; shift ;;
        -B | --branch )
            COMMAND="branch"; shift; TAG="${1}"; shift;;
        -c | --clean )
@@ -1143,7 +1149,7 @@ if [ -n "$DEBUG" ]; then
 fi
 
 case "$COMMAND" in
-    "build" | "build-binary" | "build-source" )
+    "build" | "build-binary" | "build-source" | "build-prep" )
        init_builder;
        if [ -n "$SPECFILE" ]; then
            get_spec;
This page took 0.037578 seconds and 4 git commands to generate.