]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
teeboth: Make STDIN available to a subprocess auto/th/rpm-build-tools-4.5-8
authorKacper Kornet <draenog@pld-linux.org>
Mon, 22 Apr 2013 16:22:25 +0000 (17:22 +0100)
committerKacper Kornet <draenog@pld-linux.org>
Mon, 22 Apr 2013 16:22:25 +0000 (17:22 +0100)
Otherwise tests in ack.spec fails, as ack tests if its stdin is a pipe
or not and changes its behaviour based on it.

teeboth

diff --git a/teeboth b/teeboth
index d5983527f35b78137fffde4b7dca69e1687bd5de..6c0f53372ba323045678637f2917677ade8bad6f 100755 (executable)
--- a/teeboth
+++ b/teeboth
@@ -31,8 +31,7 @@ sub sigchld
 }
 $SIG{CHLD} = \&sigchld;
 
-$pid = open3( \*child_in, \*child_out, \*child_err, @ARGV );
-close child_in;
+$pid = open3( "<&STDIN",  \*child_out, \*child_err, @ARGV );
 
 sub sethandle
 {
This page took 0.042281 seconds and 4 git commands to generate.