]> git.pld-linux.org Git - packages/rpm-build-tools.git/commitdiff
- pass --nodeps to rpm if requested
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 8 Oct 2003 22:46:02 +0000 (22:46 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    builder.sh -> 1.200

builder.sh

index b322bee8ecc00da9307c0edb52d052c5f1dbc07d..cf5dffa50c6488776f4138938808290606b7d28e 100644 (file)
@@ -139,6 +139,7 @@ Usage: builder [-D|--debug] [-V|--version] [-a|--as_anon] [-b|-ba|--build]
                        - setup \$CVSROOT,
        --define <macro> <value>
                        - define a macro <macro> with value <value>,
+       --nodeps        - rpm won't check any dependences
        -g, --get       - get <package>.spec and all related files from
                          CVS repo or HTTP/FTP,
        -h, --help      - this message,
@@ -886,6 +887,10 @@ while test $# -gt 0 ; do
            shift 2
            RPMOPTS="${RPMOPTS} --define \"${MACRO} ${VALUE}\""
            ;;
+       --nodeps)
+           shift
+           RPMOPTS="${RPMOPTS} --nodeps"
+           ;;
        * )
            SPECFILE="`basename ${1} .spec`.spec"; shift ;;
     esac
This page took 0.043687 seconds and 4 git commands to generate.