]> git.pld-linux.org Git - packages/rox.git/blob - rox.spec
- updated to 1.3.8
[packages/rox.git] / rox.spec
1 %define         _name ROX-Filer
2 %define         _platform %(echo `uname -s`-`uname -m|sed 's/i.86/ix86/'`)
3 Summary:        File manager
4 Summary(pl):    Zarz±dca plików
5 Name:           rox
6 Version:        1.3.8
7 Release:        1
8 License:        GPL
9 Group:          X11/Applications
10 Source0:        http://dl.sourceforge.net/rox/%{name}-%{version}.tgz
11 Source1:        %{name}.desktop
12 Patch0:         %{name}-fix-mime-info-path.patch
13 Patch1:         %{name}-help.patch
14 Patch2:         %{name}-fix-type.c.patch
15 URL:            http://rox.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  gdk-pixbuf-devel
18 BuildRequires:  gtk+2-devel >= 2.0.1
19 BuildRequires:  libxml2-devel >= 2.0.0
20 BuildRequires:  pkgconfig
21 Requires:       glib2 >= 2.0.3
22 Requires:       gtk+2 >= 2.0.1
23 Requires:       libxml2 >= 2.0.0
24 Requires:       shared-mime-info >= 0.8
25 Conflicts: rox-base
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _appsdir        %{_libdir}/ROX-apps
29
30 %description
31 ROX-Filer is a small, fast and powerful file manager for Linux and
32 Unix systems.
33
34 %description -l pl
35 ROX-Filer jest ma³ym, szybkim programem do zarz±dzania plikami o
36 du¿ych mo¿liwo¶ciach przeznaczonym dla Linuksa i innych systemów
37 uniksowych.
38
39 %prep
40 %setup -q
41 %patch0 -p1
42 %patch1 -p1
43 %patch2 -p1
44
45 %build
46 #./ROX-Filer/AppRun --compile
47 cd ROX-Filer/src
48 %{__autoconf}
49 %configure \
50         --enable-rox \
51         --with-platform="`uname -s`-`echo \"\`uname -m\`\"|sed s/i.86/ix86/`"
52 %{__make}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appsdir}/%{_name},%{_mandir}/man1} \
57         $RPM_BUILD_ROOT{%{_pixmapsdir}/rox,%{_applnkdir}/Utilities} \
58         $RPM_BUILD_ROOT%{_datadir}/{mime-info,Choices}
59
60 ln -sf %{_appsdir}/%{_name}/.DirIcon $RPM_BUILD_ROOT%{_pixmapsdir}/rox.png
61 ln -sf %{_datadir}/Choices/MIME-icons $RPM_BUILD_ROOT%{_pixmapsdir}/rox
62
63 cp -R ROX-Filer/* $RPM_BUILD_ROOT%{_appsdir}/%{_name}
64 cp -R Choices/* $RPM_BUILD_ROOT%{_datadir}/Choices
65
66 install ROX-Filer/.DirIcon $RPM_BUILD_ROOT%{_appsdir}/%{_name}
67 install rox.xml $RPM_BUILD_ROOT%{_datadir}/mime-info
68 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
69
70 # start-up script
71 cat > $RPM_BUILD_ROOT%{_bindir}/%{name} << EOF
72 #!/bin/sh
73 CHOICESPATH=~/Choices:%{_datadir}/Choices; export CHOICESPATH
74 exec %{_appsdir}/%{_name}/AppRun "\$@"
75 EOF
76
77 echo ".so rox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/ROX-Filer.1
78
79 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Utilities/
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %pre
85 test -h %{_pixmapsdir}/rox/MIME-icons || rm -rf %{_pixmapsdir}/rox/MIME-icons
86
87 %post
88 %{_bindir}/update-mime-database %{_datadir}/mime-info
89
90 %postun
91 %{_bindir}/update-mime-database %{_datadir}/mime-info
92
93 %files
94 %defattr(644,root,root,755)
95 %doc ROX-Filer/Help/{Changes,README,README-es,TODO}
96 %attr(755,root,root) %{_bindir}/*
97 %attr(755,root,root) %{_appsdir}/%{_name}/%{_platform}
98 %attr(755,root,root) %{_appsdir}/%{_name}/AppRun
99 %{_mandir}/man1/*
100 %dir %{_appsdir}
101 %dir %{_appsdir}/%{_name}
102 %dir %{_appsdir}/%{_name}/Help
103 %{_appsdir}/%{_name}/*.png
104 %{_appsdir}/%{_name}/*.xml
105 %{_appsdir}/%{_name}/*.css
106 %{_appsdir}/%{_name}/.DirIcon
107 %{_appsdir}/%{_name}/Help/*html
108 %{_appsdir}/%{_name}/Messages
109 %{_appsdir}/%{_name}/images
110 %dir %{_datadir}/Choices
111 %{_datadir}/Choices/MIME-icons
112 %dir %{_datadir}/Choices/MIME-types
113 %attr(755,root,root) %{_datadir}/Choices/MIME-types/*
114 %{_applnkdir}/Utilities/*
115 %{_pixmapsdir}/*
116 %{_datadir}/mime-info/*
This page took 0.095359 seconds and 4 git commands to generate.