]> git.pld-linux.org Git - packages/rox.git/blob - rox.spec
- updated to 1.3.3
[packages/rox.git] / rox.spec
1 %define _appsdir /usr/X11R6/share/ROX-apps
2 %define _name ROX-Filer
3 %define _platform %(echo `uname -s`-`uname -m|sed 's/i.86/ix86/'`)
4 Summary:        File-manager
5 Summary(pl):    Menad¿er plików
6 Name:           rox
7 Version:        1.3.3
8 Release:        1
9 License:        GPL
10 Group:          X11/Applications
11 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/rox/%{name}-%{version}.tgz
12 Source1:        %{name}.desktop
13 Patch0:         %{name}-fix-mime-info-path.patch
14 URL:            http://rox.sourceforge.net/
15 BuildRequires:  gdk-pixbuf-devel
16 BuildRequires:  gtk+2-devel >= 2.0.0
17 BuildRequires:  libxml2-devel >= 2.0.0
18 BuildRequires:  pkgconfig
19 Requires:       gtk+2 >= 2.0.0
20 Requires:       libxml2 >= 2.0.0
21 Requires:       shared-mime-info >= 0.8
22 Conflicts: rox-base
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define         _prefix         /usr/X11R6
26 %define         _mandir         %{_prefix}/man
27
28 %description
29 ROX-Filer is a small, fast and powerful filer for Linux and Unix
30 systems.
31
32 %description -l pl
33 ROX-Filer jest ma³ym, szybkim menad¿erem plików o du¿ych mo¿liwo¶ciach
34 dla Linuksa i innych uniksów.
35
36 %prep
37 %setup -q
38 %patch0 -p1
39
40 %build
41 ./ROX-Filer/AppRun --compile
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_bindir},%{_appsdir}/%{_name},%{_mandir}/man1}
46 install -d $RPM_BUILD_ROOT{%{_pixmapsdir}/rox,%{_applnkdir}/Utilities}
47 install -d $RPM_BUILD_ROOT%{_datadir}/{mime-info,Choices}
48
49 ln -sf %{_appsdir}/%{_name}/.DirIcon $RPM_BUILD_ROOT%{_pixmapsdir}/rox.png
50 ln -sf %{_datadir}/Choices/MIME-icons $RPM_BUILD_ROOT%{_pixmapsdir}/rox
51 cp -R ROX-Filer/* $RPM_BUILD_ROOT%{_appsdir}/%{_name}
52 cp -R Choices/* $RPM_BUILD_ROOT%{_datadir}/Choices
53 install ROX-Filer/.DirIcon $RPM_BUILD_ROOT%{_appsdir}/%{_name}
54 install rox.xml $RPM_BUILD_ROOT%{_datadir}/mime-info
55 install %{name}.1 $RPM_BUILD_ROOT%{_mandir}/man1
56
57 # start-up script
58 cat > $RPM_BUILD_ROOT%{_bindir}/%{name} << EOF
59 #!/bin/sh
60 CHOICESPATH=~/Choices:%{_datadir}/Choices; export CHOICESPATH
61 exec %{_appsdir}/%{_name}/AppRun "\$@"
62 EOF
63
64 echo ".so rox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/ROX-Filer.1
65
66 install %{SOURCE1} $RPM_BUILD_ROOT%{_applnkdir}/Utilities/
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %pre
72 test -h %{_pixmapsdir}/rox/MIME-icons || rm -rf %{_pixmapsdir}/rox/MIME-icons
73
74 %post
75 %{_bindir}/update-mime-database %{_datadir}/mime-info
76
77 %postun
78 %{_bindir}/update-mime-database %{_datadir}/mime-info
79
80 %files
81 %defattr(644,root,root,755)
82 %doc ROX-Filer/Help/{Changes,README,README-es,TODO}
83 %attr(755,root,root) %{_bindir}/*
84 %attr(755,root,root) %{_appsdir}/%{_name}/%{_platform}
85 %attr(755,root,root) %{_appsdir}/%{_name}/AppRun
86 %{_mandir}/man1/*
87 %dir %{_appsdir}
88 %dir %{_appsdir}/%{_name}
89 %dir %{_appsdir}/%{_name}/Help
90 %{_appsdir}/%{_name}/*.png
91 %{_appsdir}/%{_name}/*.xml
92 %{_appsdir}/%{_name}/*.css
93 %{_appsdir}/%{_name}/.DirIcon
94 %{_appsdir}/%{_name}/Help/*html
95 %{_appsdir}/%{_name}/Messages
96 %{_appsdir}/%{_name}/images
97 %dir %{_datadir}/Choices
98 %{_datadir}/Choices/MIME-icons
99 %dir %{_datadir}/Choices/MIME-types
100 %attr(755,root,root) %{_datadir}/Choices/MIME-types/*
101 %{_applnkdir}/Utilities/*
102 %{_pixmapsdir}/*
103 %{_datadir}/mime-info/*
This page took 0.079707 seconds and 4 git commands to generate.