]> git.pld-linux.org Git - packages/reglookup.git/blob - reglookup.spec
- fix python install
[packages/reglookup.git] / reglookup.spec
1 Summary:        small utility for querying NT/2K/XP/2K3/Vista registries
2 Summary(pl.UTF-8):      proste narzędzie do odpytywania rejestrów NT/2K/XP/2K3/Vista
3 Name:           reglookup
4 Version:        1.0.1
5 Release:        3
6 License:        GPL v3
7 Group:          Applications
8 Source0:        http://projects.sentinelchicken.org/data/downloads/%{name}-src-%{version}.tar.gz
9 # Source0-md5:  c451c2dba904db8ae5b0531ca303e322
10 Patch0:         %{name}-paths.patch
11 Patch1:         %{name}-soname.patch
12 URL:            http://projects.sentinelchicken.org/reglookup/
13 BuildRequires:  rpmbuild(macros) >= 1.385
14 BuildRequires:  scons
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 RegLookup is an small command line utility for reading and querying
19 Windows NT-based registries. RegLookup is released under the GNU GPL,
20 and is implemented in ANSI C. Original source was borrowed from the
21 program editreg, written by Richard Sharpe. It has since been
22 rewritten to use the regfio library, written by Gerald Carter.
23
24 Currently the program allows one to read an entire registry and output
25 it in a (mostly) standardized, quoted format. It also provides
26 features for filtering of results based on registry path and data
27 type.
28
29 %description -l pl.UTF-8
30 RegLookup to proste narzędzie do odczytywania i odpytywania rejestrów
31 systemów Windows serii NT. RegLookup jest udostępniony na zasadach
32 licencji GNU GPL i zaimplementowany w ANSI C. Źródła oparte są na
33 programie editreg, napisanym przez Richarda Sharpe. Od tamtej pory
34 program został przepisany z wykorzystaniem biblioteki regfio,
35 napisanej przez Geralda Cartera.
36
37 Obecnie program pozwala na odczyt rejestru i wypisania go w
38 ustandaryzowanym formacie. Możliwe jest także filtrowanie wyników na
39 podstawie ścieżek rejestru czy typów danych.
40
41 %package libs
42 Summary:        reglookup shared library
43 Summary(pl.UTF-8):      współdzielona biblioteka reglookup
44 Group:          Libraries
45
46 %description libs
47 reglookup shared library.
48
49 %description libs -l pl.UTF-8
50 współdzielona biblioteka reglookup.
51
52 %package devel
53 Summary:        Header files for reglookup library
54 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki reglookup
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for reglookup library.
60
61 %description devel -l pl.UTF-8
62 Pliki nagłówkowe biblioteki reglookup.
63
64 %package static
65 Summary:        Static reglookup library
66 Summary(pl.UTF-8):      Statyczna biblioteka reglookup
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static reglookup library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka reglookup.
75
76 %package -n python-pyregfi
77 Summary:        Python bindings for regfi library
78 Summary(pl.UTF-8):      Dowiązania pythona do blblioteki regfi
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description -n python-pyregfi
83 Python bindings for regfi library.
84
85 %description -n python-pyregfi -l pl.UTF-8
86 Dowiązania pythona do biblioteki regfi.
87
88 %prep
89 %setup -q -n %{name}-src-%{version}
90 %patch0 -p1
91 %patch1 -p1
92
93 %build
94 %scons
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98
99 DESTDIR=$RPM_BUILD_ROOT \
100 PREFIX="%{_prefix}" \
101 BINDIR="%{_bindir}" \
102 LIBDIR="%{_libdir}" \
103 MANDIR="%{_mandir}" \
104 INCLUDEDIR="%{_includedir}" \
105 %scons install
106
107 %{__python} pyregfi-distutils.py install \
108         --prefix=%{_prefix} \
109         --install-purelib=%{py_sitescriptdir} \
110         --install-platlib=%{py_sitedir} \
111         --optimize=2 \
112         --root=$RPM_BUILD_ROOT
113
114 # fix soname
115 mv $RPM_BUILD_ROOT%{_libdir}/libregfi.so{,.%{version}}
116 ln -sf libregfi.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libregfi.so.1
117 ln -sf libregfi.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libregfi.so
118
119 %py_postclean
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %post libs -p /sbin/ldconfig
125 %postun libs -p /sbin/ldconfig
126
127 %files
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_bindir}/*
130 %{_mandir}/man1/reglookup*.1*
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/*.so.*.*.*
135 %attr(755,root,root) %{_libdir}/*.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_libdir}/*.so
140 %{_includedir}/regfi
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/lib*.a
145
146 %files -n python-pyregfi
147 %defattr(644,root,root,755)
148 %dir %{py_sitescriptdir}/pyregfi
149 %{py_sitescriptdir}/pyregfi/*.py[co]
150 %{py_sitescriptdir}/*.egg-info
This page took 0.139249 seconds and 3 git commands to generate.