]> git.pld-linux.org Git - packages/quota.git/commitdiff
- -d option for warnquota (don't attach quota report in email) auto/ac/quota-3_09-2
authorTomek Orzechowski <orzech@pld-linux.org>
Thu, 2 Oct 2003 13:05:35 +0000 (13:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    quota-warnquota_nodetails.patch -> 1.1
    quota.spec -> 1.65

quota-warnquota_nodetails.patch [new file with mode: 0644]
quota.spec

diff --git a/quota-warnquota_nodetails.patch b/quota-warnquota_nodetails.patch
new file mode 100644 (file)
index 0000000..09fb567
--- /dev/null
@@ -0,0 +1,67 @@
+--- quota-tools/warnquota.c.orig       Thu Oct  2 13:53:57 2003
++++ quota-tools/warnquota.c    Thu Oct  2 14:02:41 2003
+@@ -76,6 +76,7 @@
+ #define FL_USER 1
+ #define FL_GROUP 2
+ #define FL_NOAUTOFS 4
++#define FL_NODETAILS 8
+ struct usage {
+       char *devicename;
+@@ -255,7 +256,7 @@
+               else
+                       fprintf(fp, DEF_GROUP_MESSAGE, offender->offender_name);
+-      for (lptr = offender->usage; lptr; lptr = lptr->next) {
++      for (lptr = offender->usage; !(flags & FL_NODETAILS) && lptr; lptr = lptr->next) {
+               dqb = &lptr->dq_dqb;
+               for (cnt = 0; cnt < qtab_i; cnt++)
+                       if (!strcmp(quotatable[cnt].devname, lptr->devicename)) {
+@@ -599,14 +600,14 @@
+ /* Print usage information */
+ static void usage(void)
+ {
+-      errstr(_("Usage:\n  warnquota [-ugi] [-F quotaformat] [-c configfile] [-q quotatabfile]\n"));
++      errstr(_("Usage:\n  warnquota [-ugid] [-F quotaformat] [-c configfile] [-q quotatabfile]\n"));
+ }
+  
+ static void parse_options(int argcnt, char **argstr)
+ {
+       int ret;
+  
+-      while ((ret = getopt(argcnt, argstr, "ugVF:hc:q:a:i")) != -1) {
++      while ((ret = getopt(argcnt, argstr, "ugVF:hc:q:a:id")) != -1) {
+               switch (ret) {
+                 case '?':
+                 case 'h':
+@@ -636,6 +637,9 @@
+                 case 'i':
+                       flags |= FL_NOAUTOFS;
+                       break;
++                case 'd':
++                      flags |= FL_NODETAILS;
++                      break;
+               }
+       }
+       if (!(flags & FL_USER) && !(flags & FL_GROUP))
+--- quota-tools/warnquota.8.orig       Thu Oct  2 14:55:45 2003
++++ quota-tools/warnquota.8    Thu Oct  2 14:58:05 2003
+@@ -4,7 +4,7 @@
+ .SH SYNOPSIS
+ .B warnquota
+ [
+-.B \-ugi
++.B \-ugid
+ ] [
+ .B \-F
+ .I quotaformat
+@@ -67,6 +67,9 @@
+ .TP
+ .B \-i
+ ignore mountpoints mounted by automounter.
++.TP
++.B -d
++don't attach quota report in email.
+ .SH FILES
+ .PD 0
+ .TP 20
index 924b680a40075304cedbd354f5941d19a59afd2b..fdc7fc14ac9309e22d0da7df66016fe4c81360e4 100644 (file)
@@ -10,7 +10,7 @@ Summary(uk):  
 Summary(zh_CN):        ´ÅÅÌʹÓÃÇé¿öµÄ¼à¿Ø¹¤¾ß
 Name:          quota
 Version:       3.09
-Release:       1
+Release:       2
 Epoch:         1
 License:       BSD
 Group:         Applications/System
@@ -24,6 +24,7 @@ URL:          http://sourceforge.net/projects/linuxquota/
 Patch0:                %{name}-defaults.patch
 Patch1:                %{name}-missing-nls.patch
 Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-warnquota_nodetails.patch
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: e2fsprogs-devel
@@ -107,6 +108,7 @@ dla zdalnego systemu plik
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1 -b .orig
+%patch3 -p1
 
 %build
 %{__aclocal}
This page took 0.113526 seconds and 4 git commands to generate.