]> git.pld-linux.org Git - packages/quota.git/blob - quota.spec
- added kernel64 bcond to build 32bit userland for 64bit kernel
[packages/quota.git] / quota.spec
1 # TODO:
2 # - add warnquota as cron job
3 #
4 # Conditional build:
5 %bcond_with     kernel64        # build 32bit userland for 64bit kernel
6 #
7
8 # possibly also sparc and ppc
9 %ifnarch %{x86}
10 %undefine       with_kernel64
11 %endif
12
13 Summary:        Quota administration package%{?with_kernel64: - 32bit userland for 64bit kernel}
14 Summary(de.UTF-8):      Quotenverwaltungspaket
15 Summary(es.UTF-8):      Paquete de administración cuota
16 Summary(fr.UTF-8):      Paquetage de gestion des quotas
17 Summary(pl.UTF-8):      Pakiet administaracyjny Quota%{?with_kernel64: - 32 bitowe programy dla 64 bitowego jądra}
18 Summary(pt_BR.UTF-8):   Pacote de administração quota
19 Summary(ru.UTF-8):      Утилиты системного администратора для управления дисковыми квотами
20 Summary(tr.UTF-8):      Kota denetleme paketi
21 Summary(uk.UTF-8):      Утиліти системного адміністратора для керування дисковими квотами
22 Summary(zh_CN.UTF-8):   磁盘使用情况的监控工具
23 Name:           quota%{?with_kernel64:64}
24 Version:        3.15
25 Release:        1
26 Epoch:          1
27 License:        BSD
28 Group:          Applications/System
29 Source0:        http://dl.sourceforge.net/linuxquota/%{name}-%{version}.tar.gz
30 # Source0-md5:  5a1c2f5e669aba825e0126d2f30ee622
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
32 # Source1-md5:  05a209bc054366ea190d1c67669f9ca3
33 Source2:        r%{name}d.init
34 Source3:        r%{name}d.sysconfig
35 URL:            http://sourceforge.net/projects/linuxquota/
36 Patch0:         %{name}-defaults.patch
37 Patch1:         %{name}-pl.po-update.patch
38 Patch2:         %{name}-repquota-len-fix.patch
39 BuildRequires:  autoconf
40 BuildRequires:  automake
41 BuildRequires:  e2fsprogs-devel
42 BuildRequires:  gettext-devel
43 BuildRequires:  libwrap-devel
44 BuildRequires:  rpmbuild(macros) >= 1.268
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Quotas allow the system administrator to limit disk usage by a user
49 and/or group per filesystem. This package contains the tools which are
50 needed to enable, modify, and update quotas.
51
52 %description -l de.UTF-8
53 Quotas gestatten es dem Systemadministrator, die Festplattennutzung
54 durch einen Anwender und/oder Gruppen pro Dateisystem zu beschränken.
55 Es enthält die Tools, die zur Aktivierung, Modifikation und zum
56 Aktualisieren von Quoten erforderlich sind."
57
58 %description -l es.UTF-8
59 Cuotas permite al administrador del sistema limitar el uso de disco
60 por un usuario y/o grupo por sistema de archivos. Este paquete
61 contiene las herramientas que son necesarias para activar, modificar y
62 actualizar cuotas.
63
64 %description -l fr.UTF-8
65 Les quotas permettant à l'administrateur système de limiter
66 l'utilisation disque par un utilisateur et/ou un groupe par système de
67 fichiers. Ce paquetage contient les outils nécessaires à la mise en
68 place, la modification et la mise à jour des quotas.
69
70 %description -l pl.UTF-8
71 Quota pozwala administratorowi systemu na ograniczanie wielkości
72 miejsca na dysku dla użytkownika/grupy. Pakiet ten zawiera narzędzia
73 do aktywacji i modyfikacji Quoty.
74
75 %description -l pt_BR.UTF-8
76 Quotas permite ao administrador do sistema limitar o uso de disco por
77 um usuário e/ou grupo por sistema de arquivos. Este pacote contém as
78 ferramentas que são necessárias para ativar, modificar e atualizar
79 quotas.
80
81 %description -l ru.UTF-8
82 Пакет quota содержит утилиты системного администратора для мониторинга
83 и ограничения использования дискового пространства пользователями и их
84 группами в каждой файловой системе.
85
86 %description -l tr.UTF-8
87 Kota, sistem yöneticisine, bir kullanıcının ya da kullanıcı grubunun
88 disk kullanımını sınırlama yeteneği verir. Bu paket içerisindeki
89 yazılımlar kota sistemini kullanmak için gereken kontrol
90 yazılımlarıdır.
91
92 %description -l uk.UTF-8
93 Пакет quota містить утиліти системного адміністратора для моніторингу
94 та обмеження використання дискового простору користувачами та їх
95 групами в кожній файловій системі.
96
97 %package rquotad
98 Summary:        Remote quota server
99 Summary(pl.UTF-8):      Zdalny serwer quota
100 Group:          Networking/Daemons
101 Requires(post,preun):   /sbin/chkconfig
102 Requires:       portmap >= 4.0
103 Requires:       rc-scripts >= 0.4.1.5
104 Obsoletes:      nfs-utils-rquotad
105
106 %description rquotad
107 rquotad is an rpc(3N) server which returns quotas for a user of a
108 local file system which is mounted by a remote machine over the NFS.
109 The results are used by quota(1) to display user quotas for remote
110 file systems.
111
112 %description rquotad -l pl.UTF-8
113 rquotad jest serverem rpc(3N), który zwraca quoty użytkownika
114 lokalnego systemu plików, który jest zamountowany przez zdalną maszynę
115 poprzez NFS. Rezultaty są używane przez quota(1), aby wyświetlić quote
116 dla zdalnego systemu plików.
117
118 %prep
119 %setup -q -n %{name}-tools
120 %patch0 -p1
121 %patch1 -p1
122 %patch2 -p1
123
124 %build
125 %{__aclocal}
126 %{__autoconf}
127
128 %if %{with kernel64}
129 CFLAGS="%{rpmcflags} -malign-double"
130 export CFLAGS
131 %endif
132
133 %configure \
134         --enable-rpcsetquota
135
136 %{__make}
137
138 %install
139 rm -rf $RPM_BUILD_ROOT
140 install -d $RPM_BUILD_ROOT{/sbin,/etc/{rc.d/init.d,sysconfig}}
141
142 %{__make} install \
143         ROOTDIR=$RPM_BUILD_ROOT
144
145 # essential, used by rc-scripts
146 mv -f $RPM_BUILD_ROOT%{_sbindir}/{quotacheck,quotaon,quotaoff,convertquota} \
147         $RPM_BUILD_ROOT/sbin
148
149 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rquotad
150 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/rquotad
151
152 echo ".so quotaon.8" > $RPM_BUILD_ROOT%{_mandir}/man8/quotaoff.8
153 echo ".so rquotad.8" >  $RPM_BUILD_ROOT%{_mandir}/man8/rpc.rquotad.8
154
155 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
156
157 %find_lang quota
158
159 %clean
160 rm -rf $RPM_BUILD_ROOT
161
162 %post rquotad
163 /sbin/chkconfig --add rquotad
164 %service rquotad restart "RPC rquotad"
165
166 %preun rquotad
167 if [ "$1" = "0" ]; then
168         %service rquotad stop
169         /sbin/chkconfig --del rquotad
170 fi
171
172 %triggerpostun rquotad -- %{name}-rquotad < 3.14-3
173 /sbin/chkconfig rquotad reset
174
175 %files -f quota.lang
176 %defattr(644,root,root,755)
177 %doc Changelog doc/{quotas-1.eps,quotas.ms} quotatab
178 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/quotagrpadmins
179 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/quotatab
180 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/warnquota.conf
181 %attr(755,root,root) /sbin/convertquota
182 %attr(755,root,root) /sbin/quotacheck
183 %attr(755,root,root) /sbin/quotaoff
184 %attr(755,root,root) /sbin/quotaon
185 %attr(755,root,root) %{_sbindir}/edquota
186 %attr(755,root,root) %{_sbindir}/quotastats
187 %attr(755,root,root) %{_sbindir}/quot
188 %attr(755,root,root) %{_sbindir}/repquota
189 %attr(755,root,root) %{_sbindir}/setquota
190 %attr(755,root,root) %{_sbindir}/warnquota
191 %attr(755,root,root) %{_sbindir}/xqmstats
192 %attr(755,root,root) %{_bindir}/*
193
194 %{_mandir}/man1/*
195 %{_mandir}/man8/quot*.8*
196 %{_mandir}/man8/*quota.8*
197 %{_mandir}/man8/xqmstats.8*
198
199 %lang(fi) %{_mandir}/fi/man1/*
200
201 %lang(hu) %{_mandir}/hu/man8/*
202
203 %lang(ja) %{_mandir}/ja/man1/*
204 %lang(ja) %{_mandir}/ja/man8/quota*
205 %lang(ja) %{_mandir}/ja/man8/edquota.8*
206 %lang(ja) %{_mandir}/ja/man8/repquota.8*
207 %lang(ja) %{_mandir}/ja/man8/setquota.8*
208
209 %lang(pl) %{_mandir}/pl/man1/*
210 %lang(pl) %{_mandir}/pl/man8/*
211
212 %files rquotad
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_sbindir}/rpc.rquotad
215 %attr(754,root,root) /etc/rc.d/init.d/rquotad
216 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/rquotad
217
218 %{_mandir}/man8/*rquotad.8*
219 %lang(fr) %{_mandir}/fr/man8/*rquotad.8*
220 %lang(ja) %{_mandir}/ja/man8/*rquotad.8*
This page took 0.515048 seconds and 4 git commands to generate.