]> git.pld-linux.org Git - packages/quickjs.git/blob - quickjs.spec
BRs for tar.xz source
[packages/quickjs.git] / quickjs.spec
1 %define         ver     2021-03-27
2 Summary:        QuickJS Javascript Engine
3 Summary(pl.UTF-8):      Silnik Javascriptu QuickJS
4 Name:           quickjs
5 Version:        20210327
6 Release:        4
7 License:        MIT
8 Group:          Libraries
9 Source0:        https://bellard.org/quickjs/%{name}-%{ver}.tar.xz
10 # Source0-md5:  135182a626aa0c87a49aa2bf58fd39bf
11 Patch0:         rpmpldcflags.patch
12 Patch1:         q.diff
13 URL:            https://bellard.org/quickjs/
14 BuildRequires:  libtool
15 BuildRequires:  rpmbuild(macros) >= 1.583
16 BuildRequires:  tar >= 1:1.22
17 BuildRequires:  xz
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 QuickJS is a small and embeddable Javascript engine. It supports the
22 ES2020 specification including modules, asynchronous generators,
23 proxies and BigInt. It supports mathematical extensions such as big
24 decimal float float numbers (BigDecimal), big binary floating point
25 numbers (BigFloat), and operator overloading.
26
27 %description -l pl.UTF-8
28 QuickJS jest małym osadzalnym silnikiem Javascriptu. Wspiera
29 specyfikację ES2020, w tym moduły, asynchroniczne generatory, proxy i
30 BigInt. Wspiera też rozszerzenia matematyczne, takie jak liczby
31 BigDecimal, BigFloat i przeciążenia operatorów.
32
33 %package devel
34 Summary:        Header files for QuickJS library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QuickJS
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for QuickJS library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki QuickJS.
44
45 %prep
46 %setup -q -n %{name}-%{ver}
47 %patch0 -p1
48 %patch1 -p1
49
50 %build
51 %{__make} \
52         CC="%{__cc}" \
53         RPMPLDCFLAGS="%{rpmcflags} %{rpmcppflags}" \
54         LDFLAGS="%{rpmldflags} %{rpmcflags}" \
55         prefix="%{_prefix}"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_libdir}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT \
63         STRIP=true \
64         prefix="%{_prefix}"
65
66 %if "%{_lib}" != "lib"
67 %{__mv} $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}/%{name}
68 %endif
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %attr(755,root,root) %{_bindir}/qjs
76 %attr(755,root,root) %{_bindir}/qjsc
77 %attr(755,root,root) %{_bindir}/qjscalc
78
79 %files devel
80 %defattr(644,root,root,755)
81 %doc doc/*.html
82 %dir %{_libdir}/%{name}
83 %{_libdir}/%{name}/libquickjs.a
84 %{_libdir}/%{name}/libquickjs.lto.a
85 %{_includedir}/%{name}
This page took 0.554142 seconds and 4 git commands to generate.