]> git.pld-linux.org Git - packages/qt5-qtwebkit.git/commitdiff
- added gstreamer patch (adjust for current GstAppSinkCallbacks)
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 29 Jun 2022 04:14:12 +0000 (06:14 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 29 Jun 2022 04:14:12 +0000 (06:14 +0200)
qt5-qtwebkit-gstreamer.patch [new file with mode: 0644]
qt5-qtwebkit.spec

diff --git a/qt5-qtwebkit-gstreamer.patch b/qt5-qtwebkit-gstreamer.patch
new file mode 100644 (file)
index 0000000..1ba4f77
--- /dev/null
@@ -0,0 +1,11 @@
+--- qtwebkit-5.212.0-alpha4/Source/WebCore/platform/audio/gstreamer/AudioFileReaderGStreamer.cpp.orig  2020-03-04 18:16:37.000000000 +0100
++++ qtwebkit-5.212.0-alpha4/Source/WebCore/platform/audio/gstreamer/AudioFileReaderGStreamer.cpp       2022-06-28 19:21:04.705394935 +0200
+@@ -230,7 +230,7 @@ void AudioFileReader::handleNewDeinterle
+         [](GstAppSink* sink, gpointer userData) -> GstFlowReturn {
+             return static_cast<AudioFileReader*>(userData)->handleSample(sink);
+         },
+-        { nullptr }
++        nullptr // new_event
+     };
+     gst_app_sink_set_callbacks(GST_APP_SINK(sink), &callbacks, this, 0);
index d228bb16c37ff0fc491084fca8c903f208a60f99..ee73eb2e0c39c87df6b6e48a85de7d0ec0f269a4 100644 (file)
@@ -43,6 +43,7 @@ Source0:      https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-%{versi
 Patch0:                %{name}-css.patch
 Patch1:                %{name}-docs.patch
 Patch2:                glib2.68.patch
+Patch3:                %{name}-gstreamer.patch
 # from FC
 Patch102:      qtwebkit-5.212.0_cmake_cmp0071.patch
 Patch108:      x32.patch
@@ -193,6 +194,7 @@ Dokumentacja do bibliotek Qt5 WebKit w formacie QCH.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 %patch102 -p1
 %patch108 -p1
 
This page took 0.159674 seconds and 4 git commands to generate.