]> git.pld-linux.org Git - packages/qt5-qtsvg.git/blob - qt5-qtsvg.spec
up to 5.15.13
[packages/qt5-qtsvg.git] / qt5-qtsvg.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtsvg
6 %define         qtbase_ver      %{version}
7 %define         qttools_ver     %{version}
8 Summary:        The Qt5 Svg library
9 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
10 Name:           qt5-%{orgname}
11 Version:        5.15.13
12 Release:        1
13 License:        LGPL v3 or GPL v2 or GPL v3 or comercial
14 Group:          X11/Libraries
15 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
16 # Source0-md5:  480f00693f742c1b12f88385e538f1be
17 Patch0:         CVE-2023-32573-qtsvg-5.15.diff
18 URL:            https://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
21 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
22 # for examples
23 BuildRequires:  Qt5OpenGL-devel >= %{qtbase_ver}
24 # for tests
25 BuildRequires:  Qt5Xml-devel >= %{qtbase_ver}
26 %if %{with doc}
27 BuildRequires:  qt5-assistant >= %{qttools_ver}
28 %endif
29 BuildRequires:  qt5-build >= %{qtbase_ver}
30 BuildRequires:  qt5-qmake >= %{qtbase_ver}
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 2.016
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRequires:  zlib-devel
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %define         specflags       -fno-strict-aliasing
39 %define         qt5dir          %{_libdir}/qt5
40
41 %description
42 Qt is a cross-platform application and UI framework. Using Qt, you can
43 write web-enabled applications once and deploy them across desktop,
44 mobile and embedded systems without rewriting the source code.
45
46 This package contains Qt5 Svg library.
47
48 %description -l pl.UTF-8
49 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
50 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
51 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
52 źródłowego.
53
54 Ten pakiet zawiera bibliotekę Qt5 Svg.
55
56 %package -n Qt5Svg
57 Summary:        The Qt5 Svg library
58 Summary(pl.UTF-8):      Biblioteka Qt5 Svg
59 Group:          Libraries
60 %requires_eq_to Qt5Core Qt5Core-devel
61 Requires:       Qt5Gui >= %{qtbase_ver}
62 Requires:       Qt5Widgets >= %{qtbase_ver}
63 Obsoletes:      qt5-qtsvg < 5.3.0
64
65 %description -n Qt5Svg
66 Qt5 Svg library provides functionality for handling SVG images.
67
68 %description -n Qt5Svg -l pl.UTF-8
69 Biblioteka Qt5 Svg udostępnia obsługę obrazów SVG.
70
71 %package -n Qt5Svg-devel
72 Summary:        Qt5 Svg library - development files
73 Summary(pl.UTF-8):      Biblioteka Qt5 Svg - pliki programistyczne
74 Group:          X11/Development/Libraries
75 Requires:       Qt5Core-devel >= %{qtbase_ver}
76 Requires:       Qt5Gui-devel >= %{qtbase_ver}
77 Requires:       Qt5Svg = %{version}-%{release}
78 Requires:       Qt5Widgets-devel >= %{qtbase_ver}
79 Requires:       zlib-devel
80 Obsoletes:      qt5-qtsvg-devel < 5.3.0
81
82 %description -n Qt5Svg-devel
83 Qt5 Svg library - development files.
84
85 %description -n Qt5Svg-devel -l pl.UTF-8
86 Biblioteka Qt5 Svg - pliki programistyczne.
87
88 %package doc
89 Summary:        Qt5 Svg documentation in HTML format
90 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie HTML
91 Group:          Documentation
92 Requires:       qt5-doc-common >= %{qtbase_ver}
93 BuildArch:      noarch
94
95 %description doc
96 Qt5 Svg documentation in HTML format.
97
98 %description doc -l pl.UTF-8
99 Dokumentacja do biblioteki Qt5 Svg w formacie HTML.
100
101 %package doc-qch
102 Summary:        Qt5 Svg documentation in QCH format
103 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Svg w formacie QCH
104 Group:          Documentation
105 Requires:       qt5-doc-common >= %{qtbase_ver}
106 BuildArch:      noarch
107
108 %description doc-qch
109 Qt5 Svg documentation in QCH format.
110
111 %description doc-qch -l pl.UTF-8
112 Dokumentacja do biblioteki Qt5 Svg w formacie QCH.
113
114 %package examples
115 Summary:        Qt5 Svg examples
116 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Svg
117 Group:          X11/Development/Libraries
118 BuildArch:      noarch
119
120 %description examples
121 Qt5 Svg examples.
122
123 %description examples -l pl.UTF-8
124 Przykłady do biblioteki Qt5 Svg.
125
126 %prep
127 %setup -q -n %{orgname}-everywhere-src-%{version}
128 %patch0 -p1
129
130 %build
131 %{qmake_qt5}
132 %{__make}
133 %{?with_doc:%{__make} docs}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         INSTALL_ROOT=$RPM_BUILD_ROOT
140
141 %if %{with doc}
142 %{__make} install_docs \
143         INSTALL_ROOT=$RPM_BUILD_ROOT
144 %endif
145
146 # useless symlinks
147 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
148 # actually drop *.la, follow policy of not packaging them when *.pc exist
149 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
150
151 # Prepare some files list
152 ifecho() {
153         r="$RPM_BUILD_ROOT$2"
154         if [ -d "$r" ]; then
155                 echo "%%dir $2" >> $1.files
156         elif [ -x "$r" ] ; then
157                 echo "%%attr(755,root,root) $2" >> $1.files
158         elif [ -f "$r" ]; then
159                 echo "$2" >> $1.files
160         else
161                 echo "Error generation $1 files list!"
162                 echo "$r: no such file or directory!"
163                 return 1
164         fi
165 }
166 ifecho_tree() {
167         ifecho $1 $2
168         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
169                 ifecho $1 $2/$f
170         done
171 }
172
173 echo "%defattr(644,root,root,755)" > examples.files
174 ifecho_tree examples %{_examplesdir}/qt5/svg
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %post   -n Qt5Svg -p /sbin/ldconfig
180 %postun -n Qt5Svg -p /sbin/ldconfig
181
182 %files -n Qt5Svg
183 %defattr(644,root,root,755)
184 %doc dist/changes-*
185 %attr(755,root,root) %{_libdir}/libQt5Svg.so.*.*.*
186 %attr(755,root,root) %ghost %{_libdir}/libQt5Svg.so.5
187 # R: Core Gui Svg
188 %attr(755,root,root) %{qt5dir}/plugins/iconengines/libqsvgicon.so
189 # R: Core Gui Svg
190 %attr(755,root,root) %{qt5dir}/plugins/imageformats/libqsvg.so
191
192 %files -n Qt5Svg-devel
193 %defattr(644,root,root,755)
194 %attr(755,root,root) %{_libdir}/libQt5Svg.so
195 %{_libdir}/libQt5Svg.prl
196 %{_includedir}/qt5/QtSvg
197 %{_pkgconfigdir}/Qt5Svg.pc
198 %dir %{_libdir}/cmake/Qt5Svg
199 %{_libdir}/cmake/Qt5Svg/Qt5SvgConfig*.cmake
200 %{_libdir}/cmake/Qt5Gui/Qt5Gui_QSvgIconPlugin.cmake
201 %{_libdir}/cmake/Qt5Gui/Qt5Gui_QSvgPlugin.cmake
202 %{qt5dir}/mkspecs/modules/qt_lib_svg.pri
203 %{qt5dir}/mkspecs/modules/qt_lib_svg_private.pri
204
205 %if %{with doc}
206 %files doc
207 %defattr(644,root,root,755)
208 %{_docdir}/qt5-doc/qtsvg
209
210 %files doc-qch
211 %defattr(644,root,root,755)
212 %{_docdir}/qt5-doc/qtsvg.qch
213 %endif
214
215 %files examples -f examples.files
216 %defattr(644,root,root,755)
217 # XXX: dir shared with qt5-qtbase-examples
218 %dir %{_examplesdir}/qt5
This page took 0.123796 seconds and 4 git commands to generate.