]> git.pld-linux.org Git - packages/qt5-qtspeech.git/blob - qt5-qtspeech.spec
up to 5.15.13
[packages/qt5-qtspeech.git] / qt5-qtspeech.spec
1 #
2 # Conditional build:
3 %bcond_without  doc                     # documentation
4 %bcond_without  flite                   # Flite plugin
5 %bcond_without  speech_dispatcher       # Speech Dispatcher plugin
6
7 %define         orgname         qtspeech
8 %define         qtbase_ver              %{version}
9 %define         qttools_ver             %{version}
10 %define         qtxmlpatterns_ver       %{version}
11 Summary:        The Qt5 Speech library
12 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
13 Name:           qt5-%{orgname}
14 Version:        5.15.13
15 Release:        1
16 License:        LGPL v3 or GPL v2+ or commercial
17 Group:          Libraries
18 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
19 # Source0-md5:  a8eff80706ba3fc12c6f70d198c78736
20 URL:            https://www.qt.io/
21 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
22 BuildRequires:  Qt5Gui-devel >= %{qtbase_ver}
23 BuildRequires:  Qt5Multimedia-devel >= %{qtbase_ver}
24 BuildRequires:  Qt5Widgets-devel >= %{qtbase_ver}
25 BuildRequires:  Qt5XmlPatterns-devel >= %{qtxmlpatterns_ver}
26 BuildRequires:  qt5-doc-common >= %{qtbase_ver}
27 %if %{with flite}
28 BuildRequires:  flite-devel >= 2.1
29 %endif
30 %if %{with doc}
31 BuildRequires:  qt5-assistant >= %{qttools_ver}
32 %endif
33 BuildRequires:  qt5-build >= %{qtbase_ver}
34 BuildRequires:  qt5-qmake >= %{qtbase_ver}
35 BuildRequires:  rpm-build >= 4.6
36 BuildRequires:  rpmbuild(macros) >= 2.016
37 %if %{with speech_dispatcher}
38 BuildRequires:  speech-dispatcher-devel
39 %endif
40 BuildRequires:  tar >= 1:1.22
41 BuildRequires:  xz
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         specflags       -fno-strict-aliasing
45 %define         qt5dir          %{_libdir}/qt5
46
47 %description
48 Qt is a cross-platform application and UI framework. Using Qt, you can
49 write web-enabled applications once and deploy them across desktop,
50 mobile and embedded systems without rewriting the source code.
51
52 This package contains Qt5 Speech library.
53
54 %description -l pl.UTF-8
55 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
56 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
57 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
58 źródłowego.
59
60 Ten pakiet zawiera bibliotekę Qt5 Speech.
61
62 %package -n Qt5Speech
63 Summary:        The Qt5 Speech library
64 Summary(pl.UTF-8):      Biblioteka Qt5 Speech
65 Group:          Libraries
66 %requires_eq_to Qt5Core Qt5Core-devel
67
68 %description -n Qt5Speech
69 Qt5 Speech library.
70
71 %description -n Qt5Speech -l pl.UTF-8
72 Biblioteka Qt5 Speech.
73
74 %package -n Qt5Speech-devel
75 Summary:        Qt5 Speech library - development files
76 Summary(pl.UTF-8):      Biblioteka Qt5 Speech - pliki programistyczne
77 Group:          Development/Libraries
78 Requires:       Qt5Core-devel >= %{qtbase_ver}
79 Requires:       Qt5Speech = %{version}-%{release}
80
81 %description -n Qt5Speech-devel
82 Qt5 Speech library - development files.
83
84 %description -n Qt5Speech-devel -l pl.UTF-8
85 Biblioteka Qt5 Speech - pliki programistyczne.
86
87 %package -n Qt5Speech-plugin-speechd
88 Summary:        Speech Dispatcher plugin for Qt5 Speech library
89 Summary(pl.UTF-8):      Wtyczka Speech Dispatcher do biblioteki Qt5 Speech
90 Group:          Libraries
91 Requires:       Qt5Speech = %{version}-%{release}
92
93 %description -n Qt5Speech-plugin-speechd
94 Speech Dispatcher plugin for Qt5 Speech library.
95
96 %description -n Qt5Speech-plugin-speechd -l pl.UTF-8
97 Wtyczka Speech Dispatcher do biblioteki Qt5 Speech
98
99 %package -n Qt5Speech-plugin-flite
100 Summary:        flite plugin for Qt5 Speech library
101 Summary(pl.UTF-8):      Wtyczka flite do biblioteki Qt5 Speech
102 Group:          Libraries
103 Requires:       Qt5Speech = %{version}-%{release}
104 Requires:       flite >= 2.1
105
106 %description -n Qt5Speech-plugin-flite
107 flite plugin for Qt5 Speech library.
108
109 %description -n Qt5Speech-plugin-flite -l pl.UTF-8
110 Wtyczka flite do biblioteki Qt5 Speech
111
112 %package doc
113 Summary:        Qt5 Speech documentation in HTML format
114 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie HTML
115 License:        FDL v1.3
116 Group:          Documentation
117 Requires:       qt5-doc-common >= %{qtbase_ver}
118 BuildArch:      noarch
119
120 %description doc
121 Qt5 Speech documentation in HTML format.
122
123 %description doc -l pl.UTF-8
124 Dokumentacja do biblioteki Qt5 Speech w formacie HTML.
125
126 %package doc-qch
127 Summary:        Qt5 Speech documentation in QCH format
128 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Speech w formacie QCH
129 License:        FDL v1.3
130 Group:          Documentation
131 Requires:       qt5-doc-common >= %{qtbase_ver}
132 BuildArch:      noarch
133
134 %description doc-qch
135 Qt5 Speech documentation in QCH format.
136
137 %description doc-qch -l pl.UTF-8
138 Dokumentacja do biblioteki Qt5 Speech w formacie QCH.
139
140 %package examples
141 Summary:        Qt5 Speech examples
142 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Speech
143 License:        BSD or commercial
144 Group:          Development/Libraries
145 BuildArch:      noarch
146
147 %description examples
148 Qt5 Speech examples.
149
150 %description examples -l pl.UTF-8
151 Przykłady do biblioteki Qt5 Speech.
152
153 %prep
154 %setup -q -n %{orgname}-everywhere-src-%{version}
155
156 %build
157 %{qmake_qt5} -- \
158         -%{!?with_flite:no-}flite \
159         -%{!?with_speech_dispatcher:no-}speechd
160 %{__make}
161 %{?with_doc:%{__make} docs}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 %{__make} install \
167         INSTALL_ROOT=$RPM_BUILD_ROOT
168
169 %if %{with doc}
170 %{__make} install_docs \
171         INSTALL_ROOT=$RPM_BUILD_ROOT
172 %endif
173
174 # useless symlinks
175 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
176 # actually drop *.la, follow policy of not packaging them when *.pc exist
177 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
178
179 # Prepare some files list
180 ifecho() {
181         r="$RPM_BUILD_ROOT$2"
182         if [ -d "$r" ]; then
183                 echo "%%dir $2" >> $1.files
184         elif [ -x "$r" ] ; then
185                 echo "%%attr(755,root,root) $2" >> $1.files
186         elif [ -f "$r" ]; then
187                 echo "$2" >> $1.files
188         else
189                 echo "Error generation $1 files list!"
190                 echo "$r: no such file or directory!"
191                 return 1
192         fi
193 }
194 ifecho_tree() {
195         ifecho $1 $2
196         for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
197                 ifecho $1 $2/$f
198         done
199 }
200
201 echo "%defattr(644,root,root,755)" > examples.files
202 ifecho_tree examples %{_examplesdir}/qt5/speech
203
204 %clean
205 rm -rf $RPM_BUILD_ROOT
206
207 %post   -n Qt5Speech -p /sbin/ldconfig
208 %postun -n Qt5Speech -p /sbin/ldconfig
209
210 %files -n Qt5Speech
211 %defattr(644,root,root,755)
212 %doc dist/changes-*
213 # R: Core
214 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so.*.*.*
215 %attr(755,root,root) %ghost %{_libdir}/libQt5TextToSpeech.so.5
216 %dir %{_libdir}/qt5/plugins/texttospeech
217 %dir %{_libdir}/cmake/Qt5TextToSpeech
218
219 %files -n Qt5Speech-devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libQt5TextToSpeech.so
222 %{_libdir}/libQt5TextToSpeech.prl
223 %{_includedir}/qt5/QtTextToSpeech
224 %{_pkgconfigdir}/Qt5TextToSpeech.pc
225 %{_libdir}/cmake/Qt5TextToSpeech/Qt5TextToSpeechConfig*.cmake
226 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech.pri
227 %{qt5dir}/mkspecs/modules/qt_lib_texttospeech_private.pri
228
229 %files -n Qt5Speech-plugin-speechd
230 %defattr(644,root,root,755)
231 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqtexttospeech_speechd.so
232 %{_libdir}/cmake/Qt5TextToSpeech/Qt5TextToSpeech_QTextToSpeechPluginSpeechd.cmake
233
234 %if %{with flite}
235 %files -n Qt5Speech-plugin-flite
236 %defattr(644,root,root,755)
237 %attr(755,root,root) %{_libdir}/qt5/plugins/texttospeech/libqttexttospeech_flite.so
238 %{_libdir}/cmake/Qt5TextToSpeech/Qt5TextToSpeech_QTextToSpeechEngineFlite.cmake
239 %endif
240
241 %if %{with doc}
242 %files doc
243 %defattr(644,root,root,755)
244 %{_docdir}/qt5-doc/qtspeech
245
246 %files doc-qch
247 %defattr(644,root,root,755)
248 %{_docdir}/qt5-doc/qtspeech.qch
249 %endif
250
251 %files examples -f examples.files
252 %defattr(644,root,root,755)
253 # XXX: dir shared with qt5-qtbase-examples
254 %dir %{_examplesdir}/qt5
This page took 0.164056 seconds and 4 git commands to generate.