]> git.pld-linux.org Git - packages/qt5-qtscxml.git/blob - qt5-qtscxml.spec
up to 5.15.9
[packages/qt5-qtscxml.git] / qt5-qtscxml.spec
1 #
2 # Conditional build:
3 %bcond_without  doc     # Documentation
4
5 %define         orgname         qtscxml
6 %define         qtbase_ver              %{version}
7 %define         qtdeclarative_ver       %{version}
8 %define         qttools_ver             %{version}
9 Summary:        The Qt5 Scxml library
10 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
11 Name:           qt5-%{orgname}
12 Version:        5.15.9
13 Release:        1
14 License:        LGPL v3 or GPL v2+ or commercial
15 Group:          X11/Libraries
16 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-opensource-src-%{version}.tar.xz
17 # Source0-md5:  9b709a2e7af4d4ba6b82a2d53c4cdb50
18 URL:            https://www.qt.io/
19 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
20 BuildRequires:  Qt5Qml-devel >= %{qtdeclarative_ver}
21 %if %{with doc}
22 BuildRequires:  qt5-assistant >= %{qttools_ver}
23 BuildRequires:  qt5-doc-common >= %{qttools_ver}
24 %endif
25 BuildRequires:  qt5-build >= %{qtbase_ver}
26 BuildRequires:  qt5-qmake >= %{qtbase_ver}
27 BuildRequires:  rpm-build >= 4.6
28 BuildRequires:  rpmbuild(macros) >= 2.016
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         specflags       -fno-strict-aliasing
34 %define         qt5dir          %{_libdir}/qt5
35
36 %description
37 Qt is a cross-platform application and UI framework. Using Qt, you can
38 write web-enabled applications once and deploy them across desktop,
39 mobile and embedded systems without rewriting the source code.
40
41 This package contains Qt5 Scxml library.
42
43 %description -l pl.UTF-8
44 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
45 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
46 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
47 źródłowego.
48
49 Ten pakiet zawiera bibliotekę Qt5 Scxml.
50
51 %package -n Qt5Scxml
52 Summary:        The Qt5 Scxml library
53 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml
54 Group:          X11/Libraries
55 Requires:       Qt5Core >= %{qtbase_ver}
56 Requires:       Qt5Qml >= %{qtdeclarative_ver}
57
58 %description -n Qt5Scxml
59 Qt5 Scxml library.
60
61 %description -n Qt5Scxml -l pl.UTF-8
62 Biblioteka Qt5 Scxml.
63
64 %package -n Qt5Scxml-devel
65 Summary:        Qt5 Scxml - development files
66 Summary(pl.UTF-8):      Biblioteka Qt5 Scxml - pliki programistyczne
67 Group:          X11/Development/Libraries
68 Requires:       Qt5Core-devel >= %{qtbase_ver}
69 Requires:       Qt5Qml-devel >= %{qtdeclarative_ver}
70 Requires:       Qt5Scxml = %{version}-%{release}
71
72 %description -n Qt5Scxml-devel
73 Qt5 Scxml - development files.
74
75 %description -n Qt5Scxml-devel -l pl.UTF-8
76 Biblioteka Qt5 Scxml - pliki programistyczne.
77
78 %package doc
79 Summary:        Qt5 Scxml documentation in HTML format
80 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie HTML
81 Group:          Documentation
82 Requires:       qt5-doc-common >= %{qtbase_ver}
83 BuildArch:      noarch
84
85 %description doc
86 Qt5 Scxml documentation in HTML format.
87
88 %description doc -l pl.UTF-8
89 Dokumentacja do biblioteki Qt5 Scxml w formacie HTML.
90
91 %package doc-qch
92 Summary:        Qt5 Scxml documentation in QCH format
93 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Scxml w formacie QCH
94 Group:          Documentation
95 Requires:       qt5-doc-common >= %{qtbase_ver}
96 BuildArch:      noarch
97
98 %description doc-qch
99 Qt5 Scxml documentation in QCH format.
100
101 %description doc-qch -l pl.UTF-8
102 Dokumentacja do biblioteki Qt5 Scxml w formacie QCH.
103
104 %package examples
105 Summary:        Qt5 Scxml examples
106 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Scxml
107 Group:          X11/Development/Libraries
108 BuildArch:      noarch
109
110 %description examples
111 Qt5 Scxml examples.
112
113 %description examples -l pl.UTF-8
114 Przykłady do biblioteki Qt5 Scxml.
115
116 %prep
117 %setup -q -n %{orgname}-everywhere-src-%{version}
118
119 %build
120 %{qmake_qt5}
121 %{__make}
122 %{?with_doc:%{__make} docs}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         INSTALL_ROOT=$RPM_BUILD_ROOT
129
130 %if %{with doc}
131 %{__make} install_docs \
132         INSTALL_ROOT=$RPM_BUILD_ROOT
133 %endif
134
135 # useless symlinks
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
137 # obsoleted by pkg-config
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %post   -n Qt5Scxml -p /sbin/ldconfig
144 %postun -n Qt5Scxml -p /sbin/ldconfig
145
146 %files -n Qt5Scxml
147 %defattr(644,root,root,755)
148 %doc LICENSE.GPL3-EXCEPT dist/changes-*
149 # R: Qt5Core Qt5Qml
150 %attr(755,root,root) %{_libdir}/libQt5Scxml.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/libQt5Scxml.so.5
152 # R: Qt5Core
153 %attr(755,root,root) %{qt5dir}/bin/qscxmlc
154 %dir %{qt5dir}/qml/QtScxml
155 # R: Qt5Core Qt5Qml Qt5Scxml
156 %attr(755,root,root) %{qt5dir}/qml/QtScxml/libdeclarative_scxml.so
157 %{qt5dir}/qml/QtScxml/plugins.qmltypes
158 %{qt5dir}/qml/QtScxml/qmldir
159
160 %files -n Qt5Scxml-devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libQt5Scxml.so
163 %{_libdir}/libQt5Scxml.prl
164 %{_includedir}/qt5/QtScxml
165 %{_pkgconfigdir}/Qt5Scxml.pc
166 %{_libdir}/cmake/Qt5Scxml
167 %{qt5dir}/mkspecs/features/qscxmlc.prf
168 %{qt5dir}/mkspecs/modules/qt_lib_scxml.pri
169 %{qt5dir}/mkspecs/modules/qt_lib_scxml_private.pri
170
171 %if %{with doc}
172 %files doc
173 %defattr(644,root,root,755)
174 %{_docdir}/qt5-doc/qtscxml
175
176 %files doc-qch
177 %defattr(644,root,root,755)
178 %{_docdir}/qt5-doc/qtscxml.qch
179 %endif
180
181 %files examples
182 %defattr(644,root,root,755)
183 # XXX: dir shared with qt5-qtbase-examples
184 %dir %{_examplesdir}/qt5
185 %{_examplesdir}/qt5/scxml
This page took 0.12544 seconds and 4 git commands to generate.