]> git.pld-linux.org Git - packages/qt5-qtnetworkauth.git/blob - qt5-qtnetworkauth.spec
- don't package compiled examples in noarch subpackage
[packages/qt5-qtnetworkauth.git] / qt5-qtnetworkauth.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # disable features to able to build without installed qt5
4 %bcond_without  doc             # documentation
5
6 %if %{with bootstrap}
7 %undefine       with_doc
8 %endif
9
10 %define         orgname         qtnetworkauth
11 %define         qtbase_ver              %{version}
12 %define         qtdeclarative_ver       %{version}
13 %define         qttools_ver             5.9
14 Summary:        The Qt5 Network Auth library
15 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth
16 Name:           qt5-%{orgname}
17 Version:        5.15.2
18 Release:        2
19 License:        GPL v3 or commercial
20 Group:          X11/Libraries
21 Source0:        https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
22 # Source0-md5:  a23c82ae0527d5bdde61882cabac1f01
23 URL:            https://www.qt.io/
24 BuildRequires:  Qt5Core-devel >= %{qtbase_ver}
25 BuildRequires:  Qt5Network-devel >= %{qtbase_ver}
26 %if %{with doc}
27 BuildRequires:  qt5-assistant >= %{qttools_ver}
28 %endif
29 BuildRequires:  qt5-build >= %{qtbase_ver}
30 BuildRequires:  qt5-qmake >= %{qtbase_ver}
31 BuildRequires:  rpm-build >= 4.6
32 BuildRequires:  rpmbuild(macros) >= 1.752
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         specflags       -fno-strict-aliasing
38 %define         qt5dir          %{_libdir}/qt5
39
40 %description
41 Qt is a cross-platform application and UI framework. Using Qt, you can
42 write web-enabled applications once and deploy them across desktop,
43 mobile and embedded systems without rewriting the source code.
44
45 This package contains Qt5 Network Auth library.
46
47 %description -l pl.UTF-8
48 Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
49 Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
50 systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
51 źródłowego.
52
53 Ten pakiet zawiera bibliotekę Qt5 Network Auth.
54
55 %package -n Qt5NetworkAuth
56 Summary:        The Qt5 Network Auth library
57 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth
58 Group:          Libraries
59 Requires:       Qt5Core >= %{qtbase_ver}
60 Requires:       Qt5Network >= %{qtbase_ver}
61
62 %description -n Qt5NetworkAuth
63 Qt5 Network Auth library provides classes for network authentication.
64
65 %description -n Qt5NetworkAuth -l pl.UTF-8
66 Biblioteka Qt5 Network Auth dostarcza klasy do uwierzytelniania w
67 sieci.
68
69 %package -n Qt5NetworkAuth-devel
70 Summary:        Qt5 Network Auth library - development files
71 Summary(pl.UTF-8):      Biblioteka Qt5 Network Auth - pliki programistyczne
72 Group:          Development/Libraries
73 Requires:       Qt5Core-devel >= %{qtbase_ver}
74 Requires:       Qt5Network-devel >= %{qtbase_ver}
75 Requires:       Qt5NetworkAuth = %{version}-%{release}
76
77 %description -n Qt5NetworkAuth-devel
78 Qt5 Network Auth library - development files.
79
80 %description -n Qt5NetworkAuth-devel -l pl.UTF-8
81 Biblioteka Qt5 NetworkAuth - pliki programistyczne.
82
83 %package doc
84 Summary:        Qt5 Network Auth documentation in HTML format
85 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Network Auth w formacie HTML
86 License:        FDL v1.3
87 Group:          Documentation
88 Requires:       qt5-doc-common >= %{qtbase_ver}
89 BuildArch:      noarch
90
91 %description doc
92 Qt5 Network Auth documentation in HTML format.
93
94 %description doc -l pl.UTF-8
95 Dokumentacja do biblioteki Qt5 Netwok Auth w formacie HTML.
96
97 %package doc-qch
98 Summary:        Qt5 Network Auth documentation in QCH format
99 Summary(pl.UTF-8):      Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH
100 License:        FDL v1.3
101 Group:          Documentation
102 Requires:       qt5-doc-common >= %{qtbase_ver}
103 BuildArch:      noarch
104
105 %description doc-qch
106 Qt5 Network Auth documentation in QCH format.
107
108 %description doc-qch -l pl.UTF-8
109 Dokumentacja do biblioteki Qt5 Network Auth w formacie QCH.
110
111 %package examples
112 Summary:        Qt5 Network Auth examples
113 Summary(pl.UTF-8):      Przykłady do biblioteki Qt5 Network Auth
114 License:        BSD or commercial
115 Group:          X11/Development/Libraries
116 BuildArch:      noarch
117
118 %description examples
119 Qt5 Network Auth examples.
120
121 %description examples -l pl.UTF-8
122 Przykłady do biblioteki Qt5 Network Auth.
123
124 %prep
125 %setup -q -n %{orgname}-everywhere-src-%{version}
126
127 %build
128 qmake-qt5
129 %{__make}
130
131 %{?with_doc:%{__make} docs}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         INSTALL_ROOT=$RPM_BUILD_ROOT
138
139 %if %{with doc}
140 %{__make} install_docs \
141         INSTALL_ROOT=$RPM_BUILD_ROOT
142 %endif
143
144 # useless symlinks
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
146 # actually drop *.la, follow policy of not packaging them when *.pc exist
147 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
148
149 %{__rm} $RPM_BUILD_ROOT%{_examplesdir}/qt5/oauth/redditclient/redditclient
150 %{__rm} $RPM_BUILD_ROOT%{_examplesdir}/qt5/oauth/twittertimeline/twittertimeline
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -n Qt5NetworkAuth -p /sbin/ldconfig
156 %postun -n Qt5NetworkAuth -p /sbin/ldconfig
157
158 %files -n Qt5NetworkAuth
159 %defattr(644,root,root,755)
160 %doc LICENSE.GPL3-EXCEPT dist/changes-*
161 %attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so.*.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libQt5NetworkAuth.so.5
163
164 %files -n Qt5NetworkAuth-devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libQt5NetworkAuth.so
167 %{_libdir}/libQt5NetworkAuth.prl
168 %{_includedir}/qt5/QtNetworkAuth
169 %{_libdir}/cmake/Qt5NetworkAuth
170 %{_pkgconfigdir}/Qt5NetworkAuth.pc
171 %{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth.pri
172 %{_libdir}/qt5/mkspecs/modules/qt_lib_networkauth_private.pri
173
174 %if %{with doc}
175 %files doc
176 %defattr(644,root,root,755)
177 %{_docdir}/qt5-doc/qtnetworkauth
178
179 %files doc-qch
180 %defattr(644,root,root,755)
181 %{_docdir}/qt5-doc/qtnetworkauth.qch
182 %endif
183
184 %files examples
185 %defattr(644,root,root,755)
186 # XXX: dir shared with qt5-qtbase-examples
187 %dir %{_examplesdir}/qt5
188 %{_examplesdir}/qt5/oauth
This page took 0.076646 seconds and 3 git commands to generate.