]> git.pld-linux.org Git - packages/qt4.git/commitdiff
- up to 4.8.5 auto/th/qt4-4.8.5-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Jul 2013 10:59:35 +0000 (12:59 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 2 Jul 2013 10:59:35 +0000 (12:59 +0200)
moc-boost148.patch [deleted file]
qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
qt4-CVE-2013-0254.patch [deleted file]
qt4.spec

diff --git a/moc-boost148.patch b/moc-boost148.patch
deleted file mode 100644 (file)
index f0ce656..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ur qt-everywhere-opensource-src-4.8.0/src/tools/moc/main.cpp qt-everywhere-opensource-src-4.8.0-moc-boost148/src/tools/moc/main.cpp
---- qt-everywhere-opensource-src-4.8.0/src/tools/moc/main.cpp  2011-10-04 05:44:32.000000000 +0200
-+++ qt-everywhere-opensource-src-4.8.0-moc-boost148/src/tools/moc/main.cpp     2011-12-04 00:11:25.000000000 +0100
-@@ -187,6 +187,7 @@
-     Moc moc;
-     pp.macros["Q_MOC_RUN"];
-     pp.macros["__cplusplus"];
-+    pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"]; // rh#756395
-     QByteArray filename;
-     QByteArray output;
-     FILE *in = 0;
index 85fc71a4d4969c947c3f2f54fb28c95c7107cc5d..cb3a59686633a2aa09dcce01f617a059dc30aa16 100644 (file)
@@ -1,32 +1,30 @@
 diff -up qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfilesystemengine_unix.cpp.QTBUG-4862 qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfilesystemengine_unix.cpp
 --- qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfilesystemengine_unix.cpp.QTBUG-4862    2012-09-10 20:36:50.000000000 -0500
 +++ qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfilesystemengine_unix.cpp       2012-10-22 14:16:42.672111081 -0500
-@@ -611,7 +611,26 @@ bool QFileSystemEngine::setPermissions(c
- QString QFileSystemEngine::homePath()
+@@ -624,6 +624,25 @@ QString QFileSystemEngine::homePath()
  {
      QString home = QFile::decodeName(qgetenv("HOME"));
--    if (home.isNull())
-+    if (home.isEmpty())
+     if (home.isEmpty())
 +    {
 +#if !defined(QT_NO_THREAD) && defined(_POSIX_THREAD_SAFE_FUNCTIONS) && !defined(Q_OS_OPENBSD)
-+        int size_max = sysconf(_SC_GETPW_R_SIZE_MAX);
-+        if (size_max == -1)
-+            size_max = 1024;
-+        QVarLengthArray<char, 1024> buf(size_max);
++          int size_max = sysconf(_SC_GETPW_R_SIZE_MAX);
++          if (size_max == -1)
++                  size_max = 1024;
++          QVarLengthArray<char, 1024> buf(size_max);
 +#endif
-+        struct passwd *pw = 0;
-+        uid_t user_id = getuid();
-+        pw = getpwuid(user_id);
++          struct passwd *pw = 0;
++          uid_t user_id = getuid();
++          pw = getpwuid(user_id);
 +#if !defined(QT_NO_THREAD) && defined(_POSIX_THREAD_SAFE_FUNCTIONS) && !defined(Q_OS_OPENBSD)
-+        struct passwd entry;
-+        getpwuid_r(user_id, &entry, buf.data(), buf.size(), &pw);
++          struct passwd entry;
++          getpwuid_r(user_id, &entry, buf.data(), buf.size(), &pw);
 +#else
-+        pw = getpwuid(user_id);
++          pw = getpwuid(user_id);
 +#endif
-+        home = QFile::decodeName(QByteArray(pw->pw_dir));
++          home = QFile::decodeName(QByteArray(pw->pw_dir));
 +    }
 +    if (home.isEmpty())
          home = rootPath();
      return QDir::cleanPath(home);
  }
-diff -up qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfsfileengine_unix.cpp.QTBUG-4862 qt-everywhere-opensource-src-4.8.3/src/corelib/io/qfsfileengine_unix.cpp
+
index 15105642bb7b72cb797a22f078b238025fb3ac9e..13e98b732efdc1cf2d5f23b4739f25c51c7ac775 100644 (file)
@@ -2,7 +2,7 @@ diff -up qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle.cpp.disable
 diff -up qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp.disable_gtk_theme_check qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp
 --- qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp.disable_gtk_theme_check  2012-11-23 04:09:53.000000000 -0600
 +++ qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp  2013-01-04 11:37:22.111481756 -0600
-@@ -503,21 +503,6 @@ void QGtkStylePrivate::initGtkWidgets()
+@@ -503,18 +503,6 @@ void QGtkStylePrivate::initGtkWidgets()
          return;
      }
  
@@ -10,10 +10,7 @@ diff -up qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp.disab
 -    if (!gtkWidgetMap()->contains("GtkWindow") && themeName.isEmpty()) {
 -        themeName = getThemeName();
 -
--        if (themeName.isEmpty()) {
--            qWarning("QGtkStyle was unable to detect the current GTK+ theme.");
--            return;
--        } else if (themeName == QLS("Qt") || themeName == QLS("Qt4")) {
+-        if (themeName == QLS("Qt") || themeName == QLS("Qt4")) {
 -            // Due to namespace conflicts with Qt3 and obvious recursion with Qt4,
 -            // we cannot support the GTK_Qt Gtk engine
 -            qWarning("QGtkStyle cannot be used together with the GTK_Qt engine.");
@@ -24,3 +21,4 @@ diff -up qt-everywhere-opensource-src-4.8.4/src/gui/styles/qgtkstyle_p.cpp.disab
      if (QGtkStylePrivate::gtk_init) {
          // Gtk will set the Qt error handler so we have to reset it afterwards
          x11ErrorHandler qt_x_errhandler = XSetErrorHandler(0);
+
diff --git a/qt4-CVE-2013-0254.patch b/qt4-CVE-2013-0254.patch
deleted file mode 100644 (file)
index c3f56e6..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-From 20b26bdb3dd5e46b01b9a7e1ce8342074df3c89c Mon Sep 17 00:00:00 2001
-From: Thiago Macieira <thiago.macieira@intel.com>
-Date: Sat, 22 Dec 2012 08:32:12 -0800
-Subject: [PATCH] Change all shmget calls to user-only memory
-
-Drop the read and write permissions for group and other users in the
-system.
-
-Change-Id: I8fc753f09126651af3fb82df3049050f0b14e876
-(cherry-picked from Qt 5 commit 856f209fb63ae336bfb389a12d2a75fa886dc1c5)
-Reviewed-by: Richard J. Moore <rich@kde.org>
----
- src/corelib/kernel/qsharedmemory_unix.cpp          |    6 +++---
- src/corelib/kernel/qsystemsemaphore_unix.cpp       |    4 ++--
- src/gui/image/qnativeimage.cpp                     |    2 +-
- src/gui/image/qpixmap_x11.cpp                      |    2 +-
- src/plugins/platforms/xcb/qxcbwindowsurface.cpp    |    2 +-
- src/plugins/platforms/xlib/qxlibwindowsurface.cpp  |    2 +-
- .../auto/qtipc/qsharedmemory/tst_qsharedmemory.cpp |    2 +-
- tools/qvfb/qvfbshmem.cpp                           |    4 ++--
- 8 files changed, 12 insertions(+), 12 deletions(-)
-
-diff --git a/src/corelib/kernel/qsharedmemory_unix.cpp b/src/corelib/kernel/qsharedmemory_unix.cpp
-index 20d76e3..4cf3acf 100644
---- a/src/corelib/kernel/qsharedmemory_unix.cpp
-+++ b/src/corelib/kernel/qsharedmemory_unix.cpp
-@@ -238,7 +238,7 @@ bool QSharedMemoryPrivate::create(int size)
-     }
-     // create
--    if (-1 == shmget(unix_key, size, 0666 | IPC_CREAT | IPC_EXCL)) {
-+    if (-1 == shmget(unix_key, size, 0600 | IPC_CREAT | IPC_EXCL)) {
-         QString function = QLatin1String("QSharedMemory::create");
-         switch (errno) {
-         case EINVAL:
-@@ -293,7 +293,7 @@ bool QSharedMemoryPrivate::attach(QSharedMemory::AccessMode mode)
- {
- #ifndef QT_POSIX_IPC
-     // grab the shared memory segment id
--    int id = shmget(unix_key, 0, (mode == QSharedMemory::ReadOnly ? 0444 : 0660));
-+    int id = shmget(unix_key, 0, (mode == QSharedMemory::ReadOnly ? 0400 : 0600));
-     if (-1 == id) {
-         setErrorString(QLatin1String("QSharedMemory::attach (shmget)"));
-         return false;
-@@ -381,7 +381,7 @@ bool QSharedMemoryPrivate::detach()
-     size = 0;
-     // Get the number of current attachments
--    int id = shmget(unix_key, 0, 0444);
-+    int id = shmget(unix_key, 0, 0400);
-     cleanHandle();
-     struct shmid_ds shmid_ds;
-diff --git a/src/corelib/kernel/qsystemsemaphore_unix.cpp b/src/corelib/kernel/qsystemsemaphore_unix.cpp
-index fad9acc..e77456b 100644
---- a/src/corelib/kernel/qsystemsemaphore_unix.cpp
-+++ b/src/corelib/kernel/qsystemsemaphore_unix.cpp
-@@ -153,10 +153,10 @@ key_t QSystemSemaphorePrivate::handle(QSystemSemaphore::AccessMode mode)
-     }
-     // Get semaphore
--    semaphore = semget(unix_key, 1, 0666 | IPC_CREAT | IPC_EXCL);
-+    semaphore = semget(unix_key, 1, 0600 | IPC_CREAT | IPC_EXCL);
-     if (-1 == semaphore) {
-         if (errno == EEXIST)
--            semaphore = semget(unix_key, 1, 0666 | IPC_CREAT);
-+            semaphore = semget(unix_key, 1, 0600 | IPC_CREAT);
-         if (-1 == semaphore) {
-             setErrorString(QLatin1String("QSystemSemaphore::handle"));
-             cleanHandle();
-diff --git a/src/gui/image/qnativeimage.cpp b/src/gui/image/qnativeimage.cpp
-index 9654afe..fef38c5 100644
---- a/src/gui/image/qnativeimage.cpp
-+++ b/src/gui/image/qnativeimage.cpp
-@@ -176,7 +176,7 @@ QNativeImage::QNativeImage(int width, int height, QImage::Format format,bool /*
-     bool ok;
-     xshminfo.shmid = shmget(IPC_PRIVATE, xshmimg->bytes_per_line * xshmimg->height,
--                            IPC_CREAT | 0777);
-+                            IPC_CREAT | 0700);
-     ok = xshminfo.shmid != -1;
-     if (ok) {
-         xshmimg->data = (char*)shmat(xshminfo.shmid, 0, 0);
-diff --git a/src/gui/image/qpixmap_x11.cpp b/src/gui/image/qpixmap_x11.cpp
-index 280d8bd..88c9b7b 100644
---- a/src/gui/image/qpixmap_x11.cpp
-+++ b/src/gui/image/qpixmap_x11.cpp
-@@ -193,7 +193,7 @@ static bool qt_create_mitshm_buffer(const QPaintDevice* dev, int w, int h)
-     bool ok;
-     xshminfo.shmid = shmget(IPC_PRIVATE,
-                              xshmimg->bytes_per_line * xshmimg->height,
--                             IPC_CREAT | 0777);
-+                             IPC_CREAT | 0700);
-     ok = xshminfo.shmid != -1;
-     if (ok) {
-         xshmimg->data = (char*)shmat(xshminfo.shmid, 0, 0);
-diff --git a/src/plugins/platforms/xcb/qxcbwindowsurface.cpp b/src/plugins/platforms/xcb/qxcbwindowsurface.cpp
-index b6a42d8..0d56821 100644
---- a/src/plugins/platforms/xcb/qxcbwindowsurface.cpp
-+++ b/src/plugins/platforms/xcb/qxcbwindowsurface.cpp
-@@ -98,7 +98,7 @@ QXcbShmImage::QXcbShmImage(QXcbScreen *screen, const QSize &size, uint depth, QI
-                                           0);
-     m_shm_info.shmid = shmget (IPC_PRIVATE,
--          m_xcb_image->stride * m_xcb_image->height, IPC_CREAT|0777);
-+          m_xcb_image->stride * m_xcb_image->height, IPC_CREAT|0600);
-     m_shm_info.shmaddr = m_xcb_image->data = (quint8 *)shmat (m_shm_info.shmid, 0, 0);
-     m_shm_info.shmseg = xcb_generate_id(xcb_connection());
-diff --git a/src/plugins/platforms/xlib/qxlibwindowsurface.cpp b/src/plugins/platforms/xlib/qxlibwindowsurface.cpp
-index bf003eb..46a2f97 100644
---- a/src/plugins/platforms/xlib/qxlibwindowsurface.cpp
-+++ b/src/plugins/platforms/xlib/qxlibwindowsurface.cpp
-@@ -99,7 +99,7 @@ void QXlibWindowSurface::resizeShmImage(int width, int height)
-     image_info->shminfo.shmid = shmget (IPC_PRIVATE,
--          image->bytes_per_line * image->height, IPC_CREAT|0777);
-+          image->bytes_per_line * image->height, IPC_CREAT|0700);
-     image_info->shminfo.shmaddr = image->data = (char*)shmat (image_info->shminfo.shmid, 0, 0);
-     image_info->shminfo.readOnly = False;
-diff --git a/tools/qvfb/qvfbshmem.cpp b/tools/qvfb/qvfbshmem.cpp
-index 7f9671f..84b6ebe 100644
---- a/tools/qvfb/qvfbshmem.cpp
-+++ b/tools/qvfb/qvfbshmem.cpp
-@@ -176,13 +176,13 @@ QShMemViewProtocol::QShMemViewProtocol(int displayid, const QSize &s,
-     uint data_offset_value = sizeof(QVFbHeader);
-     int dataSize = bpl * h + data_offset_value;
--    shmId = shmget(key, dataSize, IPC_CREAT | 0666);
-+    shmId = shmget(key, dataSize, IPC_CREAT | 0600);
-     if (shmId != -1)
-       data = (unsigned char *)shmat(shmId, 0, 0);
-     else {
-       struct shmid_ds shm;
-       shmctl(shmId, IPC_RMID, &shm);
--      shmId = shmget(key, dataSize, IPC_CREAT | 0666);
-+    shmId = shmget(key, dataSize, IPC_CREAT | 0600);
-       if (shmId == -1) {
-             perror("QShMemViewProtocol::QShMemViewProtocol");
-             qFatal("Cannot get shared memory 0x%08x", key);
--- 
-1.7.1
-
index 7a68aaf3805152350873d67611d4605a4bd2dc11..2549cd2842d9f696989dbd03fcd356a51e250f47 100644 (file)
--- a/qt4.spec
+++ b/qt4.spec
@@ -54,12 +54,12 @@ Summary(es.UTF-8):  Biblioteca para ejecutar aplicaciones GUI Qt
 Summary(pl.UTF-8):     Biblioteka Qt do tworzenia GUI
 Summary(pt_BR.UTF-8):  Estrutura para rodar aplicações GUI Qt
 Name:          qt4
-Version:       4.8.4
-Release:       7
+Version:       4.8.5
+Release:       1
 License:       LGPL v2.1 or GPL v3.0
 Group:         X11/Libraries
-Source0:       http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
-# Source0-md5: 89c5ecba180cae74c66260ac732dc5cb
+Source0:       http://download.qt-project.org/official_releases/qt/4.8/%{version}/qt-everywhere-opensource-src-%{version}.tar.gz
+# Source0-md5: 1864987bdbb2f58f8ae8b350dfdbe133
 Source2:       %{name}-qtconfig.desktop
 Source3:       %{name}-designer.desktop
 Source4:       %{name}-assistant.desktop
@@ -80,16 +80,15 @@ Patch7:             %{name}-x11_fonts.patch
 Patch8:                %{name}-ibase.patch
 Patch9:                qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
 Patch10:       webkit-no_Werror.patch
-Patch11:       moc-boost148.patch
+
 Patch12:       fix-crash-in-assistant.patch
 Patch13:       improve-cups-support.patch
-Patch14:       qt4-CVE-2013-0254.patch
 # backported from Qt5 (essentially)
 # http://bugzilla.redhat.com/702493
 # https://bugreports.qt-project.org/browse/QTBUG-5545
 Patch15:       qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
 Patch16:       qt-everywhere-opensource-src-4.8.3-QTBUG-4862.patch
-URL:           http://qt.nokia.com/
+URL:           http://qt-project.org/
 %{?with_ibase:BuildRequires:   Firebird-devel}
 BuildRequires: Mesa-libOpenVG-devel
 BuildRequires: OpenGL-GLU-devel
@@ -1471,10 +1470,10 @@ Programas exemplo para o Qt versão.
 %patch8 -p1
 %patch9 -p1
 %patch10 -p1
-%patch11 -p1
+
 %patch12 -p1
 %patch13 -p1
-%patch14 -p1
+
 %patch15 -p1
 %patch16 -p1
 
This page took 0.135704 seconds and 4 git commands to generate.