]> git.pld-linux.org Git - packages/qt4-plugin-qca-gnupg.git/blob - qt4-plugin-qca-gnupg.spec
- use qmake-qt4, cleanup
[packages/qt4-plugin-qca-gnupg.git] / qt4-plugin-qca-gnupg.spec
1 %define         rname qca-gnupg
2 #
3 %define snap    20070904
4 Summary:        Qt Cryptographic Architecture (QCA) GNU Privacy Guard plugin
5 Summary(pl.UTF-8):      Wtyczka GNU Privacy Guard dla Qt Cryptographic Architecture (QCA)
6 Name:           qt4-plugin-%{rname}
7 Version:        0.1
8 Release:        0.%{snap}.2
9 Epoch:          1
10 License:        LGPL v2.1
11 Group:          Libraries
12 Source0:        http://delta.affinix.com/download/qca/2.0/test4/qca-gnupg-%{version}-%{snap}.tar.bz2
13 # Source0-md5:  8a2ba2a8ac51363d2933c05a100c530e
14 URL:            http://delta.affinix.com/qca/
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  openssl-devel >= 0.9.7d
17 BuildRequires:  qca-devel >= 2.0.0
18 BuildRequires:  qt4-qmake >= 4.3.3-3
19 Requires:       gnupg
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _plugindir %{_libdir}/qt4/plugins/crypto
23
24 # chrpath stripping fails
25 %define         no_install_post_chrpath 1
26
27 %description
28 A plugin to provide GNU Privacy Guard capability to programs that
29 utilize the Qt Cryptographic Architecture (QCA).
30
31 %description -l pl.UTF-8
32 Wtyczka pozwalająca wykorzystać możliwości GNU Privacy Guard w
33 programach korzystających z Qt Cryptographic Architecture (QCA).
34
35 %prep
36 %setup -qn %{rname}-%{version}-%{snap}
37
38 %build
39 export QTDIR=%{_libdir}/qt4
40 ./configure
41
42 qmake-qt4 %{rname}.pro \
43         QMAKE_CXX="%{__cxx}" \
44         QMAKE_LINK="%{__cxx}" \
45         QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
46         QMAKE_RPATH=
47
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         INSTALL_ROOT=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_plugindir}/*.so
This page took 0.086798 seconds and 3 git commands to generate.