]> git.pld-linux.org Git - packages/qt-creator.git/commitdiff
upstream fix for llvm 15
authorJan Palus <atler@pld-linux.org>
Sat, 22 Oct 2022 17:50:45 +0000 (19:50 +0200)
committerJan Palus <atler@pld-linux.org>
Sat, 22 Oct 2022 17:50:45 +0000 (19:50 +0200)
llvm15.patch [new file with mode: 0644]
qt-creator.spec

diff --git a/llvm15.patch b/llvm15.patch
new file mode 100644 (file)
index 0000000..3fe4fa6
--- /dev/null
@@ -0,0 +1,34 @@
+From e238c8f0a4caf3d1487205093cffee9f56b56516 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Robert=20L=C3=B6hning?= <robert.loehning@qt.io>
+Date: Wed, 19 Oct 2022 10:49:14 +0200
+Subject: ClangFormat: Fix compilation with LLVM 15
+
+Change-Id: I7990e8331c317d3bc363be610b2585d37dee4445
+Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
+Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
+(cherry picked from commit a1bfcbf30d493e1e1fab94851fe50fed81cd3d6e)
+Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
+Reviewed-by: Eike Ziller <eike.ziller@qt.io>
+---
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index 230078558e..1e0429d80f 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -118,7 +118,11 @@ clang::format::FormatStyle qtcStyle()
+     style.ColumnLimit = 100;
+     style.CommentPragmas = "^ IWYU pragma:";
+     style.CompactNamespaces = false;
++#if LLVM_VERSION_MAJOR >= 15
++    style.PackConstructorInitializers = FormatStyle::PCIS_BinPack;
++#else
+     style.ConstructorInitializerAllOnOneLineOrOnePerLine = false;
++#endif
+     style.ConstructorInitializerIndentWidth = 4;
+     style.ContinuationIndentWidth = 4;
+     style.Cpp11BracedListStyle = true;
+-- 
+cgit v1.2.1
+
index ee9e9dcd5c1ec7aa6910fb517c8a3481f18a7fd8..7fec4e457b15034add192321d7a5de0f872d0d83 100644 (file)
@@ -8,6 +8,7 @@ License:        LGPL v2.1
 Group:         X11/Development/Tools
 Source0:       https://download.qt.io/official_releases/qtcreator/8.0/%{version}/%{name}-opensource-src-%{version}.tar.xz
 # Source0-md5: bdd73958efa2383a6a0953b81f48cc57
+Patch0:                llvm15.patch
 URL:           https://doc.qt.io/qt-5/topics-app-development.html
 BuildRequires: Qt5Concurrent-devel >= 5.9.0
 BuildRequires: Qt5Designer-devel >= 5.9.0
@@ -55,6 +56,7 @@ Qt.
 
 %prep
 %setup -q -n %{name}-opensource-src-%{version}
+%patch0 -p1
 
 sed -i '1s|^#!.*python\b|#!%{__python}|' src/shared/qbs/src/3rdparty/python/bin/dmgbuild
 
This page took 1.269399 seconds and 4 git commands to generate.