]> git.pld-linux.org Git - packages/qt-creator.git/commitdiff
up to 10.0.0
authorJan Palus <atler@pld-linux.org>
Tue, 11 Apr 2023 19:44:29 +0000 (21:44 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 11 Apr 2023 19:44:29 +0000 (21:44 +0200)
build.patch [new file with mode: 0644]
llvm15.patch [deleted file]
qt-creator.spec

diff --git a/build.patch b/build.patch
new file mode 100644 (file)
index 0000000..a4364ae
--- /dev/null
@@ -0,0 +1,11 @@
+--- qt-creator-opensource-src-10.0.0/src/shared/qbs/src/lib/corelib/jsextensions/domxml.cpp.orig       2023-04-11 21:39:31.321826852 +0200
++++ qt-creator-opensource-src-10.0.0/src/shared/qbs/src/lib/corelib/jsextensions/domxml.cpp    2023-04-11 21:39:38.731872451 +0200
+@@ -369,7 +369,7 @@
+ template<> bool XmlDomNode<QDomDocument>::setContent(const QString &content)
+ {
+-    return m_value.setContent(content);
++    return bool(m_value.setContent(content));
+ }
+ template<> QString XmlDomNode<QDomDocument>::toString(int indent)
diff --git a/llvm15.patch b/llvm15.patch
deleted file mode 100644 (file)
index 3fe4fa6..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From e238c8f0a4caf3d1487205093cffee9f56b56516 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Robert=20L=C3=B6hning?= <robert.loehning@qt.io>
-Date: Wed, 19 Oct 2022 10:49:14 +0200
-Subject: ClangFormat: Fix compilation with LLVM 15
-
-Change-Id: I7990e8331c317d3bc363be610b2585d37dee4445
-Reviewed-by: <github-actions-qt-creator@cristianadam.eu>
-Reviewed-by: Christian Kandeler <christian.kandeler@qt.io>
-(cherry picked from commit a1bfcbf30d493e1e1fab94851fe50fed81cd3d6e)
-Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
-Reviewed-by: Eike Ziller <eike.ziller@qt.io>
----
- src/plugins/clangformat/clangformatutils.cpp | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
-index 230078558e..1e0429d80f 100644
---- a/src/plugins/clangformat/clangformatutils.cpp
-+++ b/src/plugins/clangformat/clangformatutils.cpp
-@@ -118,7 +118,11 @@ clang::format::FormatStyle qtcStyle()
-     style.ColumnLimit = 100;
-     style.CommentPragmas = "^ IWYU pragma:";
-     style.CompactNamespaces = false;
-+#if LLVM_VERSION_MAJOR >= 15
-+    style.PackConstructorInitializers = FormatStyle::PCIS_BinPack;
-+#else
-     style.ConstructorInitializerAllOnOneLineOrOnePerLine = false;
-+#endif
-     style.ConstructorInitializerIndentWidth = 4;
-     style.ContinuationIndentWidth = 4;
-     style.Cpp11BracedListStyle = true;
--- 
-cgit v1.2.1
-
index 510b16e6a74adc00b48cb12af5788921694275b4..dd74fd3acd2d3c2057244d89af780e7e579c075f 100644 (file)
 Summary:       An IDE tailored to the needs of Qt developers
 Summary(pl.UTF-8):     IDE dostosowane do potrzeb programistów Qt
 Name:          qt-creator
-Version:       8.0.2
-Release:       6
+Version:       10.0.0
+Release:       1
 Epoch:         1
 License:       LGPL v2.1
 Group:         X11/Development/Tools
-Source0:       https://download.qt.io/official_releases/qtcreator/8.0/%{version}/%{name}-opensource-src-%{version}.tar.xz
-# Source0-md5: bdd73958efa2383a6a0953b81f48cc57
-Patch0:                llvm15.patch
+Source0:       https://download.qt.io/official_releases/qtcreator/10.0/%{version}/%{name}-opensource-src-%{version}.tar.xz
+# Source0-md5: fceb0dc8bacc759d5291574be1190c2f
+Patch0:                build.patch
 URL:           https://doc.qt.io/qt-5/topics-app-development.html
 BuildRequires: Qt6Concurrent-devel >= %{qtver}
 BuildRequires: Qt6Designer-devel >= %{qtver}
@@ -38,6 +38,7 @@ BuildRequires:        Qt6UiTools-devel >= %{qtver}
 BuildRequires: Qt6Widgets-devel >= %{qtver}
 BuildRequires: Qt6Xml-devel >= %{qtver}
 BuildRequires: clang-devel >= 6.0.0
+BuildRequires: cmake >= 3.16
 BuildRequires: gdb
 BuildRequires: libstdc++-devel
 BuildRequires: llvm-devel >= 7.0.0
@@ -125,7 +126,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libexecdir}/qtcreator/perfparser
 %attr(755,root,root) %{_libexecdir}/qtcreator/qtcreator_processlauncher
 %attr(755,root,root) %{_libexecdir}/qtcreator/qbs_processlauncher
-%attr(755,root,root) %{_libexecdir}/qtcreator/qml2puppet
+%attr(755,root,root) %{_libexecdir}/qtcreator/qml2puppet-%{version}
 %attr(755,root,root) %{_libexecdir}/qtcreator/qtcreator_process_stub
 %attr(755,root,root) %{_libexecdir}/qtcreator/qtc-askpass
 %attr(755,root,root) %{_libexecdir}/qtcreator/qtpromaker
@@ -133,7 +134,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_libdir}/qtcreator
 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
-%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.8
+%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.10
 %dir %{_libdir}/qtcreator/plugins
 %attr(755,root,root) %{_libdir}/qtcreator/plugins/lib*.so
 %dir %{_libdir}/qtcreator/plugins/qbs
This page took 0.045948 seconds and 4 git commands to generate.