]> git.pld-linux.org Git - packages/qt-creator.git/blobdiff - qt-creator.spec
- up to 3.4.1
[packages/qt-creator.git] / qt-creator.spec
index 842cd4f661913e8255816e24a30844b170e387cc..160ef1d4470a640c62d4f2c69e5cef91a393a1cb 100644 (file)
@@ -1,45 +1,57 @@
-#
-
 Summary:       An IDE tailored to the needs of Qt developers
 Summary(pl.UTF-8):     IDE dostosowane do potrzeb developerow Qt
 Name:          qt-creator
-Version:       1.0.0
-Release:       2
+Version:       3.4.1
+Release:       1
 Epoch:         1
 License:       LGPL v2.1
-Group:         Libraries
-Source0:       http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
-# Source0-md5: 5478124035d80a90e66a3db67ab4477a
+Group:         X11/Development/Tools
+Source0:       http://download.qt-project.org/official_releases/qtcreator/3.4/%{version}/%{name}-opensource-src-%{version}.tar.gz
+# Source0-md5: bcbae4a567c93158babe3b7f42d01219
+Source1:       %{name}.desktop
 Patch0:                %{name}-pluginpath64.patch
-URL:           http://www.qtsoftware.com/developer/qt-creator
-BuildRequires: QtDBus-devel
+URL:           http://qt.digia.com/Product/Developer-Tools
+BuildRequires: QtDeclarative-devel
+BuildRequires: QtDesigner-devel
 BuildRequires: QtGui-devel
 BuildRequires: QtHelp-devel
 BuildRequires: QtNetwork-devel
 BuildRequires: QtScript-devel
-BuildRequires: QtSql-sqlite
 BuildRequires: QtSvg-devel
 BuildRequires: QtWebKit-devel
 BuildRequires: QtXml-devel
-BuildRequires: qt4-build >= 4.5.0-3
-BuildRequires: qt4-qmake >= 4.5.0-3
-BuildRequires: unzip
+BuildRequires: gdb
+BuildRequires: qt4-build >= 4.8.0
+BuildRequires: qt4-linguist
+BuildRequires: qt4-qmake >= 4.8.0
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.602
+Requires(post,postun): desktop-file-utils
+%requires_eq   QtCore
+Requires:      QtSql-sqlite3
+Requires:      hicolor-icon-theme
+# for xdg-open
+Suggests:      xdg-utils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Qt Creator is a cross-platform integrated development environment (IDE) 
-tailored to the needs of Qt developers.
+Qt Creator is a cross-platform integrated development environment
+(IDE) tailored to the needs of Qt developers.
 
 %description -l pl.UTF-8
-Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
+Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow
+Qt.
 
 %prep
-%setup -q -n %{name}-%{version}-src
+%setup -q -n %{name}-opensource-src-%{version}
 
 %if "%{_lib}" == "lib64"
 %patch0 -p1
 %endif
 
+# fix unresolved symbols in libQtcSsh
+echo "LIBS += -ldl" > src/libs/ssh/ssh_dependencies.pri
+
 %build
 export QTDIR=%{_libdir}/qt4
 # the qmakespec in qt4 is somewhat broken, need to look at this
@@ -49,40 +61,62 @@ qmake-qt4 qtcreator.pro \
        QMAKE_CXX="%{__cxx}" \
        QMAKE_LINK="%{__cxx}" \
        QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
-       QMAKE_RPATH=    
+       QMAKE_RPATH=
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_desktopdir}
 
 export QTDIR=%{_libdir}/qt4
-#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
 %{__make} install \
-       INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
+       INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
+
+%if "%{_lib}" == "lib64"
+mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
+%endif
+
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
+echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
 
-mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
+install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
-install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
-echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
+# not supported by hicolor-icon-theme
+rm -rf $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+/sbin/ldconfig
+%update_desktop_database
+%update_icon_cache hicolor
+
+%postun
+/sbin/ldconfig
+%update_desktop_database_postun
+%update_icon_cache hicolor
+
 %files
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/qtcreator
+%attr(755,root,root) %{_bindir}/qtcreator_process_stub
+%attr(755,root,root) %{_bindir}/qtpromaker
+%attr(755,root,root) %{_bindir}/sdktool
 %{_sysconfdir}/ld.so.conf.d/qtcreator.conf
 %dir %{_libdir}/qtcreator
 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
 %attr(755,root,root) %{_libdir}/qtcreator/lib*.so
+%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
 %dir %{_libdir}/qtcreator/plugins
-%dir %{_libdir}/qtcreator/plugins/Nokia
-%{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
-%attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
+%dir %{_libdir}/qtcreator/plugins/BlackBerry
+%dir %{_libdir}/qtcreator/plugins/QtProject
+%{_libdir}/qtcreator/plugins/BlackBerry/*.pluginspec
+%{_libdir}/qtcreator/plugins/QtProject/*.pluginspec
+%attr(755,root,root) %{_libdir}/qtcreator/plugins/BlackBerry/*.so
+%attr(755,root,root) %{_libdir}/qtcreator/plugins/QtProject/*.so
+%{_libdir}/qtcreator/qtcomponents
 %{_datadir}/qtcreator
-%{_defaultdocdir}/qtcreator
-%{_pixmapsdir}/qtcreator_logo*.png
-
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
+%{_desktopdir}/qt-creator.desktop
+%{_iconsdir}/hicolor/*/*/*.png
This page took 0.076428 seconds and 4 git commands to generate.