]> git.pld-linux.org Git - packages/qt-creator.git/blame_incremental - qt-creator.spec
- bump reqs to Qt5
[packages/qt-creator.git] / qt-creator.spec
... / ...
CommitLineData
1Summary: An IDE tailored to the needs of Qt developers
2Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
3Name: qt-creator
4Version: 3.4.1
5Release: 1
6Epoch: 1
7License: LGPL v2.1
8Group: X11/Development/Tools
9Source0: http://download.qt-project.org/official_releases/qtcreator/3.4/%{version}/%{name}-opensource-src-%{version}.tar.gz
10# Source0-md5: bcbae4a567c93158babe3b7f42d01219
11Source1: %{name}.desktop
12Patch0: %{name}-pluginpath64.patch
13URL: http://qt.digia.com/Product/Developer-Tools
14BuildRequires: Qt5Declarative-devel >= 5.3.1
15BuildRequires: Qt5Designer-devel >= 5.3.1
16BuildRequires: Qt5Gui-devel >= 5.3.1
17BuildRequires: Qt5Help-devel >= 5.3.1
18BuildRequires: Qt5Network-devel >= 5.3.1
19BuildRequires: Qt5Script-devel >= 5.3.1
20BuildRequires: Qt5Svg-devel >= 5.3.1
21BuildRequires: Qt5WebKit-devel >= 5.3.1
22BuildRequires: Qt5Xml-devel >= 5.3.1
23BuildRequires: gdb
24BuildRequires: qt5-build >= 5.3.1
25BuildRequires: qt5-linguist
26BuildRequires: qt5-qmake >= 5.3.1
27BuildRequires: rpm-pythonprov
28BuildRequires: rpmbuild(macros) >= 1.602
29Requires(post,postun): desktop-file-utils
30%requires_eq Qt5Core
31Requires: Qt5Sql
32Requires: hicolor-icon-theme
33# for xdg-open
34Suggests: xdg-utils
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37%description
38Qt Creator is a cross-platform integrated development environment
39(IDE) tailored to the needs of Qt developers.
40
41%description -l pl.UTF-8
42Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow
43Qt.
44
45%prep
46%setup -q -n %{name}-opensource-src-%{version}
47
48%if "%{_lib}" == "lib64"
49%patch0 -p1
50%endif
51
52# fix unresolved symbols in libQtcSsh
53echo "LIBS += -ldl" > src/libs/ssh/ssh_dependencies.pri
54
55%build
56export QTDIR=%{_libdir}/qt4
57# the qmakespec in qt4 is somewhat broken, need to look at this
58#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
59
60qmake-qt4 qtcreator.pro \
61 QMAKE_CXX="%{__cxx}" \
62 QMAKE_LINK="%{__cxx}" \
63 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
64 QMAKE_RPATH=
65
66%{__make}
67
68%install
69rm -rf $RPM_BUILD_ROOT
70install -d $RPM_BUILD_ROOT%{_desktopdir}
71
72export QTDIR=%{_libdir}/qt4
73%{__make} install \
74 INSTALL_ROOT=$RPM_BUILD_ROOT%{_prefix}
75
76%if "%{_lib}" == "lib64"
77mv -f $RPM_BUILD_ROOT{%{_prefix}/lib,%{_libdir}}
78%endif
79
80install -d $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d
81echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
82
83install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
84
85# not supported by hicolor-icon-theme
86rm -rf $RPM_BUILD_ROOT%{_iconsdir}/hicolor/512x512
87
88%clean
89rm -rf $RPM_BUILD_ROOT
90
91%post
92/sbin/ldconfig
93%update_desktop_database
94%update_icon_cache hicolor
95
96%postun
97/sbin/ldconfig
98%update_desktop_database_postun
99%update_icon_cache hicolor
100
101%files
102%defattr(644,root,root,755)
103%attr(755,root,root) %{_bindir}/qtcreator
104%attr(755,root,root) %{_bindir}/qtcreator_process_stub
105%attr(755,root,root) %{_bindir}/qtpromaker
106%attr(755,root,root) %{_bindir}/sdktool
107%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
108%dir %{_libdir}/qtcreator
109%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
110%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
111%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
112%dir %{_libdir}/qtcreator/plugins
113%dir %{_libdir}/qtcreator/plugins/BlackBerry
114%dir %{_libdir}/qtcreator/plugins/QtProject
115%{_libdir}/qtcreator/plugins/BlackBerry/*.pluginspec
116%{_libdir}/qtcreator/plugins/QtProject/*.pluginspec
117%attr(755,root,root) %{_libdir}/qtcreator/plugins/BlackBerry/*.so
118%attr(755,root,root) %{_libdir}/qtcreator/plugins/QtProject/*.so
119%{_libdir}/qtcreator/qtcomponents
120%{_datadir}/qtcreator
121%{_desktopdir}/qt-creator.desktop
122%{_iconsdir}/hicolor/*/*/*.png
This page took 0.029561 seconds and 4 git commands to generate.