]> git.pld-linux.org Git - packages/qhull.git/blob - qhull.spec
- enhanced cmake patch to fix cmake files installation; release 2
[packages/qhull.git] / qhull.spec
1 Summary:        Qhull - convex hulls, triangulations and related computations
2 Summary(pl.UTF-8):      Qhull - obliczanie powłok wypukłych, triangulacji i powiązanych rzeczy
3 Name:           qhull
4 Version:        2019.1
5 Release:        2
6 License:        distributable (see COPYING.txt)
7 Group:          Libraries
8 Source0:        http://www.qhull.org/download/%{name}-2019-src-7.3.2.tgz
9 # Source0-md5:  53c04f9c89b491b17b10c7ea1eaa4cc8
10 Patch0:         %{name}-cmake.patch
11 URL:            http://www.qhull.org/
12 BuildRequires:  cmake >= 2.6
13 BuildRequires:  libstdc++-devel
14 BuildRequires:  rpmbuild(macros) >= 1.603
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 Qhull computes convex hulls, Delaunay triangulations, Voronoi
19 diagrams, furthest-site Voronoi diagrams, and halfspace intersections
20 about a point. It runs in 2-d, 3-d, 4-d, or higher. It implements the
21 Quickhull algorithm for computing convex hulls. Qhull handles
22 round-off errors from floating point arithmetic. It can approximate a
23 convex hull.
24
25 %description -l pl.UTF-8
26 Qhull oblicza powłoki wypukłe, triangulacje Delaunaya, diagramy
27 Voronoi, diagramy Voronoi większych rzędów oraz przecięcia
28 półprzestrzeni. Działa w przestrzeniach dwu, trzy, cztero i więcej
29 wymiarowych. Ma zaimplementowany algorytm Quickhull do obliczania
30 powłok wypukłych. Obsługuje błędy zaokrągleń wynikłe z arytmetyki
31 zmiennoprzecinkowej. Może aproksymować powłoki wypukłe.
32
33 %package devel
34 Summary:        Header files for Qhull library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Qhull
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38
39 %description devel
40 Header files for Qhull library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki Qhull.
44
45 %package static
46 Summary:        Static Qhull library
47 Summary(pl.UTF-8):      Statyczna biblioteka Qhull
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static Qhull library.
53
54 %description static -l pl.UTF-8
55 Statyczna biblioteka Qhull.
56
57 %package c++
58 Summary:        QhullCPP library
59 Summary(pl.UTF-8):      Biblioteka QhullCPP
60 Group:          Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description c++
64 QhullCPP library.
65
66 %description c++ -l pl.UTF-8
67 Biblioteka QhullCPP.
68
69 %package c++-devel
70 Summary:        Header files for QhullCPP library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki QhullCPP
72 Group:          Development/Libraries
73 Requires:       %{name}-c++ = %{version}-%{release}
74 Requires:       %{name}-devel = %{version}-%{release}
75 Requires:       libstdc++-devel
76
77 %description c++-devel
78 Header files for QhullCPP library.
79
80 %description c++-devel -l pl.UTF-8
81 Pliki nagłówkowe biblioteki QhullCPP.
82
83 %package c++-static
84 Summary:        Static QhullCPP library
85 Summary(pl.UTF-8):      Statyczna biblioteka QhullCPP
86 Group:          Development/Libraries
87 Requires:       %{name}-c++-devel = %{version}-%{release}
88
89 %description c++-static
90 Static QhullCPP library.
91
92 %description c++-static -l pl.UTF-8
93 Statyczna biblioteka QhullCPP.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98
99 %build
100 install -d build-cmake
101 cd build-cmake
102 %cmake .. \
103         -DLIB_INSTALL_DIR=%{_libdir} \
104         -DMAN_INSTALL_DIR=%{_mandir}/man1
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} -C build-cmake install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qhull
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %post   c++ -p /sbin/ldconfig
122 %postun c++ -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc Announce.txt COPYING.txt README.txt REGISTER.txt index.htm
127 %attr(755,root,root) %{_bindir}/qconvex
128 %attr(755,root,root) %{_bindir}/qdelaunay
129 %attr(755,root,root) %{_bindir}/qhalf
130 %attr(755,root,root) %{_bindir}/qhull
131 %attr(755,root,root) %{_bindir}/qvoronoi
132 %attr(755,root,root) %{_bindir}/rbox
133 %attr(755,root,root) %{_libdir}/libqhull.so.*.*.*
134 %attr(755,root,root) %ghost %{_libdir}/libqhull.so.7
135 %attr(755,root,root) %{_libdir}/libqhull_p.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/libqhull_p.so.7
137 %attr(755,root,root) %{_libdir}/libqhull_r.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libqhull_r.so.7
139 %{_mandir}/man1/qhull.1*
140 %{_mandir}/man1/rbox.1*
141
142 %files devel
143 %defattr(644,root,root,755)
144 %doc html/*.{htm,gif,jpg}
145 %attr(755,root,root) %{_libdir}/libqhull.so
146 %attr(755,root,root) %{_libdir}/libqhull_p.so
147 %attr(755,root,root) %{_libdir}/libqhull_r.so
148 %{_includedir}/libqhull
149 %{_includedir}/libqhull_r
150 %{_libdir}/cmake/Qhull
151
152 %files static
153 %defattr(644,root,root,755)
154 %{_libdir}/libqhullstatic.a
155 %{_libdir}/libqhullstatic_r.a
156
157 %files c++
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libqhullcpp.so.*.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libqhullcpp.so.7
161
162 %files c++-devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libqhullcpp.so
165 %{_includedir}/libqhullcpp
166
167 %files c++-static
168 %defattr(644,root,root,755)
169 %{_libdir}/libqhullcppstatic.a
This page took 0.083666 seconds and 3 git commands to generate.