]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- add grsec_kernel bcond
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
55023879
ER
17%bcond_with grsec_kernel # build for kernel-grsecurity
18#
19%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
20%define alt_kernel grsecurity
21%endif
22#
39b50bf0 23#
b0b2a1d9 24# no kernel kqemu module for ppc
25%ifarch ppc
26%undefine with_kqemu
27%undefine with_kernel
28%endif
b337f190 29%define _kqemu_version 1.3.0pre11
617c952b 30%define _rel 55
cd19124e 31Summary: QEMU CPU Emulator
4d74b97c 32Summary(pl): QEMU - emulator procesora
cd19124e 33Name: qemu
b337f190 34Version: 0.9.0
8bb1261c 35Release: %{_rel}%{?with_kqemu:k}
5a2da1d0
JB
36License: GPL
37Group: Applications/Emulators
867764ba 38#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
cd19124e 39Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
b337f190 40# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
c33439fc 41Source1: http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
b337f190 42# Source1-md5: 970521874ef8b1ba4598925ace5936c3
8bd2aee2 43Patch0: %{name}-nostatic.patch
c33439fc 44Patch1: %{name}-cc.patch
d8d8cede 45Patch3: %{name}-dot.patch
8d073aaa
ER
46Patch4: %{name}-gcc4_x86.patch
47Patch5: %{name}-gcc4_ppc.patch
48Patch6: %{name}-nosdlgui.patch
49Patch7: %{name}-ifup.patch
81a493f2
MM
50# Proof of concept, for reference, do not remove
51Patch8: %{name}-kde_virtual_workspaces_hack.patch
e05988b9
AM
52# http://gwenole.beauchesne.info/en/projects/qemu
53Patch9: %{name}-0.8.0-gcc4-hacks.patch
e05988b9 54Patch11: %{name}-0.7.2-gcc4-opts.patch
b337f190 55#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
b4d7fbfb 56Patch13: %{name}-dosguest.patch
5b888e18 57# Fix crash when using qemu instances with NICs connected via socket
58# This patch will be obsolete in versions after 0.9.0
59Patch14: %{name}-0.9.0-remove-iohandlers.patch
cd19124e 60URL: http://fabrice.bellard.free.fr/qemu/
d1ae30a6 61%if %{with kernel} && %{with dist_kernel}
62BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
9ea49998 63BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 64%endif
65%if %{with userspace}
867764ba 66BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 67BuildRequires: alsa-lib-devel
21c5c008 68%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 69BuildRequires: perl-tools-pod
2fb8ea02 70BuildRequires: tetex
8bb1261c 71BuildRequires: sed >= 4.0
d1ae30a6 72%endif
8bb1261c 73Requires: SDL >= 1.2.1
2ef13cb9 74# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
39b50bf0 75ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
cd19124e 76BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
867764ba 78# some SPARC boot image in ELF format
ca55b10f 79%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 80
cd19124e 81%description
82QEMU is a FAST! processor emulator. By using dynamic translation it
83achieves a reasonnable speed while being easy to port on new host
84CPUs. QEMU has two operating modes:
85
86- User mode emulation. In this mode, QEMU can launch Linux processes
87 compiled for one CPU on another CPU. Linux system calls are converted
88 because of endianness and 32/64 bit mismatches. Wine (Windows
89 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
90
91- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
92 including a processor and various peripherials. It can also be used to
93 provide virtual hosting of several virtual PC on a single server.
cd19124e 94
4d74b97c 95%description -l pl
96