]> git.pld-linux.org Git - packages/qemu.git/blame - qemu.spec
- rel 3
[packages/qemu.git] / qemu.spec
CommitLineData
6aef4654 1#
0b920c52
2# TODO:
3# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
4#
6aef4654 5# Conditional build:
8f93639f 6%bcond_without kqemu # disable KQEMU ACCELERATOR support in QEMU
161ffd93 7%bcond_with cflags_passing # with passing rpmcflags to Makefiles
b4d7fbfb 8%bcond_with dosguest # add special patch when use with DOS as guest os
a6d3659e 9%bcond_with nosdlgui # do not use SDL gui (use X11 instead)
63dabd29 10# Note that gcc4 build is very problematic and not supported by qemu team
80e91c68 11%bcond_with gcc4 # use gcc4 patches (broke build on gcc33)
8bb1261c 12%bcond_without dist_kernel # without distribution kernel
b337f190 13%bcond_without kernel # build kqemu KERNEL MODULES
3a6eaa3b 14%bcond_without up # don't build up module
8bb1261c
KK
15%bcond_without smp # don't build SMP module
16%bcond_without userspace # don't build userspace utilities
55023879 17%bcond_with grsec_kernel # build for kernel-grsecurity
0287446d 18
ae00823b
ER
19%if %{without kernel}
20%undefine with_dist_kernel
21%endif
5d595c73 22%if %{with dist_kernel} && %{with grsec_kernel}
ae00823b
ER
23%define alt_kernel grsecurity
24%endif
76cb30ae
ER
25
26# no kernel kqemu module for ppc
27%ifarch ppc
28%undefine with_kqemu
29%undefine with_kernel
30%endif
31
0287446d
ER
32%if "%{_alt_kernel}" != "%{nil}"
33%undefine with_userspace
34%endif
ae00823b 35
420584f3
ER
36%define kqemu_version 1.3.0pre11
37%define qemu_version 0.9.1
4a24b47c 38%define pname qemu
420584f3 39
fe3769d4 40%define rel 3
cd19124e 41Summary: QEMU CPU Emulator
4d74b97c 42Summary(pl): QEMU - emulator procesora
4a24b47c 43Name: %{pname}%{_alt_kernel}
420584f3
ER
44Version: %{qemu_version}
45Release: %{rel}%{?with_kqemu:k}
5a2da1d0
JB
46License: GPL
47Group: Applications/Emulators
867764ba 48#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
4a24b47c 49Source0: http://fabrice.bellard.free.fr/qemu/%{pname}-%{version}.tar.gz
5d541e92 50# Source0-md5: 6591df8e9270eb358c881de4ebea1262
420584f3 51Source1: http://fabrice.bellard.free.fr/qemu/k%{pname}-%{kqemu_version}.tar.gz
b337f190 52# Source1-md5: 970521874ef8b1ba4598925ace5936c3
4a24b47c
ER
53Patch0: %{pname}-nostatic.patch
54Patch1: %{pname}-cc.patch
55Patch3: %{pname}-dot.patch
56Patch4: %{pname}-gcc4_x86.patch
57Patch5: %{pname}-gcc4_ppc.patch
58Patch6: %{pname}-nosdlgui.patch
59Patch7: %{pname}-ifup.patch
81a493f2 60# Proof of concept, for reference, do not remove
4a24b47c 61Patch8: %{pname}-kde_virtual_workspaces_hack.patch
e05988b9 62# http://gwenole.beauchesne.info/en/projects/qemu
4a24b47c
ER
63Patch9: %{pname}-0.8.0-gcc4-hacks.patch
64Patch11: %{pname}-0.7.2-gcc4-opts.patch
65#Patch12: %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
66Patch13: %{pname}-dosguest.patch
033bfe61 67Patch14: %{pname}-ppc_old_binutils.patch
cd19124e 68URL: http://fabrice.bellard.free.fr/qemu/
ae00823b
ER
69%if %{with kernel}
70%{?with_dist_kernel:BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7}
9ea49998 71BuildRequires: rpmbuild(macros) >= 1.330
d1ae30a6 72%endif
73%if %{with userspace}
867764ba 74BuildRequires: SDL-devel >= 1.2.1
b0b3ca8d 75BuildRequires: alsa-lib-devel
21c5c008 76%{!?with_gcc4:BuildRequires: gcc < 5:4.0}
2fb8ea02 77BuildRequires: perl-tools-pod
2fb8ea02 78BuildRequires: tetex
8bb1261c 79BuildRequires: sed >= 4.0
d1ae30a6 80%endif
8bb1261c 81Requires: SDL >= 1.2.1
2ef13cb9 82# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
3cb1ae6e 83ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
cd19124e 84BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
85
867764ba 86# some SPARC boot image in ELF format
ca55b10f 87%define _noautostrip .*%{_datadir}/qemu/openbios-sparc32
867764ba 88
cd19124e 89%description
90QEMU is a FAST! processor emulator. By using dynamic translation it
91achieves a reasonnable speed while being easy to port on new host
92CPUs. QEMU has two operating modes:
93
94- User mode emulation. In this mode, QEMU can launch Linux processes
95 compiled for one CPU on another CPU. Linux system calls are converted
96 because of endianness and 32/64 bit mismatches. Wine (Windows
97 emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
98
99- Full system emulation. In this mode, QEMU emulates a full system,
8799423b
ER
100 including a processor and various peripherials. It can also be used to
101 provide virtual hosting of several virtual PC on a single server.
cd19124e 102
4d74b97c 103%description -l pl
104