]> git.pld-linux.org Git - packages/python3.git/commitdiff
- enable ndbm, too (by forcing linking to gdbm_compat provided by gdbm.spec) which...
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 27 Dec 2016 22:35:36 +0000 (23:35 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Tue, 27 Dec 2016 22:35:36 +0000 (23:35 +0100)
python3-db.patch
python3.spec

index 63b011d417d19df7944ab8f367bc6bb99b7a0b69..f986f77e8226a928158119fbced51492eab4fa01 100644 (file)
@@ -9,3 +9,23 @@
          min_db_ver = (3, 3)
          db_setup_debug = False   # verbose debug prints from this script?
  
+--- Python-3.6.0/setup.py~     2016-12-27 23:21:52.000000000 +0100
++++ Python-3.6.0/setup.py      2016-12-27 23:28:54.720208583 +0100
+@@ -1252,16 +1252,7 @@ class PyBuildExt(build_ext):
+             for cand in dbm_order:
+                 if cand == "ndbm":
+                     if find_file("ndbm.h", inc_dirs, []) is not None:
+-                        # Some systems have -lndbm, others have -lgdbm_compat,
+-                        # others don't have either
+-                        if self.compiler.find_library_file(lib_dirs,
+-                                                               'ndbm'):
+-                            ndbm_libs = ['ndbm']
+-                        elif self.compiler.find_library_file(lib_dirs,
+-                                                             'gdbm_compat'):
+-                            ndbm_libs = ['gdbm_compat']
+-                        else:
+-                            ndbm_libs = []
++                        ndbm_libs = ['gdbm_compat']
+                         if dbm_setup_debug: print("building dbm using ndbm")
+                         dbmext = Extension('_dbm', ['_dbmmodule.c'],
+                                            define_macros=[
index 79f9300fc263b1f0045ad81474faa51d5cadcce6..852a98e24a9863678eb3e0c161c235dc779d3cff 100644 (file)
@@ -519,7 +519,7 @@ fi
        --enable-ipv6 \
        --enable-shared \
        --with-computed-gotos \
-       --with-dbmliborder=gdbm:bdb \
+       --with-dbmliborder=gdbm:ndbm:bdb \
        --with-doc-strings \
        --without-ensurepip \
        --with-fpectl \
This page took 0.105285 seconds and 4 git commands to generate.