]> git.pld-linux.org Git - packages/python3-pkgconfig.git/blob - python3-pkgconfig.spec
- python-pkgconfig.spec updated to 1.5.5 for python 3.3+
[packages/python3-pkgconfig.git] / python3-pkgconfig.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # unit tests (not included in pypi release)
4
5 Summary:        Python 3 interface to pkg-config
6 Summary(pl.UTF-8):      Interfejs Pythona 3 do narzędzia pkg-config
7 Name:           python3-pkgconfig
8 Version:        1.5.5
9 Release:        1
10 License:        MIT
11 Group:          Libraries/Python
12 #Source0Download: https://pypi.org/simple/pkgconfig/
13 Source0:        https://files.pythonhosted.org/packages/source/p/pkgconfig/pkgconfig-%{version}.tar.gz
14 # Source0-md5:  12523e11b91b050ca49975cc033689a4
15 URL:            https://github.com/matze/pkgconfig
16 BuildRequires:  python3-modules >= 1:3.3
17 BuildRequires:  python3-setuptools
18 %if %{with tests}
19 BuildRequires:  python3-pytest >= 3.8.2
20 %endif
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.714
23 Requires:       python3-modules >= 1:3.3
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 pkgconfig is a Python module to interface with the pkg-config command
29 line tool.
30
31 %description -l pl.UTF-8
32 pkgconfig to moduł Pythona do współpracy z narzędziem linii poleceń
33 pkg-config.
34
35 %prep
36 %setup -q -n pkgconfig-%{version}
37
38 %build
39 %py3_build
40
41 %{?with_tests:%{__python3} -m pytest test_pkgconfig.py}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %py3_install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc LICENSE README.rst
54 %{py3_sitescriptdir}/pkgconfig
55 %{py3_sitescriptdir}/pkgconfig-%{version}-py*.egg-info
This page took 0.087022 seconds and 3 git commands to generate.