]> git.pld-linux.org Git - packages/python3-ordered-set.git/blob - python3-ordered-set.spec
Release 2 (by relup.sh)
[packages/python3-ordered-set.git] / python3-ordered-set.spec
1 # Conditional build:
2 %bcond_with     tests   # unit tests
3
4 %define         module  ordered-set
5 Summary:        A mutable set that remembers the order of its entries
6 Name:           python3-%{module}
7 Version:        4.1.0
8 Release:        2
9 License:        MIT
10 Group:          Libraries/Python
11 Source0:        https://pypi.debian.net/%{module}/%{module}-%{version}.tar.gz
12 # Source0-md5:  2a9ba8d1a962c26f9a4fbe246b62ee77
13 URL:            https://github.com/seperman/ordered-set
14 BuildRequires:  python3-modules >= 1:3.2
15 #BuildRequires: python3-setuptools
16 %if %{with tests}
17 #BuildRequires: python3-
18 %endif
19 BuildRequires:  rpm-pythonprov
20 BuildRequires:  rpmbuild(macros) >= 1.714
21 Requires:       python3-modules >= 1:3.2
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 An OrderedSet is a mutable data structure that is a hybrid of a list
27 and a set. It remembers the order of its entries, and every entry has
28 an index number that can be looked up.
29
30 %prep
31 %setup -q -n %{module}-%{version}
32
33 %build
34 %py3_build
35
36 %if %{with tests}
37 # use explicit plugins list for reliable builds (delete PYTEST_PLUGINS if empty)
38 PYTEST_DISABLE_PLUGIN_AUTOLOAD=1 \
39 PYTEST_PLUGINS= \
40 %{__python3} -m pytest tests
41 %endif
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %py3_install
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README.md
54 %dir %{py3_sitescriptdir}/ordered_set
55 %{py3_sitescriptdir}/ordered_set/*.py
56 %{py3_sitescriptdir}/ordered_set/__pycache__
57 %{py3_sitescriptdir}/ordered_set-%{version}-py*.egg-info
58
This page took 0.177884 seconds and 4 git commands to generate.