]> git.pld-linux.org Git - packages/python3-Uranium.git/commitdiff
- up to 4.5.0 auto/th/python3-Uranium-4.5.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 8 Apr 2020 12:36:50 +0000 (14:36 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 8 Apr 2020 12:36:50 +0000 (14:36 +0200)
plugins-path.patch
python3-Uranium.spec

index 6a30d65b0c60a2f7bec9c65e0cabf4197eb69232..cd04d6a198f22e991b1edab0351cd7f1710f36a9 100644 (file)
@@ -1,19 +1,22 @@
---- Uranium-3.5.1/CMakeLists.txt~      2018-11-04 14:15:43.000000000 +0100
-+++ Uranium-3.5.1/CMakeLists.txt       2018-11-04 14:16:18.346958842 +0100
+--- Uranium-3.5.1/cmake/UraniumPluginInstall.cmake~    2018-11-04 14:15:43.000000000 +0100
++++ Uranium-3.5.1/cmake/UraniumPluginInstall.cmake     2018-11-04 14:16:18.346958842 +0100
 @@ -55,6 +55,6 @@
- install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
-         DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
- install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
--install(DIRECTORY plugins DESTINATION lib${LIB_SUFFIX}/uranium)
-+install(DIRECTORY plugins DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
- include(CPackConfig.cmake)
+         message(STATUS "[+] PLUGIN TO INSTALL: ${_rel_plugin_dir}")
+         get_filename_component(_rel_plugin_parent_dir ${_rel_plugin_dir} DIRECTORY)
+         install(DIRECTORY ${_rel_plugin_dir}
+-                DESTINATION lib${LIB_SUFFIX}/uranium/${_rel_plugin_parent_dir}
++                DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium/${_rel_plugin_parent_dir}
+                 PATTERN "__pycache__" EXCLUDE
+                 PATTERN "*.qmlc" EXCLUDE
+                 )
 --- Uranium-3.5.1/UM/Application.py~   2018-10-15 11:44:28.000000000 +0200
 +++ Uranium-3.5.1/UM/Application.py    2018-11-04 14:30:40.963992502 +0100
 @@ -165,6 +165,7 @@
-         self._plugin_registry = PluginRegistry(self)  #type: PluginRegistry
  
-         self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, UraniumLibraryDir, "uranium"))
+         self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "lib", "uranium"))
+         self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "lib64", "uranium"))
+-        self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "lib32", "uranium"))
++        self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "libx32", "uranium"))
 +        self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "share", "uranium"))
          self._plugin_registry.addPluginLocation(os.path.join(os.path.dirname(sys.executable), "plugins"))
          self._plugin_registry.addPluginLocation(os.path.join(self._app_install_dir, "Resources", "uranium", "plugins"))
index cb99819c39dce280d15e7568e5e51311a9377526..22ac3f6433628a759cc226c19e0369d9b04489ac 100644 (file)
@@ -5,13 +5,13 @@
 %define                module          Uranium
 Summary:       A Python framework for building desktop applications
 Name:          python3-%{module}
-Version:       3.5.1
-Release:       5
+Version:       4.5.0
+Release:       1
 License:       AGPLv3+
 Group:         Libraries/Python
 URL:           https://github.com/Ultimaker/Uranium
 Source0:       https://github.com/Ultimaker/Uranium/archive/%{version}/%{module}-%{version}.tar.gz
-# Source0-md5: c67cc1f04d5a78595eefa55a02629c47
+# Source0-md5: ebfbcb5d98fbf4056aa00a72051499c6
 Patch0:                remove-mypy-test.patch
 Patch1:                plugins-path.patch
 BuildRequires: cmake
This page took 0.054899 seconds and 4 git commands to generate.