]> git.pld-linux.org Git - packages/python3-Uranium.git/commitdiff
- up to 3.5.1 auto/th/python3-Uranium-3.5.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 4 Nov 2018 13:11:08 +0000 (14:11 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 4 Nov 2018 13:11:08 +0000 (14:11 +0100)
plugins-path.patch [deleted file]
python3-Uranium.spec
remove-mypy-test.patch [new file with mode: 0644]

diff --git a/plugins-path.patch b/plugins-path.patch
deleted file mode 100644 (file)
index 4603c0e..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
---- Uranium-2.5.0/CMakeLists.txt~      2017-05-13 23:51:30.000000000 +0200
-+++ Uranium-2.5.0/CMakeLists.txt       2017-05-13 23:56:38.423247507 +0200
-@@ -64,6 +64,6 @@
- install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
-         DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
- install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
--install(DIRECTORY plugins DESTINATION lib/uranium)
-+install(DIRECTORY plugins DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
- include(CPackConfig.cmake)
---- Uranium-2.5.0/UM/Application.py~   2017-04-13 15:03:28.000000000 +0200
-+++ Uranium-2.5.0/UM/Application.py    2017-05-14 11:25:56.345442852 +0200
-@@ -95,7 +95,7 @@
-         self._plugin_registry = PluginRegistry.getInstance()
--        self._plugin_registry.addPluginLocation(os.path.join(Application.getInstallPrefix(), "lib", "uranium"))
-+        self._plugin_registry.addPluginLocation(os.path.join(Application.getInstallPrefix(), "share", "uranium"))
-         self._plugin_registry.addPluginLocation(os.path.join(os.path.dirname(sys.executable), "plugins"))
-         self._plugin_registry.addPluginLocation(os.path.join(Application.getInstallPrefix(), "Resources", "uranium", "plugins"))
-         self._plugin_registry.addPluginLocation(os.path.join(Application.getInstallPrefix(), "Resources", self.getApplicationName(), "plugins"))
index 182596ed6fd08c52c0e2151fe5d5fe323ece5c38..a70acbd39c8c33a7af15959980ca0f08c11d17e9 100644 (file)
@@ -1,14 +1,14 @@
 %define                module          Uranium
 Summary:       A Python framework for building desktop applications
 Name:          python3-%{module}
-Version:       2.5.0
-Release:       4
+Version:       3.5.1
+Release:       1
 License:       AGPLv3+
 Group:         Libraries/Python
 URL:           https://github.com/Ultimaker/Uranium
 Source0:       https://github.com/Ultimaker/Uranium/archive/%{version}/%{module}-%{version}.tar.gz
-# Source0-md5: 28586f24c35d99e5730692defd728b3e
-Patch0:                plugins-path.patch
+# Source0-md5: c67cc1f04d5a78595eefa55a02629c47
+Patch0:                remove-mypy-test.patch
 BuildRequires: cmake
 BuildRequires: doxygen
 BuildRequires: gettext-tools
@@ -17,11 +17,13 @@ BuildRequires:      python3-devel
 BuildRequires: python3-numpy
 BuildRequires: python3-pytest
 BuildRequires: python3-scipy
+BuildRequires: python3-shapely
 BuildRequires: sip-PyQt5
 Requires:      python3-Arcus = %{version}
 Requires:      python3-PyQt5
 Requires:      python3-numpy
 Requires:      python3-scipy
+Requires:      python3-shapely
 Obsoletes:     python3-UM
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -42,14 +44,14 @@ related applications.
 %setup -q -n %{module}-%{version}
 %patch0 -p1
 
+for bad_lang in de_DE es_ES fi_FI fr_FR hu_HU it_IT ja_JP ko_KR nl_NL pl_PL pt_PT ru_RU tr_TR ; do
+       lang="$(echo $bad_lang | sed 's/_.*//')"
+       %{__mv} "resources/i18n/$bad_lang" "resources/i18n/$lang"
+done
+
 # Upstream installs to lib/python3/dist-packages
 # We want to install to %%{py3_sitescriptdir}
-sed -i 's|lib/python${PYTHON_VERSION_MAJOR}/dist-packages|%(echo %{py3_sitescriptdir} | sed -e s@%{_prefix}/@@)|g' CMakeLists.txt
-
-# Invalid locale name ptbr
-# https://github.com/Ultimaker/Uranium/issues/246
-mv resources/i18n/{ptbr,pt_BR}
-sed -i 's/"Language: ptbr\n"/"Language: pt_BR\n"/' resources/i18n/pt_BR/*.po
+sed -i 's|lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.*/.*-packages|%(echo %{py3_sitescriptdir} | sed -e s@%{_prefix}/@@)|g' CMakeLists.txt
 
 # empty file. appending to the end to make sure we are not overriding
 # a non empty file in the future
@@ -91,6 +93,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README.md
 %{py3_sitescriptdir}/UM
+%{_libdir}/uranium
 %{_datadir}/uranium
 %{_datadir}/cmake
 
diff --git a/remove-mypy-test.patch b/remove-mypy-test.patch
new file mode 100644 (file)
index 0000000..4df309e
--- /dev/null
@@ -0,0 +1,13 @@
+--- Uranium-3.5.1/cmake/UraniumTests.cmake~    2018-10-15 11:44:28.000000000 +0200
++++ Uranium-3.5.1/cmake/UraniumTests.cmake     2018-11-04 13:20:29.843658161 +0100
+@@ -46,9 +46,3 @@
+         uranium_add_test(NAME pytest-${_plugin_name} DIRECTORY ${_plugin_directory} PYTHONPATH "${CMAKE_SOURCE_DIR}|${_plugin_directory}")
+     endif()
+ endforeach()
+-
+-#Add code style test.
+-add_test(
+-    NAME "code-style"
+-    COMMAND ${PYTHON_EXECUTABLE} run_mypy.py WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+-)
+\ No newline at end of file
This page took 0.060185 seconds and 4 git commands to generate.