]> git.pld-linux.org Git - packages/python-whisper.git/blob - python-whisper.spec
version 0.9.12-1
[packages/python-whisper.git] / python-whisper.spec
1 Summary:        Simple database library for storing time-series data
2 Name:           python-whisper
3 Version:        0.9.12
4 Release:        1
5 License:        Apache v2.0
6 Group:          Development/Libraries
7 #               https://github.com/graphite-project/whisper/archive/0.9.12.tar.gz
8 Source0:        https://github.com/graphite-project/whisper/archive/%{version}.tar.gz
9 # Source0-md5:  fcaa34d128d13278ba1b8e23443e0871
10 # Source0:      https://codeload.github.com/graphite-project/whisper/whisper-%{version}.tar.gz
11 URL:            https://launchpad.net/graphite/
12 BuildRequires:  python-setuptools
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 BuildArch:      noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 simple database library for storing time-series data (similar in
20 design to RRD)
21
22 %prep
23 %setup -q -n whisper-%{version}
24
25 %build
26 %{__python} setup.py build
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 %{__python} setup.py install \
31         --skip-build \
32         --optimize=2 \
33         --root=$RPM_BUILD_ROOT
34
35 %py_postclean
36
37 # Temp mv to non .py locations
38 cd $RPM_BUILD_ROOT%{_bindir}
39 %{__mv} rrd2whisper.py rrd2whisper
40 %{__mv} whisper-create.py whisper-create
41 %{__mv} whisper-dump.py whisper-dump
42 %{__mv} whisper-fetch.py whisper-fetch
43 %{__mv} whisper-info.py whisper-info
44 %{__mv} whisper-merge.py whisper-merge
45 %{__mv} whisper-resize.py whisper-resize
46 %{__mv} whisper-set-aggregation-method.py whisper-set-aggregation-method
47 %{__mv} whisper-update.py whisper-update
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %attr(755,root,root) %{_bindir}/rrd2whisper
55 %attr(755,root,root) %{_bindir}/whisper-create
56 %attr(755,root,root) %{_bindir}/whisper-dump
57 %attr(755,root,root) %{_bindir}/whisper-fetch
58 %attr(755,root,root) %{_bindir}/whisper-info
59 %attr(755,root,root) %{_bindir}/whisper-merge
60 %attr(755,root,root) %{_bindir}/whisper-resize
61 %attr(755,root,root) %{_bindir}/whisper-set-aggregation-method
62 %attr(755,root,root) %{_bindir}/whisper-update
63 %{py_sitescriptdir}/whisper-%{version}-py*.egg-info
64 %{py_sitescriptdir}/whisper.py[co]
This page took 0.145995 seconds and 3 git commands to generate.