]> git.pld-linux.org Git - packages/python-webunit.git/blob - python-webunit.spec
74c6499d834963d9a15244ce052a137b351b7c32
[packages/python-webunit.git] / python-webunit.spec
1
2 %define         module  webunit
3
4 Summary:        Website unit/regression testing tool
5 Summary(pl.UTF-8):   Narzędzie do testowania modułów sieci Web
6 Name:           python-%{module}
7 Version:        1.3.8
8 Release:        1
9 License:        BSD-like
10 Group:          Libraries/Python
11 Source0:        http://www.mechanicalcat.net/tech/webunit/%{module}-%{version}.tar.gz
12 # Source0-md5:  97b9e6b5149dadce48b86adbf2db3b0a
13 URL:            http://www.mechanicalcat.net/tech/webunit/
14 BuildRequires:  python-devel >= 1:2.3
15 Requires:       python >= 2.3
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 webunit test your websites with code that acts like a web browser.
21
22 Features in a nutshell:
23
24 1. Browser-like page fetching including fetching the images and
25    stylesheets needed for a page and following redirects
26 2. Cookies stored and trackable (all automatically handled)
27 3. HTTP, HTTPS, GET, POST, basic auth all handled, control over
28    expected status codes, ...
29 4. DOM parsing of pages to retrieve and analyse structure, including
30    simple form re-posting
31 5. Two-line page-fetch followed by form-submit possible, with error
32    checking
33 6. Ability to register error page content across multiple tests
34 7. Uses python's standard unittest module as the underlying framework
35
36 %description -l pl.UTF-8
37 webunit używany jest do testowania stron WWW przy pomocy kodu
38 symulującego działanie przeglądarki internetowej.
39
40 Cechy webunit:
41
42 1. Pobieranie stron WWW symulujące działanie przeglądarki
43    internetowej, pobieranie obrazków i styli, podążanie za
44    przekierowaniami.
45 2. Automatyczna obsługa ciasteczek (cookies).
46 3. Obsługa protokołów HTTP, HTTPS, metod GET, POST, uwierzytelniania,
47    kontrola oczekiwanych kodów statusu.
48 4. Parsowanie struktury DOM stron w celu pobrania i analizy strony,
49    także w celu łatwego odsyłania formularzy.
50 5. Dwutorowe pobieranie strony kończone wysyłką formularza wraz ze
51    sprawdzaniem błędów.
52 6. Możliwość określenia zawartości strony z błędem przy przechodzeniu
53    przez kolejne testy.
54 7. Użycie standardowego modułu pythona unittest jako zasadniczego
55    szkieletu testu.
56
57 %prep
58 %setup -q -n %{module}-%{version}
59
60 %build
61 python setup.py build_ext
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{py_sitescriptdir}
66
67 python setup.py install \
68         --root=$RPM_BUILD_ROOT \
69         --install-lib=%{py_sitescriptdir} \
70         --optimize=2
71
72 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec rm {} \;
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %files
78 %defattr(644,root,root,755)
79 %doc CHANGES.txt demo README.txt run_tests
80 %{py_sitescriptdir}/webunit
This page took 0.045858 seconds and 2 git commands to generate.