]> git.pld-linux.org Git - packages/python-webcolors.git/commitdiff
- version 1.3.1,
authorcieciwa <cieciwa@pld-linux.org>
Tue, 18 Oct 2011 07:05:59 +0000 (07:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- release 0.1.

initial

Changed files:
    python-webcolors.spec -> 1.1

python-webcolors.spec [new file with mode: 0644]

diff --git a/python-webcolors.spec b/python-webcolors.spec
new file mode 100644 (file)
index 0000000..3417dd0
--- /dev/null
@@ -0,0 +1,51 @@
+%define        module  webcolors
+Summary:       A library for working with color names and color value formats defined by the HTML and CSS specifications for use in documents on the Web.
+Name:          python-%module
+Version:       1.3.1
+Release:       0.1
+License:       BSD License
+Group:         Development/Languages
+URL:           http://www.bitbucket.org/ubernostrum/webcolors/overview/
+Source0:       http://bitbucket.org/ubernostrum/%{module}/downloads/%{module}-%{version}.tar.gz
+# Source0-md5: aeb4f33be6c26ec7f76a78c2d88cfb0c
+BuildRequires: python-funcparserlib >= 0.3.4
+BuildRequires: rpmbuild(macros) >= 1.219
+BuildRequires: sed >= 4.0
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+A library for working with color names and color value formats defined by the HTML and CSS specifications for use in documents on the Web.
+
+Support is included for the following formats (RGB colorspace only; conversion to/from HSL can be handled by the colorsys module in the Python standard library):
+
+- Specification-defined color names
+- Six-digit hexadecimal
+- Three-digit hexadecimal
+- Integer rgb() triplet
+- Percentage rgb() triple
+
+%prep
+%setup -q -n %{module}-%{version}
+%{__sed} -i -e 's/^from ez_setup/#from ez_setup/' setup.py
+%{__sed} -i -e 's/^use_setuptools()/#use_setuptools()/' setup.py
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+       --optimize=2 \
+       --skip-build \
+       --root $RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%{py_sitescriptdir}/%{module}.*
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/%{module}-%{version}-*.egg-info
+%endif
This page took 0.04968 seconds and 4 git commands to generate.