]> git.pld-linux.org Git - packages/python-testscenarios.git/blob - python-testscenarios.spec
- removed redundant dependencies (pythonegg ones are autogenerated)
[packages/python-testscenarios.git] / python-testscenarios.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # make check
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Testscenarios - pyunit extension for dependency injection
8 Summary(pl.UTF-8):      Testscenarios - rozszerzenie pyunit do wstrzykiwania zależności
9 Name:           python-testscenarios
10 Version:        0.5.0
11 Release:        4
12 License:        Apache v2.0 or BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/testscenarios/
15 Source0:        https://files.pythonhosted.org/packages/source/t/testscenarios/testscenarios-%{version}.tar.gz
16 # Source0-md5:  859073d9e7b049aee2e6704c51f6001a
17 URL:            https://launchpad.net/testscenarios
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-pbr >= 0.11
23 BuildRequires:  python-setuptools
24 BuildRequires:  python-testtools
25 %endif
26 %if %{with python3}
27 BuildRequires:  python3-modules >= 1:3.2
28 BuildRequires:  python3-pbr >= 0.11
29 BuildRequires:  python3-setuptools
30 BuildRequires:  python3-testtools
31 %endif
32 Requires:       python-modules >= 1:2.6
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 testscenarios provides clean dependency injection for python unittest
38 style tests. This can be used for interface testing (testing many
39 implementations via a single test suite) or for classic dependency
40 injection (provide tests with dependencies externally to the test code
41 itself, allowing easy testing in different situations).
42
43 %description -l pl.UTF-8
44 Moduł testscenarios zapewnia czyste wstrzykiwanie zależności dla
45 testów pythonowych w stylu unittest. Może to być używane do testowania
46 interfejsów (testowania wielu implementacji poprzez prosty zestaw
47 testów) albo klasycznego wstrzykiwania zależności (dostarczania testów
48 z zależnościami zewnętrznymi w stosunku do kodu testującego, co
49 pozwala na łatwiejsze testowanie w różnych sytuacjach).
50
51 %package -n python3-testscenarios
52 Summary:        Testscenarios - pyunit extension for dependency injection
53 Summary(pl.UTF-8):      Testscenarios - rozszerzenie pyunit do wstrzykiwania zależności
54 Group:          Libraries/Python
55 Requires:       python3-modules >= 1:3.2
56
57 %description -n python3-testscenarios
58 testscenarios provides clean dependency injection for python unittest
59 style tests. This can be used for interface testing (testing many
60 implementations via a single test suite) or for classic dependency
61 injection (provide tests with dependencies externally to the test code
62 itself, allowing easy testing in different situations).
63
64 %description -n python3-testscenarios -l pl.UTF-8
65 Moduł testscenarios zapewnia czyste wstrzykiwanie zależności dla
66 testów pythonowych w stylu unittest. Może to być używane do testowania
67 interfejsów (testowania wielu implementacji poprzez prosty zestaw
68 testów) albo klasycznego wstrzykiwania zależności (dostarczania testów
69 z zależnościami zewnętrznymi w stosunku do kodu testującego, co
70 pozwala na łatwiejsze testowanie w różnych sytuacjach).
71
72 %prep
73 %setup -q -n testscenarios-%{version}
74
75 %build
76 %if %{with python2}
77 %py_build
78
79 %if %{with tests}
80 %{__make} check \
81         PYTHON=%{__python}
82 %endif
83 %endif
84
85 %if %{with python3}
86 %py3_build
87
88 %if %{with tests}
89 %{__make} check \
90         PYTHON=%{__python3}
91 %endif
92 %endif
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %if %{with python2}
98 %py_install
99
100 %py_postclean
101 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/testscenarios/tests
102 %endif
103
104 %if %{with python3}
105 %py3_install
106 %{__rm} -r $RPM_BUILD_ROOT%{py3_sitescriptdir}/testscenarios/tests
107 %endif
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %if %{with python2}
113 %files
114 %defattr(644,root,root,755)
115 %doc AUTHORS BSD COPYING ChangeLog GOALS NEWS README
116 %{py_sitescriptdir}/testscenarios
117 %{py_sitescriptdir}/testscenarios-%{version}-py*.egg-info
118 %endif
119
120 %if %{with python3}
121 %files -n python3-testscenarios
122 %defattr(644,root,root,755)
123 %doc AUTHORS BSD COPYING ChangeLog GOALS NEWS README
124 %{py3_sitescriptdir}/testscenarios
125 %{py3_sitescriptdir}/testscenarios-%{version}-py*.egg-info
126 %endif
This page took 0.043685 seconds and 3 git commands to generate.