]> git.pld-linux.org Git - packages/python-pyudev.git/commitdiff
- new package
authorJacek Konieczny <jajcus@pld-linux.org>
Tue, 26 Jun 2012 12:13:21 +0000 (12:13 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-pyudev.spec -> 1.1

python-pyudev.spec [new file with mode: 0644]

diff --git a/python-pyudev.spec b/python-pyudev.spec
new file mode 100644 (file)
index 0000000..633579a
--- /dev/null
@@ -0,0 +1,56 @@
+#
+# Conditional build:
+%bcond_without tests   # do not perform "make test"
+
+%define        module  pyudev
+Summary:       Pure Python binding for libudev
+Name:          python-%{module}
+Version:       0.15
+Release:       1
+License:       LGPL v2.1+
+Group:         Development/Languages/Python
+Source0:       http://pypi.python.org/packages/source/p/pyudev/%{module}-%{version}.tar.gz
+# Source0-md5: 35d7295e71664bb630a1fa61ad11d6f6
+URL:           http://pyudev.readthedocs.org/
+BuildRequires: python-distribute
+BuildRequires: rpm-pythonprov
+Requires:      python-modules
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+pyudev is a LGPL licensed, pure Python binding for libudev, the device
+and hardware management and information library for Linux. It supports
+almost all libudev functionality, you can enumerate devices, query
+device properties and attributes or monitor devices, including
+asynchronous monitoring with threads, or within the event loops of Qt,
+Glib or wxPython.
+
+%prep
+%setup -q -n %{module}-%{version}
+
+%build
+%{__python} setup.py build
+
+%{?with_tests:%{__python} setup.py test}
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+       --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+
+%py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
+%py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc CHANGES.rst README.rst TESTING.rst doc/
+%{py_sitescriptdir}/%{module}
+%{py_sitescriptdir}/*.egg-info
This page took 0.294907 seconds and 4 git commands to generate.