]> git.pld-linux.org Git - packages/python-pyaudio.git/blob - python-pyaudio.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-pyaudio.git] / python-pyaudio.spec
1 %define         module  pyaudio
2 Summary:        Python bindings for PortAudio
3 Name:           python-%{module}
4 Version:        0.2.4
5 Release:        3
6 License:        MIT
7 Group:          Development/Languages/Python
8 Source0:        http://people.csail.mit.edu/hubert/pyaudio/packages/%{module}-%{version}.tar.gz
9 # Source0-md5:  623809778f3d70254a25492bae63b575
10 URL:            http://people.csail.mit.edu/hubert/pyaudio/
11 BuildRequires:  python-devel
12 BuildRequires:  python-distribute
13 BuildRequires:  rpm-pythonprov
14 # if py_postclean is used
15 BuildRequires:  rpmbuild(macros) >= 1.710
16 Requires:       python-libs
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 PyAudio provides Python bindings for PortAudio, the cross-platform
22 audio I/O library. With PyAudio, you can easily use Python to play
23 and record audio on a variety of platforms.
24
25 PyAudio is designed to work with the PortAudio v19 API 2.0. Note that
26 PyAudio currently only supports blocking-mode audio I/O.
27
28 %prep
29 %setup -q -n PyAudio-%{version}
30
31 %build
32 %py_build
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 %py_install
37
38 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
39 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
40 %py_postclean
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(644,root,root,755)
47 %doc CHANGELOG README docs/*
48 %{py_sitedir}/*.py[co]
49 %attr(755,root,root) %{py_sitedir}/*.so
50 %{py_sitedir}/PyAudio-*.egg-info
This page took 0.080925 seconds and 3 git commands to generate.