]> git.pld-linux.org Git - packages/python-psycopg2.git/commitdiff
- copied from python-psycopg.spec (on server side) and merged from DEVEL
authorwrobell <wrobell@pld-linux.org>
Wed, 21 Jun 2006 11:45:38 +0000 (11:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-psycopg2.spec -> 1.44

python-psycopg2.spec

index 7785097e9e578fe36bc9e924faceee8f1ff760e2..778745df53d5893529d41cb0cb913d3f87618080 100644 (file)
@@ -1,26 +1,29 @@
+#
+# todo:
+# - zope adapter
+# - lib64 patch
+#
 
-%define        module  psycopg
+%define        module  psycopg2
+%define                beta    b8
 
 Summary:       psycopg is a PostgreSQL database adapter for Python
 Summary(pl):   psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
 Name:          python-%{module}
-Version:       1.1.21
-Release:       1
+Version:       2.0
+Release:       0.%{beta}.1
 License:       GPL
 Group:         Libraries/Python
-Source0:       http://initd.org/pub/software/psycopg/%{module}-%{version}.tar.gz
-# Source0-md5: a31f79f68d6d32898d6f24e11369a106
-Patch0:                %{name}-lib64.patch
+Source0:       http://initd.org/pub/software/psycopg/%{module}-%{version}%{beta}.tar.gz
+# Source0-md5: f16d464e184351cac9c11814501083bc
+#Patch0:               %{name}-lib64.patch
 URL:           http://www.initd.org/software/psycopg/
 BuildRequires: autoconf
 BuildRequires: postgresql-backend-devel
 BuildRequires: postgresql-devel
 BuildRequires: python-devel
-BuildRequires: python-mx-DateTime-devel
-BuildRequires: rpm-pythonprov
 Requires:      postgresql-libs
 %pyrequires_eq python-modules
-Requires:      python-mx-DateTime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define zope_subname ZPsycopgDA
@@ -53,53 +56,52 @@ Zope PostgreSQL database adapter.
 Interfejs bazy danych PostgreSQL do Zope.
 
 %prep
-%setup -q -n %{module}-%{version}
-%if "%{_lib}" == "lib64"
-%patch0 -p1
-%endif
+%setup -q -n %{module}-%{version}%{beta}
+#%if "%{_lib}" == "lib64"
+#%patch0 -p1
+#%endif
 
 %build
-%{__autoconf}
-
-%configure \
-       --with-python=%{_bindir}/python \
-       --with-mxdatetime-includes=%{py_incdir}/mx \
-       --with-postgres-includes=%{_includedir}/postgresql/server
-%{__make}
+python setup.py build
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{py_sitedir},%{_datadir}/Zope-%{zope_subname}}
 
-install psycopgmodule.so $RPM_BUILD_ROOT%{py_sitedir}
+python setup.py install --optimize=2 --root=$RPM_BUILD_ROOT
+
+find $RPM_BUILD_ROOT%{py_libdir} -type f -name "*.py" | xargs rm
+
+#install -d $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
 
-cp -ar %{zope_subname}/* $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
-%py_comp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
-%py_ocomp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
-rm -f $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}/*.py
+#cp -ar %{zope_subname}/* $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+#%py_comp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+#%py_ocomp $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}
+#rm -f $RPM_BUILD_ROOT%{_datadir}/Zope-%{zope_subname}/*.py
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -n Zope-%{zope_subname}
-/usr/sbin/installzopeproduct %{_datadir}/Zope-%{zope_subname} %{zope_subname}
-if [ -f /var/lock/subsys/zope ]; then
-       /etc/rc.d/init.d/zope restart >&2
-fi
+#%post -n Zope-%{zope_subname}
+#/usr/sbin/installzopeproduct %{_datadir}/Zope-%{zope_subname} %{zope_subname}
+#if [ -f /var/lock/subsys/zope ]; then
+#      /etc/rc.d/init.d/zope restart >&2
+#fi
 
-%postun -n Zope-%{zope_subname}
-if [ "$1" = "0" ]; then
-       /usr/sbin/installzopeproduct -d %{zope_subname} 
-       if [ -f /var/lock/subsys/zope ]; then
-               /etc/rc.d/init.d/zope restart >&2
-       fi
-fi
+#%postun -n Zope-%{zope_subname}
+#if [ "$1" = "0" ]; then
+#      /usr/sbin/installzopeproduct -d %{zope_subname} 
+#      if [ -f /var/lock/subsys/zope ]; then
+#              /etc/rc.d/init.d/zope restart >&2
+#      fi
+#fi
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CREDITS FAQ NEWS README RELEASE-1.0 SUCCESS TODO doc
-%attr(755,root,root) %{py_sitedir}/*.so
-
-%files -n Zope-%{zope_subname}
-%defattr(644,root,root,755)
-%{_datadir}/Zope-%{zope_subname}
+%doc ChangeLog AUTHORS README doc/HACKING doc/SUCCESS doc/TODO
+%dir %{py_sitedir}/%{module}
+%attr(755,root,root) %{py_sitedir}/%{module}/*.so
+%{py_sitedir}/%{module}/*.py[co]
+
+#%files -n Zope-%{zope_subname}
+#%defattr(644,root,root,755)
+#%{_datadir}/Zope-%{zope_subname}
This page took 0.101622 seconds and 4 git commands to generate.