]> git.pld-linux.org Git - packages/python-psycopg2.git/commitdiff
- Zope database adapter added (Zope-ZPsycopgDA package) auto/ac/python-psycopg-1_1_9-3
authorJacek Konieczny <jajcus@pld-linux.org>
Thu, 30 Oct 2003 13:27:53 +0000 (13:27 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-psycopg2.spec -> 1.21

python-psycopg2.spec

index 16d17bf14db26ad754987781318d97f6957cd084..8fb3dab2eacc5fd3c82d17808703592660c16731 100644 (file)
@@ -6,7 +6,7 @@ Summary:        psycopg is a PostgreSQL database adapter for Python
 Summary(pl):   psycopg jest przeznaczonym dla Pythona interfejsem do bazy PostgreSQL
 Name:          python-%{module}
 Version:       1.1.9
-Release:       2
+Release:       3
 License:       GPL
 Group:         Libraries/Python
 Source0:       http://initd.org/pub/software/%{module}/%{module}-%{version}.tar.gz
@@ -21,6 +21,13 @@ Requires:    postgresql-libs
 Requires:      python-mx-DateTime
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define prod_name ZPsycopgDA
+%define zope_dir          %{_libdir}/zope
+%define zope_productsdir   %{zope_dir}/Products
+%define python_compile_opt python -O -c "import compileall; compileall.compile_dir('.')"
+%define python_compile     python -c "import compileall; compileall.compile_dir('.')"
+
+
 %description
 psycopg is a PostgreSQL database adapter for the Python programming
 language (just like pygresql and popy.) It was written from scratch
@@ -35,6 +42,21 @@ z za
 psycopg jest, ¿e w jest pe³ni zgodny z standardem DBAPI-2.0 i jest
 'thread safe' na poziomie 2.
 
+%package -n Zope-%{prod_name}
+Summary:       Zope PostgreSQL database adapter
+Summary(pl):   Interfejs bazy danych PostgreSQL do Zope
+Group:         Development/Languages/Python
+Requires:      Zope
+Requires:      %{name} = %{version}
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description -n Zope-%{prod_name}
+Zope PostgreSQL database adapter.
+
+%description -n Zope-%{prod_name} -l pl
+Interfejs bazy danych PostgreSQL do Zope.
+
 %prep
 %setup -q -n %{module}-%{version}
 %patch0 -p1
@@ -48,12 +70,20 @@ psycopg jest, 
        --with-postgres-includes=%{_includedir}/postgresql/server
 %{__make}
 
+cd %{prod_name}
+%{python_compile}
+%{python_compile_opt}
+cd ..
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{py_sitedir}
+install -d $RPM_BUILD_ROOT{%{py_sitedir},%{zope_productsdir}/%{prod_name}}
 
 install psycopgmodule.so $RPM_BUILD_ROOT%{py_sitedir}
 
+cp -ar %{prod_name}/* $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}
+rm -f $RPM_BUILD_ROOT%{zope_productsdir}/%{prod_name}/*.py
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -61,3 +91,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS CREDITS FAQ NEWS README RELEASE-1.0 SUCCESS TODO doc
 %attr(755,root,root) %{py_sitedir}/*.so
+
+%files -n Zope-%{prod_name}
+%defattr(644,root,root,755)
+%{zope_productsdir}/%{prod_name}
This page took 0.124188 seconds and 4 git commands to generate.