]> git.pld-linux.org Git - packages/python-pillow.git/commitdiff
- updated to 6.2.2 (latest supporting python2)
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 17 Jan 2020 14:59:38 +0000 (15:59 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 17 Jan 2020 14:59:38 +0000 (15:59 +0100)
- updated subpackage patch

python-pillow-subpackage.patch
python-pillow.spec

index b4317f7a5a19739db61015d459f71624fa445da1..308e13b23c79916828f39d94fb49bcb54d300c23 100644 (file)
@@ -1,8 +1,8 @@
---- Pillow-5.1.0/src/PIL/__init__.py.orig      2018-04-02 21:39:54.000000000 +0200
-+++ Pillow-5.1.0/src/PIL/__init__.py   2018-05-28 20:33:55.895681992 +0200
-@@ -18,6 +18,13 @@
+--- Pillow-6.2.2/src/PIL/__init__.py.orig      2020-01-02 09:33:30.000000000 +0100
++++ Pillow-6.2.2/src/PIL/__init__.py   2020-01-17 15:43:39.054018740 +0100
+@@ -24,6 +24,13 @@
+ del _version
  
- __version__ = PILLOW_VERSION
  
 +def _get_optional_plugins():
 +    try:
 +    except:
 +        return []
 +
- _plugins = ['BlpImagePlugin',
-             'BmpImagePlugin',
-             'BufrStubImagePlugin',
-@@ -54,7 +61,6 @@
-             'PpmImagePlugin',
-             'PsdImagePlugin',
-             'SgiImagePlugin',
--            'SpiderImagePlugin',
-             'SunImagePlugin',
-             'TgaImagePlugin',
-             'TiffImagePlugin',
-@@ -62,4 +68,4 @@
-             'WmfImagePlugin',
-             'XbmImagePlugin',
-             'XpmImagePlugin',
--            'XVThumbImagePlugin']
-+            'XVThumbImagePlugin'] + _get_optional_plugins()
+ _plugins = [
+     "BlpImagePlugin",
+     "BmpImagePlugin",
+@@ -61,7 +68,6 @@
+     "PpmImagePlugin",
+     "PsdImagePlugin",
+     "SgiImagePlugin",
+-    "SpiderImagePlugin",
+     "SunImagePlugin",
+     "TgaImagePlugin",
+     "TiffImagePlugin",
+@@ -70,4 +76,4 @@
+     "XbmImagePlugin",
+     "XpmImagePlugin",
+     "XVThumbImagePlugin",
+-]
++] + _get_optional_plugins()
index 699346e5b5c0e64ec1e8f1c8986e09059412de0b..7cb5b0b0cc002a6b4214997d744e1303ae4ff435 100644 (file)
 Summary:       Python 2 image processing library
 Summary(pl.UTF-8):     Biblioteka do przetwarzania obrazów dla Pythona 2
 Name:          python-%{module}
-Version:       5.3.0
-Release:       2
+# NOTE: keep 6.x in this spec for python 2.x support
+Version:       6.2.2
+Release:       1
 # License: see http://www.pythonware.com/products/pil/license.htm
 License:       MIT
 Group:         Libraries/Python
 #Source0Download: https://pypi.org/simple/pillow/
 Source0:       https://files.pythonhosted.org/packages/source/P/Pillow/Pillow-%{version}.tar.gz
-# Source0-md5: 0da5a4c9c548aa5cfe999302aea8c8f1
+# Source0-md5: 46cad14f0044a5ac4b2d801271528893
 Patch0:                %{name}-subpackage.patch
 Patch1:                x32.patch
 URL:           http://python-pillow.github.io/
@@ -30,11 +31,11 @@ BuildRequires:      lcms2-devel >= 2
 BuildRequires: libimagequant-devel
 BuildRequires: libjpeg-devel
 BuildRequires: libraqm-devel
-BuildRequires: libtiff-devel
+BuildRequires: libtiff-devel >= 4
 BuildRequires: libwebp-devel
 BuildRequires: openjpeg2-devel >= 2
 BuildRequires: pkgconfig
-BuildRequires: rpmbuild(macros) >= 1.710
+BuildRequires: rpmbuild(macros) >= 1.714
 BuildRequires: tk-devel
 BuildRequires: zlib-devel
 %if %{with python2}
@@ -50,7 +51,7 @@ BuildRequires:        sphinx-pdg-2
 %endif
 %if %{with python3}
 BuildRequires: python3-cffi
-BuildRequires: python3-devel >= 1:3.4
+BuildRequires: python3-devel >= 1:3.5
 BuildRequires: python3-numpy
 BuildRequires: python3-setuptools
 BuildRequires: python3-tkinter
This page took 0.172826 seconds and 4 git commands to generate.