]> git.pld-linux.org Git - packages/python-nss.git/commitdiff
- updated to 1.0.0; python3 module added auto/th/python-nss-1.0.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 2 Nov 2016 19:38:55 +0000 (20:38 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 2 Nov 2016 19:38:55 +0000 (20:38 +0100)
python-nss.spec

index e87b103eea8f11e58970c2f4f78718c131c6f01f..843437e7a360812e166a1127084c4a7be7662dcd 100644 (file)
@@ -1,48 +1,81 @@
-Summary:       Python bindings for NSS and NSPR
-Summary(pl.UTF-8):     Wiązania Pythona do bibliotek NSS i NSPR
+#
+# Conditional build:
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+Summary:       Python 2 bindings for NSS and NSPR
+Summary(pl.UTF-8):     Wiązania Pythona 2 do bibliotek NSS i NSPR
 Name:          python-nss
-Version:       0.17.0
+Version:       1.0.0
 Release:       1
-License:       MPL v1.1 or GPL v2+ or LGPL v2+
+License:       MPL v2.0 or GPL v2+ or LGPL v2+
 Group:         Development/Languages/Python
-Source0:       http://ftp.mozilla.org/pub/mozilla.org/security/python-nss/releases/PYNSS_RELEASE_0_17_0/src/%{name}-%{version}.tar.bz2
-# Source0-md5: a3401d468fcd519cbe0c01ba96baaca9
+Source0:       http://ftp.mozilla.org/pub/security/python-nss/releases/PYNSS_RELEASE_1_0_0/src/%{name}-%{version}.tar.bz2
+# Source0-md5: 2159793d207f8d1f15556fd7fcfddc48
 URL:           http://www.mozilla.org/projects/security/pki/nss/
 BuildRequires: nspr-devel >= 4
 BuildRequires: nss-devel >= 3
-BuildRequires: python-devel >= 2
+%{?with_python2:BuildRequires: python-devel >= 1:2.7}
+%{?with_python3:BuildRequires: python3-devel >= 1:3.2}
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.710
-Requires:      python-libs >= 2
+BuildRequires: rpmbuild(macros) >= 1.714
+Requires:      python-libs >= 1:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-Python bindings for Network Security Services (NSS) and Netscape
+Python bindings for Network Security Services (NSS) and Netscape
 Portable Runtime (NSPR).
 
 %description -l pl.UTF-8
-Wiązania Pythona do bibliotek NSS (Network Security Services) oraz
+Wiązania Pythona 2 do bibliotek NSS (Network Security Services) oraz
+NSPR (Netscape Portable Runtime).
+
+%package -n python3-nss
+Summary:       Python 3 bindings for NSS and NSPR
+Summary(pl.UTF-8):     Wiązania Pythona 3 do bibliotek NSS i NSPR
+Group:         Development/Languages/Python
+Requires:      python3-libs >= 1:3.2
+
+%description -n python3-nss
+Python 3 bindings for Network Security Services (NSS) and Netscape
+Portable Runtime (NSPR).
+
+%description -n python3-nss -l pl.UTF-8
+Wiązania Pythona 3 do bibliotek NSS (Network Security Services) oraz
 NSPR (Netscape Portable Runtime).
 
 %prep
 %setup -q
 
 %build
+%if %{with python2}
 %py_build
+%endif
+
+%if %{with python3}
+%py3_build
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %py_install
 
 %py_postclean
+%endif
+
+%if %{with python3}
+%py3_install
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%if %{with python2}
 %files
 %defattr(644,root,root,755)
-%doc README
+%doc README doc/ChangeLog
 %dir %{py_sitedir}/nss
 %{py_sitedir}/nss/__init__.py[co]
 %attr(755,root,root) %{py_sitedir}/nss/error.so
@@ -50,3 +83,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{py_sitedir}/nss/nss.so
 %attr(755,root,root) %{py_sitedir}/nss/ssl.so
 %{py_sitedir}/python_nss-%{version}-py*.egg-info
+%endif
+
+%if %{with python3}
+%files -n python3-nss
+%defattr(644,root,root,755)
+%doc README doc/ChangeLog
+%dir %{py3_sitedir}/nss
+%{py3_sitedir}/nss/__init__.py
+%{py3_sitedir}/nss/__pycache__
+%attr(755,root,root) %{py3_sitedir}/nss/error.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/nss/io.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/nss/nss.cpython-*.so
+%attr(755,root,root) %{py3_sitedir}/nss/ssl.cpython-*.so
+%{py3_sitedir}/python_nss-%{version}-py*.egg-info
+%endif
This page took 0.0889720000000001 seconds and 4 git commands to generate.