]> git.pld-linux.org Git - packages/python-kombu.git/blob - python-kombu.spec
- URL, rel 1
[packages/python-kombu.git] / python-kombu.spec
1 %define         module  kombu
2 Summary:        AMQP Messaging Framework for Python
3 Name:           python-%{module}
4 Version:        1.5.1
5 Release:        1
6 License:        BSD-like
7 Group:          Development/Languages/Python
8 Source0:        http://pypi.python.org/packages/source/k/%{module}/%{module}-%{version}.tar.gz
9 # Source0-md5:  50662f3c7e9395b3d0721fb75d100b63
10 URL:            http://pypi.python.org/pypi/kombu
11 BuildRequires:  python-distribute
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  rpmbuild(macros) >= 1.219
14 Requires:       python-amqplib >= 0.6
15 Requires:       python-anyjson >= 0.3.1
16 Requires:       python-modules
17 Requires:       python-pyparsing
18 BuildArch:      noarch
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The aim of Kombu is to make messaging in Python as easy as possible by
23 providing an idiomatic high-level interface for the AMQP protocol, and
24 also provide proven and tested solutions to common messaging problems.
25
26 %prep
27 %setup -q -n %{module}-%{version}
28
29 %build
30 %{__python} setup.py build
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 %{__python} setup.py install \
35         --skip-build \
36         --optimize=2 \
37         --root=$RPM_BUILD_ROOT
38
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc AUTHORS Changelog FAQ README THANKS TODO
47
48 %{py_sitescriptdir}/%{module}
49 %if "%{py_ver}" > "2.4"
50 %{py_sitescriptdir}/%{module}-*.egg-info
51 %endif
This page took 0.072072 seconds and 4 git commands to generate.