]> git.pld-linux.org Git - packages/python-git.git/commitdiff
- new auto/th/python-git-0_2_0-0_beta1_1
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 10 Aug 2010 12:18:11 +0000 (12:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    python-git.spec -> 1.1

python-git.spec [new file with mode: 0644]

diff --git a/python-git.spec b/python-git.spec
new file mode 100644 (file)
index 0000000..e6aaa3d
--- /dev/null
@@ -0,0 +1,56 @@
+%define        module  git
+%define                subver  beta1
+%define                rel             1
+Summary:       Python Git Library
+Name:          python-%{module}
+Version:       0.2.0
+Release:       0.%{subver}.%{rel}
+License:       BSD
+Group:         Development/Languages
+URL:           http://pypi.python.org/pypi/GitPython/
+Source0:       http://pypi.python.org/packages/source/G/GitPython/GitPython-%{version}-%{subver}.tar.gz
+# Source0-md5: 88a5972c28917d1c32ec28f358f620df
+BuildRequires: python-devel
+BuildRequires: python-setuptools
+BuildRequires: rpmbuild(macros) >= 1.219
+Obsoletes:     GitPython
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+GitPython is a Python library used to interact with Git repositories.
+
+GitPython provides object model access to your git repository. Once
+you have created a repository object, you can traverse it to find
+parent commit(s), trees, blobs, etc.
+
+GitPython is a port of the grit library in Ruby created by Tom
+Preston-Werner and Chris Wanstrath.
+
+%prep
+%setup -q -n GitPython-%{version}-%{subver}
+
+%build
+%{__python} setup.py build
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%{__python} setup.py install \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+%py_postclean
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(644,root,root,755)
+%doc README CHANGES LICENSE AUTHORS
+%dir %{py_sitescriptdir}/git
+%{py_sitescriptdir}/git/*.py[co]
+%dir %{py_sitescriptdir}/git/objects
+%{py_sitescriptdir}/git/objects/*.py[co]
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/GitPython-%{version}*.egg-info
+%endif
This page took 0.177464 seconds and 4 git commands to generate.