]> git.pld-linux.org Git - packages/python-fuse.git/blob - python-fuse.spec
rebuild with separate debuginfo build-ids
[packages/python-fuse.git] / python-fuse.spec
1 %define         module  fuse
2 Summary:        Python interface to FUSE (Filesystem in USErspace)
3 Summary(pl.UTF-8):      Pythonowy interfejs do FUSE (systemu plików w przestrzeni użytkownika)
4 Name:           python-%{module}
5 Version:        0.2.1
6 Release:        5
7 License:        LGPL v2.1
8 Group:          Development/Languages/Python
9 Source0:        http://downloads.sourceforge.net/fuse/fuse-python-%{version}.tar.gz
10 # Source0-md5:  9d9c5c2311ac04291ce822dfece108f8
11 URL:            http://sourceforge.net/apps/mediawiki/fuse/index.php?title=FusePython
12 BuildRequires:  libfuse-devel
13 BuildRequires:  pkgconfig
14 BuildRequires:  python-devel >= 1:2.5
15 BuildRequires:  rpm-pythonprov
16 BuildRequires:  rpmbuild(macros) >= 1.710
17 Requires:       python-modules
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Python interface to FUSE (Filesystem in USErspace).
22
23 %description -l pl.UTF-8
24 Pythonowy interfejs do FUSE (Filesystem in USErspace - systemu plików
25 w przestrzeni użytkownika).
26
27 %prep
28 %setup -q -n fuse-python-%{version}
29
30 %build
31 %py_build
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35 %py_install
36
37 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
38 cp -p example/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}-%{release}
39 %py_postclean
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc AUTHORS Changelog FAQ README*
47 %{py_sitedir}/fuse.py[co]
48 %dir %{py_sitedir}/fuseparts
49 %{py_sitedir}/fuseparts/*.py[co]
50 %attr(755,root,root) %{py_sitedir}/fuseparts/*.so
51 %{py_sitedir}/fuse_python-%{version}-py*.egg-info
52 %{_examplesdir}/%{name}-%{version}-%{release}
This page took 0.045176 seconds and 3 git commands to generate.