]> git.pld-linux.org Git - packages/python-flask-babel.git/commitdiff
Release 1. Cleanup auto/th/python-flask-babel-0.9-1
authorMateusz Korniak <matkor@pld-linux.org>
Fri, 3 Oct 2014 10:51:58 +0000 (12:51 +0200)
committerMateusz Korniak <matkor@pld-linux.org>
Fri, 3 Oct 2014 10:51:58 +0000 (12:51 +0200)
python-flask-babel.spec [new file with mode: 0644]

diff --git a/python-flask-babel.spec b/python-flask-babel.spec
new file mode 100644 (file)
index 0000000..0b2e9b6
--- /dev/null
@@ -0,0 +1,133 @@
+#
+# Conditional build:
+%bcond_with    doc             # don't build doc
+%bcond_with    tests   # do not perform "make test"
+%bcond_without python2 # CPython 2.x module
+%bcond_without python3 # CPython 3.x module
+
+%define        module  flask-babel
+Summary:       Extension to Flask that adds i18n and l10n support to any Flask application with the help of babel, pytz and speaklater
+Summary(pl.UTF-8):     Rozszerzenie Flask dodające wsparcie dla i18n i l10n przy użyciu babel, pytz i speklater.
+# Name must match the python module/package name (as in 'import' statement)
+Name:          python-%{module}
+Version:       0.9
+Release:       1
+License:       BSD
+Group:         Libraries/Python
+# https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-0.9.tar.gz
+Source0:       https://pypi.python.org/packages/source/F/Flask-Babel/Flask-Babel-%{version}.tar.gz
+# Source0-md5: 4762e0392303f464d53cbebedfb87ded
+URL:           http://github.com/mitsuhiko/flask-babel
+BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.219
+%if %{with python2}
+BuildRequires: python-distribute
+BuildRequires: python-speaklater
+%endif
+%if %{with python3}
+BuildRequires: python3-distribute
+BuildRequires: python3-modules
+BuildRequires: python3-speaklater
+%endif
+Requires:      python-jinja2 >= 2.5
+Requires:      python-modules
+Requires:      python-speaklater
+BuildArch:     noarch
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+Adds i18n/l10n support to Flask applications with the help of the
+Babel library.
+
+# %description -l pl.UTF-8
+
+%package -n python3-%{module}
+Summary:       -
+Summary(pl.UTF-8):     -
+Group:         Libraries/Python
+Requires:      python3-jinja2 >= 2.5
+Requires:      python3-modules
+Requires:      python3-speaklater
+
+%description -n python3-%{module}
+Adds i18n/l10n support to Flask applications with the help of the
+Babel library.
+
+# %description -n python3-%{module} -l pl.UTF-8
+
+%package apidocs
+Summary:       %{module} API documentation
+Summary(pl.UTF-8):     Dokumentacja API %{module}
+Group:         Documentation
+
+%description apidocs
+API documentation for %{module}.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API %{module}.
+
+%prep
+%setup -q -n Flask-Babel-%{version}
+
+%build
+%if %{with python2}
+%{__python} setup.py build --build-base build-2 %{?with_tests:test}
+%endif
+
+%if %{with python3}
+%{__python3} setup.py build --build-base build-3 %{?with_tests:test}
+%endif
+
+%if %{with doc}
+cd docs
+%{__make} -j1 html
+rm -rf _build/html/_sources
+%endif
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%{__python} setup.py \
+       build --build-base build-2 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+
+%py_postclean
+%endif
+
+%if %{with python3}
+%{__python3} setup.py \
+       build --build-base build-3 \
+       install --skip-build \
+       --optimize=2 \
+       --root=$RPM_BUILD_ROOT
+%endif
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%if %{with python2}
+%files
+%defattr(644,root,root,755)
+%doc LICENSE README
+%{py_sitescriptdir}/flask_babel
+%if "%{py_ver}" > "2.4"
+%{py_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
+%endif
+%endif
+
+%if %{with python3}
+%files -n python3-%{module}
+%defattr(644,root,root,755)
+%doc LICENSE README
+%{py3_sitescriptdir}/flask_babel
+%{py3_sitescriptdir}/Flask_Babel-%{version}-py*.egg-info
+%endif
+
+%if %{with doc}
+%files apidocs
+%defattr(644,root,root,755)
+%doc docs/_build/html/*
+%endif
This page took 0.067412 seconds and 4 git commands to generate.