]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blob - python-egenix-mx-base.spec
- use standard python macros
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
1
2 %include /usr/lib/rpm/macros.python
3 %define module egenix-mx-base
4 %define mxdir %{py_sitedir}/mx
5
6 Summary:        eGenix mx-Extensions for Python
7 Summary(pl):    eGenix mx-Extensions dla jêzyka Python
8 Name:           python-%{module}
9 Version:        2.0.1
10 Release:        3
11 License:        distributable
12 Group:          Development/Languages/Python
13 Group(de):      Entwicklung/Sprachen/Python
14 Group(pl):      Programowanie/Jêzyki/Python
15 Source0:        http://www.lemburg.com/python/%{module}-%{version}.tar.gz
16 URL:            http://www.lemburg.com/python/eGenix-mx-Extensions.html
17 BuildRequires:  python-devel >= 2.1
18 %requires_eq    python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The eGenix mx Extension Series are a collection of Python extensions
23 written in ANSI C and Python which provide a large spectrum of useful
24 additions to everyday Python programming.
25
26 This package includes the Open Source subpackages of the series and is
27 needed by all other add-on packages of the series.
28
29 %description -l pl
30 eGenix mx Extensions Series jest zestawem modu³ów, u³atwiaj±cych ¿ycie
31 ka¿demu programi¶cie pisz±cemu w jêzyku Python, napisanych w ANSI C i
32 Pythonie.
33
34 Ten pakiet zawiera podstawowe modu³y wymagane przez inne pakiety.
35
36 %package -n python-mx-DateTime
37 Summary:        Date and time Python extension
38 Summary(pl):    Obiekty daty i czasu dla jêzyka Python
39 Group:          Development/Languages/Python
40 Group(de):      Entwicklung/Sprachen/Python
41 Group(pl):      Programowanie/Jêzyki/Python
42 %requires_eq    python
43 Requires:       python-%{module} = %{version}
44
45 %description -n python-mx-DateTime
46 mxDateTime is an extension package that provides three new object
47 types - DateTime, DateTimeDelta and RelativeDateTime, which let you
48 store and handle date/time values in a much more natural way than by
49 using ticks (seconds since 01.01.1970 0:00 UTC; the encoding used by
50 the time module).
51
52 You can add, subtract and even multiply instances, pickle and copy
53 them and convert the results to strings, COM dates, ticks and some
54 other more esoteric values. In addition, there are several convenient
55 constructors and formatters at hand to greatly simplify dealing with
56 dates and times in real-world applications.
57
58 In addition to providing an easy-to-use Python interface the package
59 also exports a comfortable C API interface for other extensions to
60 build upon. This is especially interesting for database applications
61 which often have to deal with date/time values (the mxODBC package is
62 one example of an extension using this interface).
63
64 %description -l pl -n python-mx-DateTime
65 mxDateTime jest pakietem modu³ów, które definiuj± trzy nowe klasy -
66 DateTime, DateTimeDelta oraz RelativeDateTime. Umo¿liwiaj± one
67 przechowywanie oraz operowanie na dacie i czasie w bardziej naturalny
68 sposób ni¿ za pomoc± sekund od pocz±tku 1 stycznia 1970 (tak jak w
69 module time).
70
71 Programista mo¿e dodawaæ, odejmowaæ, mno¿yæ (w sensie arytmetycznym),
72 serializowaæ, a tak¿e mno¿yæ (w sesnie rozmna¿ania :-) obiekty.
73 Instancje w/w klas mog± byæ konwertowane do napisów i sekund.
74 Dodatkowo modu³ zawiera kilka u¿ytecznych funkcji do tworzenia nowych
75 obiektów i ich formatowania.
76
77 Oprócz, ³atwych w u¿yciu, klas jêzyka Python, pakiet dostarcza tak¿e
78 bardzo wygodny interfejs w C, który mo¿e byæ wykorzystany do tworzenia
79 innych rozszerzeñ (np.: pakiet mxODBC). W szczególno¶ci, cecha ta jest
80 interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
81 dacie i czasie.
82
83 %package -n python-mx-TextTools
84 Summary:        Efficient text manipulation extensions for Python
85 Summary(pl):    Wydajne manipulowanie tekstem w jêzyku Python
86 Group:          Development/Languages/Python
87 Group(de):      Entwicklung/Sprachen/Python
88 Group(pl):      Programowanie/Jêzyki/Python
89 %requires_eq    python
90 Requires:       python-%{module} = %{version}
91
92 %description -n python-mx-TextTools
93 mxTextTools is an extension package for Python that provides several
94 useful functions and types that implement high-performance text
95 manipulation and searching algorithms in addition to a very flexible
96 and extendable state machine, the Tagging Engine, that allows scanning
97 and processing text based on low-level byte-code "programs" written
98 using Python tuples. It gives you access to the speed of C without the
99 need to do any compile and link steps every time you change the
100 parsing description.
101
102 Applications include parsing structured text, finding and extracting
103 text (either exact or using translation tables) and recombining
104 strings to form new text.
105
106 %description -l pl -n python-mx-TextTools
107 Pakiet mxTextTools dostarcza szereg u¿ytecznych typów i funkcji, które
108 implementuj± wysokiej jako¶ci algorytmy do wyszukiwania i manipulacji
109 tekstu. Programista dostaje wydajne (na poziomie kodu napisanego w
110 jêzyku C) narzêdzie bez potrzeby kompilacji i konsolidacji, kiedy
111 zajdzie potrzeba zmiany sposobu interpretacji tekstu.
112
113 Pakiet mo¿e mieæ zastosowanie w aplikacjach, które musz± interpretowaæ
114 tekst zadany w konkretnym formacie, a tak¿e wyszukiwaæ, pobieraæ i
115 manipulowaæ tekstem.
116
117 %package -n python-mx-Stack
118 Summary:        Stack implementation for Python
119 Summary(pl):    Implementacja stosu dla jêzyka Python
120 Group:          Development/Languages/Python
121 Group(de):      Entwicklung/Sprachen/Python
122 Group(pl):      Programowanie/Jêzyki/Python
123 %requires_eq    python
124 Requires:       python-%{module} = %{version}
125
126 %description -n python-mx-Stack
127 mxStack is an extension package that provides a new object type called
128 Stack. It works much like what you would expect from such a type,
129 having .push() and .pop() methods and focusses on obtaining maximum
130 speed at low memory costs.
131
132 %description -l pl -n python-mx-Stack
133 Pakiet mxStack zawiera implementacjê stosu, która zawiera typowe
134 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
135 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
136
137 %package -n python-mx-Queue
138 Summary:        Queue implementation for Python
139 Summary(pl):    Implementacja kolejki dla jêzyka Python
140 Group:          Development/Languages/Python
141 Group(de):      Entwicklung/Sprachen/Python
142 Group(pl):      Programowanie/Jêzyki/Python
143 %requires_eq    python
144 Requires:       python-%{module} = %{version}
145
146 %description -n python-mx-Queue
147 mxQueue is an extension package that provides a new object type called
148 Queue. It works much like what you would expect from such a type,
149 having .push() and .pop() methods and focusses on obtaining maximum
150 speed at low memory costs.
151
152 %description -l pl -n python-mx-Queue
153 Pakiet mxQueue zawiera implementacjê kolejki, która zawiera typowe
154 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
155 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
156
157 %package -n python-mx-Tools
158 Summary:        Some handy functions and objects which provides new builtins for Python
159 Summary(pl):    Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
160 Group:          Development/Languages/Python
161 Group(de):      Entwicklung/Sprachen/Python
162 Group(pl):      Programowanie/Jêzyki/Python
163 %requires_eq    python
164 Requires:       python-%{module} = %{version}
165
166 %description -n python-mx-Tools
167 mxTools is an extension package that includes a collection of handy
168 functions and objects giving additional functionality in form of new
169 builtins to the Python programmer.
170
171 The package auto-installs the new functions and objects as builtins
172 upon first import. This means that they become instantely available to
173 all other modules without any further action on your part. Add the
174 line import mx.Tools.NewBuiltins to your site.py script and they will
175 be available to all users at your site as if they were installed in
176 the Python interpreter itself.
177
178 %description -l pl -n python-mx-Tools
179 Pakiet mxTools zawiera kilka u¿ytecznych klas i funkcji, które daj±
180 wiêcej mo¿liwo¶ci programi¶cie, w postaci wewnêtrznych mechanizmów
181 jêzyka Python.
182
183 Pakiet ten instaluje, jako mechanizmy wewnêtrzne Pythona, wszystkie
184 funkcje i klasy po ich pierwszym do³±czeniu do kodu. Oznacza to, ¿e s±
185 one dostêpne dla innych modu³ów bez jakichkolwiek dodatkowych
186 zabiegów. Wystarczy dodaæ liniê "import mx.Tools.NewBuiltins" do
187 odpowiedniego skryptu (site.py) i zdefiniowane funkcje oraz klasy bêd±
188 widoczne dla wszystkich u¿ytkowników tak, jak by by³y wbudowane w
189 jêzyk Python.
190
191 %package -n python-mx-Proxy
192 Summary:        Support for Bastion like implementations for Python
193 Summary(pl):    Wsparcie dla implementacji typu Bastion dla jêzyka Python
194 Group:          Development/Languages/Python
195 Group(de):      Entwicklung/Sprachen/Python
196 Group(pl):      Programowanie/Jêzyki/Python
197 %requires_eq    python
198 Requires:       python-%{module} = %{version}
199
200 %description -n python-mx-Proxy
201 mxProxy is an extension package that provides a new type that is
202 suitable to implement Bastion like features without the need to use
203 restricted execution environments.
204
205 The type's main features are secure data encapsulation (the hidden
206 objects are not accessible from Python since they are stored in
207 internal C structures), customizable attribute lookup methods and a
208 cleanup protocol that helps in breaking circular references prior to
209 object deletion.
210
211 The latest version adds a very interesting new feature: weak
212 references which help you work with circular references in a way that
213 doesn't cause memory leakage in a Python system.
214
215 %description -l pl -n python-mx-Proxy
216 Pakiet mxProxy dostarcza nowe klasy, które implementuj± funkcjonalno¶æ
217 typu Bastion bez potrzeby ograniczania ¶rodowiska, w którym jest
218 wykonywana aplikacja.
219
220 Podstawowymi zaletami s±: bezpieczne obudowywanie danych (ukryte
221 obiekty nie s± dostêpne z poziomu Pythona, poniewa¿ s± one
222 przechowywane w wewnêtrznych strukturach jêzyka C), konfigurowalne
223 metody do pobierania warto¶ci atrybutów oraz protokó³, który pomaga w
224 rozbijaniu zapêtlonych referencji podczas usuwania obiektów.
225
226 Ostatnia wersja pakietu implementuje tzw. s³abe referencje, które nie
227 powoduj± wycieków pamiêci w przypadku referencji zapêtlonych.
228
229 %package -n python-mx-BeeBase
230 Summary:        High performance construction kit for disk based indexed databases (B+Tree)
231 Summary(pl):    Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
232 Group:          Development/Languages/Python
233 Group(de):      Entwicklung/Sprachen/Python
234 Group(pl):      Programowanie/Jêzyki/Python
235 %requires_eq    python
236 Requires:       python-%{module} = %{version}
237
238 %description -n python-mx-BeeBase
239 mxBeeBase is a high performance construction kit for disk based
240 indexed databases. It offers components which you can plug together to
241 easily build your own custom mid-sized databases (the current size
242 limit is sizeof(long) which gives you an address range of around 2GB
243 on 32-bit platforms).
244
245 The two basic building blocks in mxBeeBase are storage and index.
246 Storage is implemented as variable record length data storage with
247 integrated data protection features, automatic data recovery and
248 locking for multi process access. Indexes use a high performance
249 optimized B+Tree implementation built on top of Thomas Niemann's
250 Cookbook B+Tree implementation.
251
252 %description -l pl -n python-mx-BeeBase
253 mxBeeBase jest wysokiej jako¶ci pakietem do tworzenia indeksowanych
254 baz danych. Zawiera komponenty, które mo¿na razem ³±czyæ w celu
255 zbudowania w³asnej bazy. Obecny limit ilo¶ci danych wynosi 2GB (max.
256 warto¶æ liczby ca³kowitej typu long na platformach 32 bitowych).
257
258 Dwoma podstawowymi komponentami w tym pakiecie s± indeksy oraz
259 rekordy. Rekord mo¿e byæ zmiennej d³ugo¶ci i zawiera mechanizmy
260 ochrony, automatycznego odzyskiwania, blokowania, a tak¿e
261 wieloprocesowego dostêpu do danych. Do indeksowania s± u¿ywane bardzo
262 wydajne B-drzewa zaimplementowane na podstawie Cookbook B+Tree Thomasa
263 Newmanna.
264
265 %prep
266 %setup -q -n %{module}-%{version}
267
268 %build
269 env CFLAGS="%{rpmcflags}" python setup.py build
270
271 %install
272 rm -rf $RPM_BUILD_ROOT
273 python setup.py install --root=$RPM_BUILD_ROOT
274
275 gzip -9nf README mx/LICENSE mx/COPYRIGHT mx/Doc/*.txt
276
277 %clean
278 rm -rf $RPM_BUILD_ROOT
279
280 %files
281 %defattr(644,root,root,755)
282 %doc *.gz mx/*.gz mx/Doc/*.gz mx/Doc/mx{Extensions,License}.html
283 %dir %{mxdir}
284 %{mxdir}/*.py[co]
285
286 %dir %{mxdir}/Misc
287 %{mxdir}/Misc/*.py[co]
288
289 %files -n python-mx-DateTime
290 %defattr(644,root,root,755)
291 %doc mx/DateTime/Doc/*.html
292 %dir %{mxdir}/DateTime
293 %{mxdir}/DateTime/*.py[co]
294
295 %dir %{mxdir}/DateTime/mxDateTime
296 %{mxdir}/DateTime/mxDateTime/*.py[co]
297 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
298
299 %files -n python-mx-TextTools
300 %defattr(644,root,root,755)
301 %doc mx/TextTools/Doc/*.html
302 %dir %{mxdir}/TextTools
303 %{mxdir}/TextTools/*.py[co]
304
305 %dir %{mxdir}/TextTools/mxTextTools
306 %{mxdir}/TextTools/mxTextTools/*.py[co]
307 %attr(755,root,root) %{mxdir}/TextTools/mxTextTools/*.so
308
309 %dir %{mxdir}/TextTools/Constants
310 %{mxdir}/TextTools/Constants/*.py[co]
311
312 %files -n python-mx-Stack
313 %defattr(644,root,root,755)
314 %doc mx/Stack/Doc/*.html
315 %dir %{mxdir}/Stack
316 %{mxdir}/Stack/*.py[co]
317
318 %dir %{mxdir}/Stack/mxStack
319 %{mxdir}/Stack/mxStack/*.py[co]
320 %attr(755,root,root) %{mxdir}/Stack/mxStack/*.so
321
322 %files -n python-mx-Queue
323 %defattr(644,root,root,755)
324 %doc mx/Queue/Doc/*.html
325 %dir %{mxdir}/Queue
326 %{mxdir}/Queue/*.py[co]
327
328 %dir %{mxdir}/Queue/mxQueue
329 %{mxdir}/Queue/mxQueue/*.py[co]
330 %attr(755,root,root) %{mxdir}/Queue/mxQueue/*.so
331
332 %files -n python-mx-Tools
333 %defattr(644,root,root,755)
334 %doc mx/Tools/Doc/*.html
335 %dir %{mxdir}/Tools
336 %{mxdir}/Tools/*.py[co]
337
338 %dir %{mxdir}/Tools/mxTools
339 %{mxdir}/Tools/mxTools/*.py[co]
340 %attr(755,root,root) %{mxdir}/Tools/mxTools/*.so
341
342 %files -n python-mx-Proxy
343 %defattr(644,root,root,755)
344 %doc mx/Proxy/Doc/*.html
345 %dir %{mxdir}/Proxy
346 %{mxdir}/Proxy/*.py[co]
347
348 %dir %{mxdir}/Proxy/mxProxy
349 %{mxdir}/Proxy/mxProxy/*.py[co]
350 %attr(755,root,root) %{mxdir}/Proxy/mxProxy/*.so
351
352 %files -n python-mx-BeeBase
353 %defattr(644,root,root,755)
354 %doc mx/BeeBase/Doc/*.html
355 %dir %{mxdir}/BeeBase
356 %{mxdir}/BeeBase/*.py[co]
357
358 %dir %{mxdir}/BeeBase/mxBeeBase
359 %{mxdir}/BeeBase/mxBeeBase/*.py[co]
360 %attr(755,root,root) %{mxdir}/BeeBase/mxBeeBase/*.so
This page took 0.438438 seconds and 4 git commands to generate.