]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blob - python-egenix-mx-base.spec
- fixed descriptions and summaries of mx-DateTime-devel subpackage
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module egenix-mx-base
4 %define         mxdir %{py_sitedir}/mx
5
6 Summary:        eGenix mx-Extensions for Python
7 Summary(pl):    eGenix mx-Extensions dla jêzyka Python
8 Name:           python-%{module}
9 Version:        2.0.4
10 Release:        1
11 License:        distributable
12 Group:          Libraries/Python
13 Source0:        http://www.lemburg.com/python/%{module}-%{version}.tar.gz
14 URL:            http://www.lemburg.com/python/eGenix-mx-Extensions.html
15 BuildRequires:  python-devel >= 2.2.1
16 BuildRequires:  python-modules >= 2.2.1
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 The eGenix mx Extension Series are a collection of Python extensions
23 written in ANSI C and Python which provide a large spectrum of useful
24 additions to everyday Python programming.
25
26 This package includes the Open Source subpackages of the series and is
27 needed by all other add-on packages of the series.
28
29 %description -l pl
30 eGenix mx Extensions Series jest zestawem modu³ów, u³atwiaj±cych ¿ycie
31 ka¿demu programi¶cie pisz±cemu w jêzyku Python, napisanych w ANSI C i
32 Pythonie.
33
34 Ten pakiet zawiera podstawowe modu³y wymagane przez inne pakiety.
35
36 %package -n python-mx-DateTime
37 Summary:        Date and time Python extension
38 Summary(pl):    Obiekty daty i czasu dla jêzyka Python
39 Group:          Libraries/Python
40 %pyrequires_eq  python
41 Requires:       python-%{module} = %{version}
42
43 %description -n python-mx-DateTime
44 mxDateTime is an extension package that provides three new object
45 types - DateTime, DateTimeDelta and RelativeDateTime, which let you
46 store and handle date/time values in a much more natural way than by
47 using ticks (seconds since 01.01.1970 0:00 UTC; the encoding used by
48 the time module).
49
50 You can add, subtract and even multiply instances, pickle and copy
51 them and convert the results to strings, COM dates, ticks and some
52 other more esoteric values. In addition, there are several convenient
53 constructors and formatters at hand to greatly simplify dealing with
54 dates and times in real-world applications.
55
56 In addition to providing an easy-to-use Python interface the package
57 also exports a comfortable C API interface for other extensions to
58 build upon. This is especially interesting for database applications
59 which often have to deal with date/time values (the mxODBC package is
60 one example of an extension using this interface).
61
62 %description -n python-mx-DateTime -l pl
63 mxDateTime jest pakietem modu³ów, które definiuj± trzy nowe klasy -
64 DateTime, DateTimeDelta oraz RelativeDateTime. Umo¿liwiaj± one
65 przechowywanie oraz operowanie na dacie i czasie w bardziej naturalny
66 sposób ni¿ za pomoc± sekund od pocz±tku 1 stycznia 1970 (tak jak w
67 module time).
68
69 Programista mo¿e dodawaæ, odejmowaæ, mno¿yæ (w sensie arytmetycznym),
70 serializowaæ, a tak¿e mno¿yæ (w sesnie rozmna¿ania :-) obiekty.
71 Instancje w/w klas mog± byæ konwertowane do napisów i sekund.
72 Dodatkowo modu³ zawiera kilka u¿ytecznych funkcji do tworzenia nowych
73 obiektów i ich formatowania.
74
75 Oprócz, ³atwych w u¿yciu, klas jêzyka Python, pakiet dostarcza tak¿e
76 bardzo wygodny interfejs w C, który mo¿e byæ wykorzystany do tworzenia
77 innych rozszerzeñ (np.: pakiet mxODBC). W szczególno¶ci, cecha ta jest
78 interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
79 dacie i czasie.
80
81 %package -n python-mx-DateTime-devel
82 Summary:        Headers for date and time Python extension
83 Summary(pl):    Nag³ówki modu³ów daty i czasu
84 Group:          Libraries/Python
85 Requires:       python-mx-DateTime = %{version}
86
87 %description -n python-mx-DateTime-devel
88 Headers for date and time Python extension.
89
90 %description -n python-mx-DateTime-devel -l pl
91 Nag³ówki dla modu³ów daty i czasu.
92
93 %package -n python-mx-TextTools
94 Summary:        Efficient text manipulation extensions for Python
95 Summary(pl):    Wydajne manipulowanie tekstem w jêzyku Python
96 Group:          Libraries/Python
97 %pyrequires_eq  python
98 Requires:       python-%{module} = %{version}
99
100 %description -n python-mx-TextTools
101 mxTextTools is an extension package for Python that provides several
102 useful functions and types that implement high-performance text
103 manipulation and searching algorithms in addition to a very flexible
104 and extendable state machine, the Tagging Engine, that allows scanning
105 and processing text based on low-level byte-code "programs" written
106 using Python tuples. It gives you access to the speed of C without the
107 need to do any compile and link steps every time you change the
108 parsing description.
109
110 Applications include parsing structured text, finding and extracting
111 text (either exact or using translation tables) and recombining
112 strings to form new text.
113
114 %description -n python-mx-TextTools -l pl
115 Pakiet mxTextTools dostarcza szereg u¿ytecznych typów i funkcji, które
116 implementuj± wysokiej jako¶ci algorytmy do wyszukiwania i manipulacji
117 tekstu. Programista dostaje wydajne (na poziomie kodu napisanego w
118 jêzyku C) narzêdzie bez potrzeby kompilacji i konsolidacji, kiedy
119 zajdzie potrzeba zmiany sposobu interpretacji tekstu.
120
121 Pakiet mo¿e mieæ zastosowanie w aplikacjach, które musz± interpretowaæ
122 tekst zadany w konkretnym formacie, a tak¿e wyszukiwaæ, pobieraæ i
123 manipulowaæ tekstem.
124
125 %package -n python-mx-Stack
126 Summary:        Stack implementation for Python
127 Summary(pl):    Implementacja stosu dla jêzyka Python
128 Group:          Libraries/Python
129 %pyrequires_eq  python
130 Requires:       python-%{module} = %{version}
131
132 %description -n python-mx-Stack
133 mxStack is an extension package that provides a new object type called
134 Stack. It works much like what you would expect from such a type,
135 having .push() and .pop() methods and focusses on obtaining maximum
136 speed at low memory costs.
137
138 %description -n python-mx-Stack -l pl
139 Pakiet mxStack zawiera implementacjê stosu, która zawiera typowe
140 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
141 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
142
143 %package -n python-mx-Queue
144 Summary:        Queue implementation for Python
145 Summary(pl):    Implementacja kolejki dla jêzyka Python
146 Group:          Libraries/Python
147 %pyrequires_eq  python
148 Requires:       python-%{module} = %{version}
149
150 %description -n python-mx-Queue
151 mxQueue is an extension package that provides a new object type called
152 Queue. It works much like what you would expect from such a type,
153 having .push() and .pop() methods and focusses on obtaining maximum
154 speed at low memory costs.
155
156 %description -n python-mx-Queue -l pl
157 Pakiet mxQueue zawiera implementacjê kolejki, która zawiera typowe
158 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
159 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
160
161 %package -n python-mx-Tools
162 Summary:        Some handy functions and objects which provides new builtins for Python
163 Summary(pl):    Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
164 Group:          Libraries/Python
165 %pyrequires_eq  python
166 Requires:       python-%{module} = %{version}
167
168 %description -n python-mx-Tools
169 mxTools is an extension package that includes a collection of handy
170 functions and objects giving additional functionality in form of new
171 builtins to the Python programmer.
172
173 The package auto-installs the new functions and objects as builtins
174 upon first import. This means that they become instantely available to
175 all other modules without any further action on your part. Add the
176 line import mx.Tools.NewBuiltins to your site.py script and they will
177 be available to all users at your site as if they were installed in
178 the Python interpreter itself.
179
180 %description -n python-mx-Tools -l pl
181 Pakiet mxTools zawiera kilka u¿ytecznych klas i funkcji, które daj±
182 wiêcej mo¿liwo¶ci programi¶cie, w postaci wewnêtrznych mechanizmów
183 jêzyka Python.
184
185 Pakiet ten instaluje, jako mechanizmy wewnêtrzne Pythona, wszystkie
186 funkcje i klasy po ich pierwszym do³±czeniu do kodu. Oznacza to, ¿e s±
187 one dostêpne dla innych modu³ów bez jakichkolwiek dodatkowych
188 zabiegów. Wystarczy dodaæ liniê "import mx.Tools.NewBuiltins" do
189 odpowiedniego skryptu (site.py) i zdefiniowane funkcje oraz klasy bêd±
190 widoczne dla wszystkich u¿ytkowników tak, jak by by³y wbudowane w
191 jêzyk Python.
192
193 %package -n python-mx-Proxy
194 Summary:        Support for Bastion like implementations for Python
195 Summary(pl):    Wsparcie dla implementacji typu Bastion dla jêzyka Python
196 Group:          Libraries/Python
197 %pyrequires_eq  python
198 Requires:       python-%{module} = %{version}
199
200 %description -n python-mx-Proxy
201 mxProxy is an extension package that provides a new type that is
202 suitable to implement Bastion like features without the need to use
203 restricted execution environments.
204
205 The type's main features are secure data encapsulation (the hidden
206 objects are not accessible from Python since they are stored in
207 internal C structures), customizable attribute lookup methods and a
208 cleanup protocol that helps in breaking circular references prior to
209 object deletion.
210
211 The latest version adds a very interesting new feature: weak
212 references which help you work with circular references in a way that
213 doesn't cause memory leakage in a Python system.
214
215 %description -n python-mx-Proxy -l pl
216 Pakiet mxProxy dostarcza nowe klasy, które implementuj± funkcjonalno¶æ
217 typu Bastion bez potrzeby ograniczania ¶rodowiska, w którym jest
218 wykonywana aplikacja.
219
220 Podstawowymi zaletami s±: bezpieczne obudowywanie danych (ukryte
221 obiekty nie s± dostêpne z poziomu Pythona, poniewa¿ s± one
222 przechowywane w wewnêtrznych strukturach jêzyka C), konfigurowalne
223 metody do pobierania warto¶ci atrybutów oraz protokó³, który pomaga w
224 rozbijaniu zapêtlonych referencji podczas usuwania obiektów.
225
226 Ostatnia wersja pakietu implementuje tzw. s³abe referencje, które nie
227 powoduj± wycieków pamiêci w przypadku referencji zapêtlonych.
228
229 %package -n python-mx-BeeBase
230 Summary:        High performance construction kit for disk based indexed databases (B+Tree)
231 Summary(pl):    Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
232 Group:          Libraries/Python
233 %pyrequires_eq  python
234 Requires:       python-%{module} = %{version}
235
236 %description -n python-mx-BeeBase
237 mxBeeBase is a high performance construction kit for disk based
238 indexed databases. It offers components which you can plug together to
239 easily build your own custom mid-sized databases (the current size
240 limit is sizeof(long) which gives you an address range of around 2GB
241 on 32-bit platforms).
242
243 The two basic building blocks in mxBeeBase are storage and index.
244 Storage is implemented as variable record length data storage with
245 integrated data protection features, automatic data recovery and
246 locking for multi process access. Indexes use a high performance
247 optimized B+Tree implementation built on top of Thomas Niemann's
248 Cookbook B+Tree implementation.
249
250 %description -n python-mx-BeeBase -l pl
251 mxBeeBase jest wysokiej jako¶ci pakietem do tworzenia indeksowanych
252 baz danych. Zawiera komponenty, które mo¿na razem ³±czyæ w celu
253 zbudowania w³asnej bazy. Obecny limit ilo¶ci danych wynosi 2GB (max.
254 warto¶æ liczby ca³kowitej typu long na platformach 32 bitowych).
255
256 Dwoma podstawowymi komponentami w tym pakiecie s± indeksy oraz
257 rekordy. Rekord mo¿e byæ zmiennej d³ugo¶ci i zawiera mechanizmy
258 ochrony, automatycznego odzyskiwania, blokowania, a tak¿e
259 wieloprocesowego dostêpu do danych. Do indeksowania s± u¿ywane bardzo
260 wydajne B-drzewa zaimplementowane na podstawie Cookbook B+Tree Thomasa
261 Newmanna.
262
263 %prep
264 %setup -q -n %{module}-%{version}
265
266 %build
267 env CFLAGS="%{rpmcflags}" python setup.py build
268
269 %install
270 rm -rf $RPM_BUILD_ROOT
271 python setup.py install --root=$RPM_BUILD_ROOT
272
273 %clean
274 rm -rf $RPM_BUILD_ROOT
275
276 %files
277 %defattr(644,root,root,755)
278 %doc README mx/LICENSE mx/COPYRIGHT mx/Doc/mxLicense.html
279 %dir %{mxdir}
280 %{mxdir}/*.py[co]
281
282 %dir %{mxdir}/Misc
283 %{mxdir}/Misc/*.py[co]
284
285 %files -n python-mx-DateTime
286 %defattr(644,root,root,755)
287 %doc mx/DateTime/Doc/*.html
288 %dir %{mxdir}/DateTime
289 %{mxdir}/DateTime/*.py[co]
290
291 %dir %{mxdir}/DateTime/mxDateTime
292 %{mxdir}/DateTime/mxDateTime/*.py[co]
293 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
294
295 %files -n python-mx-DateTime-devel
296 %defattr(644,root,root,755)
297 %dir %{mxdir}/DateTime/mxDateTime
298 %{mxdir}/DateTime/mxDateTime/*.h
299
300 %files -n python-mx-TextTools
301 %defattr(644,root,root,755)
302 %doc mx/TextTools/Doc/*.html
303 %dir %{mxdir}/TextTools
304 %{mxdir}/TextTools/*.py[co]
305
306 %dir %{mxdir}/TextTools/mxTextTools
307 %{mxdir}/TextTools/mxTextTools/*.py[co]
308 %attr(755,root,root) %{mxdir}/TextTools/mxTextTools/*.so
309
310 %dir %{mxdir}/TextTools/Constants
311 %{mxdir}/TextTools/Constants/*.py[co]
312
313 %files -n python-mx-Stack
314 %defattr(644,root,root,755)
315 %doc mx/Stack/Doc/*.html
316 %dir %{mxdir}/Stack
317 %{mxdir}/Stack/*.py[co]
318
319 %dir %{mxdir}/Stack/mxStack
320 %{mxdir}/Stack/mxStack/*.py[co]
321 %attr(755,root,root) %{mxdir}/Stack/mxStack/*.so
322
323 %files -n python-mx-Queue
324 %defattr(644,root,root,755)
325 %doc mx/Queue/Doc/*.html
326 %dir %{mxdir}/Queue
327 %{mxdir}/Queue/*.py[co]
328
329 %dir %{mxdir}/Queue/mxQueue
330 %{mxdir}/Queue/mxQueue/*.py[co]
331 %attr(755,root,root) %{mxdir}/Queue/mxQueue/*.so
332
333 %files -n python-mx-Tools
334 %defattr(644,root,root,755)
335 %doc mx/Tools/Doc/*.html
336 %dir %{mxdir}/Tools
337 %{mxdir}/Tools/*.py[co]
338
339 %dir %{mxdir}/Tools/mxTools
340 %{mxdir}/Tools/mxTools/*.py[co]
341 %attr(755,root,root) %{mxdir}/Tools/mxTools/*.so
342
343 %files -n python-mx-Proxy
344 %defattr(644,root,root,755)
345 %doc mx/Proxy/Doc/*.html
346 %dir %{mxdir}/Proxy
347 %{mxdir}/Proxy/*.py[co]
348
349 %dir %{mxdir}/Proxy/mxProxy
350 %{mxdir}/Proxy/mxProxy/*.py[co]
351 %attr(755,root,root) %{mxdir}/Proxy/mxProxy/*.so
352
353 %files -n python-mx-BeeBase
354 %defattr(644,root,root,755)
355 %doc mx/BeeBase/Doc/*.html
356 %dir %{mxdir}/BeeBase
357 %{mxdir}/BeeBase/*.py[co]
358
359 %dir %{mxdir}/BeeBase/mxBeeBase
360 %{mxdir}/BeeBase/mxBeeBase/*.py[co]
361 %attr(755,root,root) %{mxdir}/BeeBase/mxBeeBase/*.so
This page took 0.315116 seconds and 4 git commands to generate.