]> git.pld-linux.org Git - packages/python-egenix-mx-base.git/blob - python-egenix-mx-base.spec
- updated URL, noted download URL (v 2.0.6 there)
[packages/python-egenix-mx-base.git] / python-egenix-mx-base.spec
1 # TODO make examples package
2
3 %define         module  egenix-mx-base
4 %define         mxdir   %{py_sitedir}/mx
5
6 Summary:        eGenix mx-Extensions for Python
7 Summary(pl):    eGenix mx-Extensions dla jêzyka Python
8 Name:           python-%{module}
9 Version:        2.0.5
10 Release:        9
11 License:        distributable
12 Group:          Libraries/Python
13 #Source0Download: http://www.egenix.com/files/python/eGenix-mx-Extensions.html
14 Source0:        http://www.egenix.com/files/python/%{module}-%{version}.tar.gz
15 # Source0-md5:  a793a8fd2d5f646a2fb683d2d967a16b
16 URL:            http://www.egenix.com/files/python/eGenix-mx-Extensions.html
17 BuildRequires:  python
18 BuildRequires:  python-devel >= 2.2.2
19 BuildRequires:  python-modules >= 2.2.2
20 %pyrequires_eq  python
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The eGenix mx Extension Series are a collection of Python extensions
25 written in ANSI C and Python which provide a large spectrum of useful
26 additions to everyday Python programming.
27
28 This package includes the Open Source subpackages of the series and is
29 needed by all other add-on packages of the series.
30
31 %description -l pl
32 eGenix mx Extensions Series jest zestawem modu³ów, u³atwiaj±cych ¿ycie
33 ka¿demu programi¶cie pisz±cemu w jêzyku Python, napisanych w ANSI C i
34 Pythonie.
35
36 Ten pakiet zawiera podstawowe modu³y wymagane przez inne pakiety.
37
38 %package devel
39 Summary:        Basic header files for eGenix extensions
40 Summary(pl):    Podstawowe pliki nag³ówkowe dla rozszerzeñ eGenix
41 Group:          Development/Languages/Python
42
43 %description devel
44 Basic header files for eGenix extensions.
45
46 %description devel -l pl
47 Podstawowe pliki nag³ówkowe dla rozszerzeñ eGenix.
48
49 %package -n python-mx-DateTime
50 Summary:        Date and time Python extension
51 Summary(pl):    Obiekty daty i czasu dla jêzyka Python
52 Group:          Libraries/Python
53 %pyrequires_eq  python
54 Requires:       python-%{module} = %{version}-%{release}
55
56 %description -n python-mx-DateTime
57 mxDateTime is an extension package that provides three new object
58 types - DateTime, DateTimeDelta and RelativeDateTime, which let you
59 store and handle date/time values in a much more natural way than by
60 using ticks (seconds since 01.01.1970 0:00 UTC; the encoding used by
61 the time module).
62
63 You can add, subtract and even multiply instances, pickle and copy
64 them and convert the results to strings, COM dates, ticks and some
65 other more esoteric values. In addition, there are several convenient
66 constructors and formatters at hand to greatly simplify dealing with
67 dates and times in real-world applications.
68
69 In addition to providing an easy-to-use Python interface the package
70 also exports a comfortable C API interface for other extensions to
71 build upon. This is especially interesting for database applications
72 which often have to deal with date/time values (the mxODBC package is
73 one example of an extension using this interface).
74
75 %description -n python-mx-DateTime -l pl
76 mxDateTime jest pakietem modu³ów, które definiuj± trzy nowe klasy -
77 DateTime, DateTimeDelta oraz RelativeDateTime. Umo¿liwiaj± one
78 przechowywanie oraz operowanie na dacie i czasie w bardziej naturalny
79 sposób ni¿ za pomoc± sekund od pocz±tku 1 stycznia 1970 (tak jak w
80 module time).
81
82 Programista mo¿e dodawaæ, odejmowaæ, mno¿yæ (w sensie arytmetycznym),
83 serializowaæ, a tak¿e mno¿yæ (w sesnie rozmna¿ania :-) obiekty.
84 Instancje w/w klas mog± byæ konwertowane do napisów i sekund.
85 Dodatkowo modu³ zawiera kilka u¿ytecznych funkcji do tworzenia nowych
86 obiektów i ich formatowania.
87
88 Oprócz, ³atwych w u¿yciu, klas jêzyka Python, pakiet dostarcza tak¿e
89 bardzo wygodny interfejs w C, który mo¿e byæ wykorzystany do tworzenia
90 innych rozszerzeñ (np.: pakiet mxODBC). W szczególno¶ci, cecha ta jest
91 interesuj±ca w przypadku aplikacji bazodanowych, które operuj± na
92 dacie i czasie.
93
94 %package -n python-mx-DateTime-devel
95 Summary:        Headers for date and time Python extension
96 Summary(pl):    Nag³ówki modu³ów daty i czasu
97 Group:          Development/Languages/Python
98 Requires:       %{name}-devel = %{version}-%{release}
99
100 %description -n python-mx-DateTime-devel
101 Headers for date and time Python extension.
102
103 %description -n python-mx-DateTime-devel -l pl
104 Nag³ówki dla modu³ów daty i czasu.
105
106 %package -n python-mx-TextTools
107 Summary:        Efficient text manipulation extensions for Python
108 Summary(pl):    Wydajne manipulowanie tekstem w jêzyku Python
109 Group:          Libraries/Python
110 %pyrequires_eq  python
111 Requires:       python-%{module} = %{version}-%{release}
112
113 %description -n python-mx-TextTools
114 mxTextTools is an extension package for Python that provides several
115 useful functions and types that implement high-performance text
116 manipulation and searching algorithms in addition to a very flexible
117 and extendable state machine, the Tagging Engine, that allows scanning
118 and processing text based on low-level byte-code "programs" written
119 using Python tuples. It gives you access to the speed of C without the
120 need to do any compile and link steps every time you change the
121 parsing description.
122
123 Applications include parsing structured text, finding and extracting
124 text (either exact or using translation tables) and recombining
125 strings to form new text.
126
127 %description -n python-mx-TextTools -l pl
128 Pakiet mxTextTools dostarcza szereg u¿ytecznych typów i funkcji, które
129 implementuj± wysokiej jako¶ci algorytmy do wyszukiwania i manipulacji
130 tekstu. Programista dostaje wydajne (na poziomie kodu napisanego w
131 jêzyku C) narzêdzie bez potrzeby kompilacji i konsolidacji, kiedy
132 zajdzie potrzeba zmiany sposobu interpretacji tekstu.
133
134 Pakiet mo¿e mieæ zastosowanie w aplikacjach, które musz± interpretowaæ
135 tekst zadany w konkretnym formacie, a tak¿e wyszukiwaæ, pobieraæ i
136 manipulowaæ tekstem.
137
138 %package -n python-mx-Stack
139 Summary:        Stack implementation for Python
140 Summary(pl):    Implementacja stosu dla jêzyka Python
141 Group:          Libraries/Python
142 %pyrequires_eq  python
143 Requires:       python-%{module} = %{version}-%{release}
144
145 %description -n python-mx-Stack
146 mxStack is an extension package that provides a new object type called
147 Stack. It works much like what you would expect from such a type,
148 having .push() and .pop() methods and focusses on obtaining maximum
149 speed at low memory costs.
150
151 %description -n python-mx-Stack -l pl
152 Pakiet mxStack zawiera implementacjê stosu, która zawiera typowe
153 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
154 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
155
156 %package -n python-mx-Queue
157 Summary:        Queue implementation for Python
158 Summary(pl):    Implementacja kolejki dla jêzyka Python
159 Group:          Libraries/Python
160 %pyrequires_eq  python
161 Requires:       python-%{module} = %{version}-%{release}
162
163 %description -n python-mx-Queue
164 mxQueue is an extension package that provides a new object type called
165 Queue. It works much like what you would expect from such a type,
166 having .push() and .pop() methods and focusses on obtaining maximum
167 speed at low memory costs.
168
169 %description -n python-mx-Queue -l pl
170 Pakiet mxQueue zawiera implementacjê kolejki, która zawiera typowe
171 metody takie jak pop() czy push(). Mechanizm zosta³ napisany tak by,
172 przy minimalnym zu¿yciu pamiêci, by³ bardzo wydajny.
173
174 %package -n python-mx-Tools
175 Summary:        Some handy functions and objects which provides new builtins for Python
176 Summary(pl):    Kilka u¿ytecznych klas i funkcji w postaci wew. mechanizmów Pythona
177 Group:          Libraries/Python
178 %pyrequires_eq  python
179 Requires:       python-%{module} = %{version}-%{release}
180
181 %description -n python-mx-Tools
182 mxTools is an extension package that includes a collection of handy
183 functions and objects giving additional functionality in form of new
184 builtins to the Python programmer.
185
186 The package auto-installs the new functions and objects as builtins
187 upon first import. This means that they become instantely available to
188 all other modules without any further action on your part. Add the
189 line import mx.Tools.NewBuiltins to your site.py script and they will
190 be available to all users at your site as if they were installed in
191 the Python interpreter itself.
192
193 %description -n python-mx-Tools -l pl
194 Pakiet mxTools zawiera kilka u¿ytecznych klas i funkcji, które daj±
195 wiêcej mo¿liwo¶ci programi¶cie, w postaci wewnêtrznych mechanizmów
196 jêzyka Python.
197
198 Pakiet ten instaluje, jako mechanizmy wewnêtrzne Pythona, wszystkie
199 funkcje i klasy po ich pierwszym do³±czeniu do kodu. Oznacza to, ¿e s±
200 one dostêpne dla innych modu³ów bez jakichkolwiek dodatkowych
201 zabiegów. Wystarczy dodaæ liniê "import mx.Tools.NewBuiltins" do
202 odpowiedniego skryptu (site.py) i zdefiniowane funkcje oraz klasy bêd±
203 widoczne dla wszystkich u¿ytkowników tak, jak by by³y wbudowane w
204 jêzyk Python.
205
206 %package -n python-mx-Proxy
207 Summary:        Support for Bastion like implementations for Python
208 Summary(pl):    Wsparcie dla implementacji typu Bastion dla jêzyka Python
209 Group:          Libraries/Python
210 %pyrequires_eq  python
211 Requires:       python-%{module} = %{version}-%{release}
212
213 %description -n python-mx-Proxy
214 mxProxy is an extension package that provides a new type that is
215 suitable to implement Bastion like features without the need to use
216 restricted execution environments.
217
218 The type's main features are secure data encapsulation (the hidden
219 objects are not accessible from Python since they are stored in
220 internal C structures), customizable attribute lookup methods and a
221 cleanup protocol that helps in breaking circular references prior to
222 object deletion.
223
224 The latest version adds a very interesting new feature: weak
225 references which help you work with circular references in a way that
226 doesn't cause memory leakage in a Python system.
227
228 %description -n python-mx-Proxy -l pl
229 Pakiet mxProxy dostarcza nowe klasy, które implementuj± funkcjonalno¶æ
230 typu Bastion bez potrzeby ograniczania ¶rodowiska, w którym jest
231 wykonywana aplikacja.
232
233 Podstawowymi zaletami s±: bezpieczne obudowywanie danych (ukryte
234 obiekty nie s± dostêpne z poziomu Pythona, poniewa¿ s± one
235 przechowywane w wewnêtrznych strukturach jêzyka C), konfigurowalne
236 metody do pobierania warto¶ci atrybutów oraz protokó³, który pomaga w
237 rozbijaniu zapêtlonych referencji podczas usuwania obiektów.
238
239 Ostatnia wersja pakietu implementuje tzw. s³abe referencje, które nie
240 powoduj± wycieków pamiêci w przypadku referencji zapêtlonych.
241
242 %package -n python-mx-BeeBase
243 Summary:        High performance construction kit for disk based indexed databases (B+Tree)
244 Summary(pl):    Wysokiej jako¶ci pakiet do tworzenia indeksowanych baz danych (B+Tree)
245 Group:          Libraries/Python
246 %pyrequires_eq  python
247 Requires:       python-%{module} = %{version}-%{release}
248
249 %description -n python-mx-BeeBase
250 mxBeeBase is a high performance construction kit for disk based
251 indexed databases. It offers components which you can plug together to
252 easily build your own custom mid-sized databases (the current size
253 limit is sizeof(long) which gives you an address range of around 2GB
254 on 32-bit platforms).
255
256 The two basic building blocks in mxBeeBase are storage and index.
257 Storage is implemented as variable record length data storage with
258 integrated data protection features, automatic data recovery and
259 locking for multi process access. Indexes use a high performance
260 optimized B+Tree implementation built on top of Thomas Niemann's
261 Cookbook B+Tree implementation.
262
263 %description -n python-mx-BeeBase -l pl
264 mxBeeBase jest wysokiej jako¶ci pakietem do tworzenia indeksowanych
265 baz danych. Zawiera komponenty, które mo¿na razem ³±czyæ w celu
266 zbudowania w³asnej bazy. Obecny limit ilo¶ci danych wynosi 2GB (max.
267 warto¶æ liczby ca³kowitej typu long na platformach 32 bitowych).
268
269 Dwoma podstawowymi komponentami w tym pakiecie s± indeksy oraz
270 rekordy. Rekord mo¿e byæ zmiennej d³ugo¶ci i zawiera mechanizmy
271 ochrony, automatycznego odzyskiwania, blokowania, a tak¿e
272 wieloprocesowego dostêpu do danych. Do indeksowania s± u¿ywane bardzo
273 wydajne B-drzewa zaimplementowane na podstawie Cookbook B+Tree Thomasa
274 Newmanna.
275
276 %prep
277 %setup -q -n %{module}-%{version}
278
279 %build
280 env CFLAGS="%{rpmcflags}" python setup.py build
281
282 %install
283 rm -rf $RPM_BUILD_ROOT
284 install -d $RPM_BUILD_ROOT%{py_incdir}/mx
285 python setup.py install \
286         --root=$RPM_BUILD_ROOT \
287         --install-purelib=%{py_sitedir}
288
289 find $RPM_BUILD_ROOT%{py_sitedir} -name \*.h \
290         -exec mv {} $RPM_BUILD_ROOT%{py_incdir}/mx \;
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %files
296 %defattr(644,root,root,755)
297 %doc README mx/LICENSE mx/COPYRIGHT mx/Doc/mxLicense.html
298 %dir %{mxdir}
299 %dir %{py_incdir}/mx
300 %{mxdir}/*.py[co]
301
302 %dir %{mxdir}/Misc
303 %{mxdir}/Misc/*.py[co]
304
305 %files devel
306 %defattr(644,root,root,755)
307 %{py_incdir}/mx/mxh.h
308
309 %files -n python-mx-DateTime
310 %defattr(644,root,root,755)
311 %doc mx/DateTime/Doc/*.html
312 %dir %{mxdir}/DateTime
313 %{mxdir}/DateTime/*.py[co]
314
315 %dir %{mxdir}/DateTime/mxDateTime
316 %{mxdir}/DateTime/mxDateTime/*.py[co]
317 %attr(755,root,root) %{mxdir}/DateTime/mxDateTime/*.so
318
319 %files -n python-mx-DateTime-devel
320 %defattr(644,root,root,755)
321 %{py_incdir}/mx/mxDateTime.h
322
323 %files -n python-mx-TextTools
324 %defattr(644,root,root,755)
325 %doc mx/TextTools/Doc/*.html
326 %dir %{mxdir}/TextTools
327 %{mxdir}/TextTools/*.py[co]
328
329 %dir %{mxdir}/TextTools/mxTextTools
330 %{mxdir}/TextTools/mxTextTools/*.py[co]
331 %attr(755,root,root) %{mxdir}/TextTools/mxTextTools/*.so
332
333 %dir %{mxdir}/TextTools/Constants
334 %{mxdir}/TextTools/Constants/*.py[co]
335
336 %files -n python-mx-Stack
337 %defattr(644,root,root,755)
338 %doc mx/Stack/Doc/*.html
339 %dir %{mxdir}/Stack
340 %{mxdir}/Stack/*.py[co]
341
342 %dir %{mxdir}/Stack/mxStack
343 %{mxdir}/Stack/mxStack/*.py[co]
344 %attr(755,root,root) %{mxdir}/Stack/mxStack/*.so
345
346 %files -n python-mx-Queue
347 %defattr(644,root,root,755)
348 %doc mx/Queue/Doc/*.html
349 %dir %{mxdir}/Queue
350 %{mxdir}/Queue/*.py[co]
351
352 %dir %{mxdir}/Queue/mxQueue
353 %{mxdir}/Queue/mxQueue/*.py[co]
354 %attr(755,root,root) %{mxdir}/Queue/mxQueue/*.so
355
356 %files -n python-mx-Tools
357 %defattr(644,root,root,755)
358 %doc mx/Tools/Doc/*.html
359 %dir %{mxdir}/Tools
360 %{mxdir}/Tools/*.py[co]
361
362 %dir %{mxdir}/Tools/mxTools
363 %{mxdir}/Tools/mxTools/*.py[co]
364 %attr(755,root,root) %{mxdir}/Tools/mxTools/*.so
365
366 %files -n python-mx-Proxy
367 %defattr(644,root,root,755)
368 %doc mx/Proxy/Doc/*.html
369 %dir %{mxdir}/Proxy
370 %{mxdir}/Proxy/*.py[co]
371
372 %dir %{mxdir}/Proxy/mxProxy
373 %{mxdir}/Proxy/mxProxy/*.py[co]
374 %attr(755,root,root) %{mxdir}/Proxy/mxProxy/*.so
375
376 %files -n python-mx-BeeBase
377 %defattr(644,root,root,755)
378 %doc mx/BeeBase/Doc/*.html
379 %dir %{mxdir}/BeeBase
380 %{mxdir}/BeeBase/*.py[co]
381
382 %dir %{mxdir}/BeeBase/mxBeeBase
383 %{mxdir}/BeeBase/mxBeeBase/*.py[co]
384 %attr(755,root,root) %{mxdir}/BeeBase/mxBeeBase/*.so
This page took 0.178913 seconds and 4 git commands to generate.